Benutzer werden unerwartet von einer windows-authentifizierten Datenbank in Microsoft Dynamics SL 2011 aufgefordert, ein Kennwort einzugeben.

Dieser Artikel enthält Methoden zum Beheben des Problems, dass Benutzer unerwartet zur Eingabe eines Kennworts aufgefordert werden, wenn sie sich nach einem Upgrade bei einer windows-authentifizierten Datenbank in Microsoft Dynamics SL 2011 anmelden.

Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 2550383

Problembeschreibung

Benutzer werden zur Eingabe eines Kennworts aufgefordert, wenn sie sich bei einer windows-authentifizierten Datenbank in Microsoft Dynamics SL 2011 anmelden, nachdem das System von einer früheren Version von Microsoft Dynamics SL aktualisiert wurde.

Ursache

Dieses Verhalten tritt auf, weil in Microsoft Dynamics SL 2011 ein neues Feature hinzugefügt wurde, das optional die Eingabe eines Kennworts erfordert, wenn sich Benutzer anmelden, auch wenn die Windows-Authentifizierung verwendet wird. Wenn eine Datenbank, die zuvor die SQL-Authentifizierung verwendet hat, aktualisiert wird, wird das Kennwort jedes Benutzers beibehalten und muss eingegeben werden, wenn sich der Benutzer bei Microsoft Dynamics SL 2011 anmeldet.

Lösung

Wenn Sie die Eingabe eines Kennworts für eine authentifizierte Windows-Datenbank nicht anfordern möchten, entfernen Sie den Wert aus dem Feld Kennwort auf dem Bildschirm Benutzerwartung (95.260.00) für alle Benutzer mit Ausnahme des Sysadmin-Benutzers. Wenden Sie hierzu eine der folgenden Methoden an.

Methode 1

  1. Melden Sie sich bei Microsoft Dynamics SL als SYSADMIN-Benutzer an.
  2. Öffnen Sie unter der Modulgruppe Verwaltung den Bildschirm Benutzerwartung (95.260.00).
  3. Wählen Sie im Feld Benutzer-ID eine Benutzer-ID aus.
  4. Löschen Sie den Wert aus dem Kennwortfeld .
  5. Speichern Sie diese Option, und wiederholen Sie sie dann für jeden Benutzer.

Methode 2

Hinweis

Bevor Sie die Anweisungen in diesem Abschnitt befolgen, stellen Sie sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie wiederherstellen können, wenn ein Problem auftritt.

  1. Melden Sie alle Benutzer von der Microsoft Dynamics SL-Datenbank ab.

  2. Führen Sie die folgende SQL-Anweisung in Microsoft SQL Server Management Studio für Ihre Microsoft Dynamics SL 2011 System-Datenbank aus, um die Kennwörter für alle Benutzer mit Ausnahme von Sysadmin zu entfernen:

    update userrec set Password = '' where UserId not like ('SYSADMIN')
    

Weitere Informationen

Weitere Informationen finden Sie im Thema Microsoft Dynamics SL-Anmeldung im Abschnitt Referenz der Hilfe zu Microsoft Dynamics SL 2011 oder im Benutzerhandbuch.