Fehler beim Importieren von SavedQuery in Microsoft Dynamics 365
Dieser Artikel enthält eine Lösung für die Fehlermeldungen, die Sie möglicherweise erhalten, wenn Sie versuchen, eine Lösung in Microsoft Dynamics 365 zu importieren.
Gilt für: Microsoft Dynamics 365 Customer Engagement Online
Ursprüngliche KB-Nummer: 4496853
Problembeschreibung
Beim Versuch, eine Lösung in Microsoft Dynamics 365 zu importieren, tritt der folgende Fehler auf:
Fehler beim Import der Lösung : [Lösungsname].
Fehlercode 8004f016
Das Raster im Fehlerdialogfeld enthält eine Zeile mit Typ = Systemansichten. Der für diese Zeile angezeigte Detailtext ist die folgende Meldung:
Eine verwaltete Lösung kann eine SavedQuery-Komponente auf dem Zielsystem mit einer nicht verwalteten Basisinstanz nicht überschreiben. Das wahrscheinlichste Szenario für diesen Fehler ist, dass eine nicht verwaltete Lösung eine neue nicht verwaltete SavedQuery-Komponente auf dem Zielsystem installiert hat und nun eine verwaltete Lösung aus demselben Herausgeber versucht, dieselbe SavedQuery-Komponente wie verwaltet zu installieren. Dies führt zu einer ungültigen Schichtung von Lösungen auf dem Zielsystem und ist nicht zulässig.
Laden Sie die XML-Protokolldatei herunter, und öffnen Sie sie in Excel. Suchen Sie auf der Registerkarte "Komponenten " die Folgendes: 0x8004F016.
In der nächsten Spalte wird eine Fehlermeldung angezeigt, die die ID der Komponente enthält:
Eine verwaltete Lösung kann die SavedQuery-Komponente nicht mit id=[Component Id] überschreiben, die über eine nicht verwaltete Basisinstanz verfügt. Das wahrscheinlichste Szenario für diesen Fehler ist, dass eine nicht verwaltete Lösung eine neue nicht verwaltete SavedQuery-Komponente auf dem Zielsystem installiert hat und nun eine verwaltete Lösung aus demselben Herausgeber versucht, dieselbe SavedQuery-Komponente wie verwaltet zu installieren. Dies führt zu einer ungültigen Schichtung von Lösungen auf dem Zielsystem und ist nicht zulässig.
Ursache
Wie in den Fehlerdetails erwähnt, besteht das wahrscheinlichste Szenario für diesen Fehler darin, dass eine nicht verwaltete Anpassung an der Standardlösung in der Zielorganisation vorgenommen wurde. Dies führt zu einer ungültigen Schichtung von Lösungen auf dem Zielsystem und ist nicht zulässig.
Beispiel: Ihre Microsoft Dynamics 365-Instanz verfügt bereits über eine Komponente wie eine benutzerdefinierte gespeicherte Abfrage, die durch importieren einer nicht verwalteten Lösung erstellt wurde. Wenn Sie später versuchen, eine verwaltete Lösung mit derselben gespeicherten Abfrage zu importieren, tritt dieser Fehler auf.
Lösung
Für die gespeicherte Abfrage kann die verwaltete Komponente mit einer Web-API-Abfrage gefunden und dann im Ziel gelöscht werden:
Öffnen Sie einen Browser für Ihre Organisation, und duplizieren Sie dann die Registerkarte.
Ersetzen Sie die [GUID aus Fehler] durch die GUID aus der Fehlermeldung aus der Protokolldatei, und fügen Sie sie dann an Ihre Organisation an:
api/data/v9.1/savedqueries?$filter=savedqueryid eq '[GUID from Error]'
Beispiel:
https://MyOrganization.crm11.dynamics.com/api/data/v9.1/savedqueries?$filter=savedqueryid eq '1d0f4d57-6d49-e911-a98d-00224800ce20'
Dies ist die Ausgabe:
{ "@odata.etag": "W/\"5792499\"", "returnedtypecode": "css_testsqparent", "statecode": 0, "layoutxml": "<grid name=\"resultset\" icon=\"1\" preview=\"1\" select=\"1\" jump=\"css_name\" object=\"10224\"><row id=\"css_testsqparentid\" name=\"result\"><cell name=\"css_name\" width=\"150\" /> <cell name=\"css_testsqfield\" width=\"100\" /></row></grid>", "savedqueryid": "1d0f4d57-6d49-e911-a98d-00224800ce20", "description": "View to trigger 8004F016 named ", "createdon": "DateTime", "savedqueryidunique": "bdab33b7-18d0-45d6-9db9-6111afc1e444", "fetchxml": "<fetch mapping=\"logical\" output-format=\"xml-platform\" version=\"1.0\"><entity name=\"css_testsqparent\"><attribute name=\"css_name\" /><order descending=\"false\" attribute=\"css_name\" /><attribute name=\"css_testsqfield\" /><attribute name=\"css_testsqparentid\" /></entity></fetch>", "isuserdefined": true, "name": "TestSQView","isdefault": false, "solutionid": "fd140aae-4df4-11dd-bd17-0019b9312238", "ismanaged": false, "versionnumber": 5792499, "introducedversion": "1.1.0.0", "querytype": 0, "statuscode": 1, "_modifiedby_value": "ba7ca8f4-5a68-4221-821c-5ca91b5f54ad", "modifiedon": "DateTime",
Um diese Komponente in der Zielorganisation zu finden, navigieren Sie zu Einstellungen>Anpassungen>Anpassen des Systems.
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Suchen Sie die Entität, bei der es sich um den Rückgabecode in der Abfrageausgabe handelt.
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Suchen Sie den Namen, der dem Namen in der Abfrageausgabe entspricht.
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