In Microsoft Dynamics 365 wird die Fehlermeldung "Die [Lösungsname]-Lösung verfügt nicht über ein Upgrade, das angewendet werden kann.
Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie eine Lösung in Dynamics 365 auswählen und dann die Schaltfläche " Lösungsupgrade anwenden " auswählen.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4457858
Problembeschreibung
Wenn Sie eine Lösung in Dynamics 365 auswählen und dann die Schaltfläche " Lösungsupgrade anwenden " auswählen, wird die folgende Fehlermeldung angezeigt:
"Aktion nicht verfügbar.
Die Lösung [Lösungsname] verfügt nicht über ein Upgrade, das zur Anwendung bereit ist."
Wenn Sie "Protokolldatei herunterladen" auswählen, enthält die Protokolldatei einen Verweis auf den Fehlercode "-2147187397".
Ursache
Diese Meldung wird angezeigt, wenn für die ausgewählte Lösung kein Lösungsupgrade angewendet werden muss.
Die Schaltfläche " Lösungsupgrade anwenden " soll verwendet werden, wenn Sie ein Update für eine andere Lösung importiert haben, die bereits installiert ist. Beim Importieren der aktualisierten Lösung wird eine Option "Stufe für Upgrade " angezeigt. Wenn dieses Kontrollkästchen aktiviert ist, wird die Upgradeaktion während des Lösungsimports nicht ausgeführt. Am Ende des Importvorgangs wird die Schaltfläche " Lösungsupgrade anwenden " angezeigt. Wenn Sie diese Schaltfläche nicht ausgewählt haben, finden Sie die übergeordnete Lösung in der Lösungsliste, und wählen Sie dann " Lösungsupgrade anwenden" aus.
Lösung
Verwenden Sie die Schaltfläche " Lösungsupgrade anwenden ", wenn Sie ein Update für eine bereits installierte Lösung importiert und die Option "Stufe für Upgrade " ausgewählt haben.