Management Reporter für Dynamics ERP Report Queue Status window stays stuck at Queued

Dieser Artikel enthält Lösungen für die Probleme, die dazu führen, dass das Fenster "Status der Berichtswarteschlange" in der Warteschlange hängen bleibt.

Gilt für: Microsoft Dynamics GP, Microsoft Dynamics AX 2009, Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 2298248

Problembeschreibung

Sie wählen die Schaltfläche "Generieren " in "Management Reporter für Dynamics ERP", aber im Fenster "Status der Berichtswarteschlange" wird der Status als "In der Warteschlange" und nicht als "Verarbeitung" aufgeführt.

Ursache

Es gibt sechs mögliche Ursachen für diesen Fehler:

Ursache 1

Wenn sich der Management Reporter Process Service auf demselben Computer wie der Computer befindet, auf dem Ihre ManagementReporter SQL-Datenbank gehostet wird. Möglicherweise ist beim Prozessdienst ein Fehler aufgetreten, indem versucht wurde, zu starten, bevor SQL Server Verbindungen akzeptierte. Siehe Resolution 1 im Abschnitt "Resolution".

Ursache 2

Ein SQL Server Verbindungsfehler ist aufgetreten, und der Management Reporter Process Service muss neu gestartet werden. Siehe Resolution 2 im Abschnitt "Resolution".

Ursache 3

Der Benutzer, der den Management Reporter Process Service ausführt, verfügt nicht über ausreichende Berechtigungen, um aus der ManagementReporter SQL Server Datenbank zu lesen. Siehe Resolution 3 im Abschnitt "Resolution".

Ursache 4

Der SQL-Dienstbroker für die ManagementReporter-SQL Server-Datenbank ist nicht aktiviert. Siehe Resolution 4 im Abschnitt "Resolution".

Ursache 5

Dies kann passieren, wenn der Besitzer der Management Reporter-Datenbank ein Windows-Benutzer ist, während der SQL Server-Dienst von einem lokalen Benutzer ausgeführt wird. Wenn Sie die Ereignisanzeige überprüfen, wird möglicherweise die folgende Meldung angezeigt:

Ausnahme beim Anheben einer Nachricht in der Zielwarteschlange. Fehler 15404, Zustand 19. Informationen zur Windows NT-Gruppe/dem Benutzer "Domäne\Benutzer" konnten nicht abgerufen werden. Fehlercode 0x5.

Siehe Resolution 5 im Abschnitt "Resolution".

Ursache 6

Dies kann passieren, wenn das Kontrollkästchen "Keine Anzahl" in den Servereigenschaften in SQL Server Management Studio aktiviert ist. Wenn Sie Ereignisanzeige nach dem Generieren eines Berichts überprüfen, wird möglicherweise die folgende Meldung angezeigt:

System.Data.Linq.ChangeConflictException: (Zeile nicht gefunden oder geändert) oder (in Assembly 'xxxxxx' ist nicht serialisierbar)

Siehe Resolution 6 im Abschnitt "Resolution".

Lösung

Lösung 1

Wenn Sie Windows Server 2008 verwenden, können Sie den Prozessdienst von Management Reporter auf "Automatisch" (verzögerter Start) statt auf "Automatisch" festlegen.

ODER

Starten Sie den Prozessdienst manuell oder mit einem Skript wie dem folgenden neu:

NET STOP MRProcessService

NET START MRProcessService

Lösung 2

Starten Sie den Prozessdienst manuell oder mit einem Skript wie dem folgenden neu:

NET STOP MRProcessService

NET START MRProcessService

Auflösung 3

Gewähren Sie dem Benutzer, der diesen Dienst ausführt, die Rolle "GeneralUser" unter der Datenbank "Management Reporter" in SQL Server. Dieser Benutzer befindet sich auf der Registerkarte " Anmelden " unter der Systemsteuerung der Dienste.

Auflösung 4

Führen Sie die folgende Anweisung auf dem SQL-Server aus, auf dem sich Ihre ManagementReporter-Datenbank befindet:

SELECT name, is_broker_enabled FROM sys.databases WHERE name = DB_NAME() AND is_broker_enabled = 1

Diese Anweisung sollte eine Zeile für die ManagementReporter-SQL Server-Datenbank zurückgeben. Führen Sie andernfalls die nachstehende Anweisung aus, um den SQL-Dienstbroker für die ManagementReporter-SQL Server-Datenbank erneut zu aktivieren:

ALTER DATABASE [ManagementReporter] SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE;

Auflösung 5

Ändern Sie den Datenbankbesitzer in "sa", oder ändern Sie den SQL Server Service-Benutzer in einen Domänenbenutzer.

Auflösung 6

Klicken Sie in SQL Server Management Studio mit der rechten Maustaste auf den Servernamen, und wählen Sie dann "Eigenschaften" aus. Wählen Sie "Verbindungen " aus, und scrollen Sie im Optionsabschnitt "Standardverbindungen " nach unten, und deaktivieren Sie "Keine Anzahl".