Verwaltungsreporter für Dynamics ERP: Warteschlangenstatusfenster bleibt in der Warteschlange hängen

Dieser Artikel enthält Lösungen für Probleme, die dazu führen, dass das Fenster Berichtswarteschlangenstatus in der Warteschlange hängen bleibt.

Gilt für: Microsoft Dynamics GP, Microsoft Dynamics AX 2009, Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 2298248

Symptome

Sie wählen die Schaltfläche Generieren in Management Reporter for Dynamics ERP aus, aber im Fenster Warteschlangenstatus melden wird der Status als In Warteschlange statt als Verarbeitung angezeigt.

Ursache

Es gibt sechs mögliche Ursachen für diesen Fehler:

Ursache 1

Wenn sich der Management Reporter-Prozessdienst auf demselben Computer wie der Computer befindet, auf dem Ihre ManagementReporter SQL-Datenbank gehostet wird. Der Prozessdienst hat möglicherweise einen Fehler verursacht, indem er versucht hat, zu starten, bevor SQL Server Verbindungen akzeptiert hat. Siehe Auflösung 1 im Abschnitt "Auflösung".

Ursache 2

Es ist ein SQL Server Verbindungsfehler aufgetreten, und der Management Reporter-Prozessdienst muss neu gestartet werden. Siehe Auflösung 2 im Abschnitt Auflösung.

Ursache 3

Der Benutzer, der den Management Reporter-Prozessdienst ausführt, verfügt nicht über ausreichende Berechtigungen zum Lesen aus der ManagementReporter-SQL Server Datenbank. Siehe Auflösung 3 im Abschnitt Auflösung.

Ursache 4

Der SQL Service Broker für die ManagementReporter-SQL Server Datenbank ist nicht aktiviert. Siehe Auflösung 4 im Abschnitt Auflösung.

Ursache 5

Dies kann passieren, wenn der Besitzer der Management Reporter-Datenbank ein Windows-Benutzer ist, während der SQL Server-Dienst von einem lokalen Benutzer ausgeführt wird. Wenn Sie die Ereignisanzeige überprüfen, wird möglicherweise die folgende Meldung angezeigt:

Beim Einreihen einer Nachricht in die Zielwarteschlange ist eine Ausnahme aufgetreten. Fehler 15404, Status 19. Es konnten keine Informationen zur Windows NT-Gruppe/zum Benutzer "Domäne\Benutzer" abgerufen werden, Fehlercode 0x5.

Siehe Auflösung 5 im Abschnitt Auflösung.

Ursache 6

Dies kann passieren, wenn das Kontrollkästchen Keine Anzahl in den Servereigenschaften in SQL Server Management Studio aktiviert ist. Wenn Sie nach dem Generieren eines Berichts Ereignisanzeige überprüfen, wird möglicherweise die folgende Meldung angezeigt:

System.Data.Linq.ChangeConflictException: (Zeile nicht gefunden oder geändert) oder (in Assembly 'xxxxxx' ist nicht als serialisierbar gekennzeichnet)

Siehe Auflösung 6 im Abschnitt Auflösung.

Lösung

Lösung 1

Wenn Sie Windows Server 2008 verwenden, können Sie den Verwaltungsreporterprozessdienst auf Automatisch (verzögerter Start) statt auf Automatisch festlegen.

ODER

Starten Sie den Prozessdienst manuell oder mit einem Skript wie dem folgenden neu:

NET STOP MRProcessService

NET START MRProcessService

Lösung 2

Starten Sie den Prozessdienst manuell oder mit einem Skript wie dem folgenden neu:

NET STOP MRProcessService

NET START MRProcessService

Lösung 3

Weisen Sie dem Benutzer, der diesen Dienst ausführt, die Rolle GeneralUser unter der Verwaltungsreporter-Datenbank in SQL Server zu. Dieser Benutzer befindet sich auf der Registerkarte Anmelden in der Systemsteuerung für Dienste.

Lösung 4

Führen Sie die folgende Anweisung auf dem SQL Server aus, auf dem sich Ihre ManagementReporter-Datenbank befindet:

SELECT name, is_broker_enabled FROM sys.databases WHERE name = DB_NAME() AND is_broker_enabled = 1

Diese Anweisung sollte eine Zeile für die Datenbank ManagementReporter SQL Server zurückgeben. Wenn dies nicht der Fall ist, führen Sie die folgende Anweisung aus, um sql Service Broker für die ManagementReporter-SQL Server-Datenbank erneut zu aktivieren:

ALTER DATABASE [ManagementReporter] SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE;

Lösung 5

Ändern Sie den Datenbankbesitzer in sa, oder ändern Sie den SQL Server-Dienstbenutzers in einen Domänenbenutzer.

Lösung 6

Klicken Sie SQL Server Management Studio mit der rechten Maustaste auf den Servernamen, und wählen Sie dann Eigenschaften aus. Wählen Sie Connections aus, und scrollen Sie im Abschnitt Standardverbindungen nach unten, und deaktivieren Sie keine Anzahl.