"Nicht geschlossenes Anführungszeichen nach der Zeichenfolge" Fehlermeldung beim Ausführen des veralteten Teststands für die Verwaltung von Kreditoren in Microsoft Dynamics GP

Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie den Verlauf des Teststandsberichts für die Kreditorenverwaltung ausführen.

Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 2580792

Symptome

Wenn Sie den Bericht über veraltete Testversionen für die Kreditorenverwaltung ausführen, erhalten Sie eine der folgenden Fehlermeldungen:

Fehlermeldung 1 (für Gutschrift)

[Microsoft] [ODBC SQL Server-Treiber][SQL Server]Zeile 1: Falsche Syntax in der Nähe von 'XXXXX'.[ Microsoft][ODBC SQL Server Driver][SQL Server]Nicht geschlossenes Anführungszeichen vor der Zeichenfolge ' und DocumentType=5'.

Fehlermeldung 2 (für Zahlung)

[Microsoft] [SQL Native Client][SQL Server]falsche Syntax in der Nähe von 'S'[Microsoft][SQL Native Client][SQL Server] Nicht geschlossenes Anführungszeichen nach der Zeichenfolge 'and DocumentType = 6'

Darauf folgt die folgende Meldung:

Das gespeicherte proc pmHistoricalAgedTrialBalance hat die folgenden Ergebnisse zurückgegeben: DBMS: 105, Microsoft Dynamics GP: 0

Ursache

Diese Fehler werden durch ein bekanntes Problem in Microsoft Dynamics GP verursacht, bei dem eine Gutschrift oder ein manuelles Zahlungsdokument mit einem Apostroph im Feld Gutscheinnummer eingegeben wird.

Lösung

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben:

Lösung 1

  1. Führen Sie dieses Skript in SQL für die Unternehmensdatenbank aus, um nach Gutscheinnummern, Dokumentnummern oder Anbieter-IDs mit einem einzelnen Apostroph zu suchen, das vom Prozess als nicht abgeschlossenes Angebot gelesen wird. Alle Ergebnisse für die Gutscheinnummer (CONTRLNUM) sind wahrscheinlich die Klausel, aber die Dokumentnummer und die Anbieter-ID werden ebenfalls zum Skript hinzugefügt und können ein Problem darstellen oder nicht:

    SELECT * FROM PM00400
    WHERE 
    CNTRLNUM LIKE '%''%' or 
    DOCNUMBR LIKE '%''%' or 
    VENDORID LIKE '%''%' 
    
  2. Führen Sie für alle Ergebnisse, die vom obigen Skript zurückgegeben werden, das Skript "ALL Payables" für jedes oben zurückgegebene Ergebnis aus. (Da das Problem mehr als wahrscheinlich eine Gutscheinnummer ist, da dies ein bearbeitbares Feld für den Benutzer ist. Überprüfen Sie Ihre Einrichtung für Die Zahlung, um sicherzustellen, dass Sie kein Apostroph in der nächsten Standardgutscheinnummer haben.)

    Hinweis

    Wenn Sie nicht über dieses Skript verfügen, können Sie einen Supportfall öffnen, um Unterstützung zu erhalten, um dieses Skript zu erhalten und alle Tabellen zu identifizieren, in denen sich dieses Dokument möglicherweise befindet.

  3. Korrigieren Sie manuell die Gutscheinnummer mit einer direkten "update"-Anweisung in SQL für alle Tabellen, die vom Skript "ALL Payables" zurückgegeben werden, um das einzelne Apostroph aus einer Gutscheinnummer und Dokumentnummer zu entfernen. Achten Sie darauf, dass das Feld in allen Feldern/Tabellen, in denen Sie es ändern, identisch ist. (Wenn das Problem mit der Anbieter-ID zusammenhingt, führen Sie diese Schritte nicht aus. Sie können das Anbietermodifizierertool in PSTL verwenden, um eine Anbieter-ID zu ändern.)

Wenn Sie Hilfe benötigen, können Sie einen Supportfall für weitere Unterstützung eröffnen. Um den Kundendienst telefonisch zu erreichen, rufen Sie 888-477-7877 an.

Weitere Informationen

Um dieses Problem in Zukunft zu verhindern, können Sie das Feld Gutscheinnummer sperren, um zu verhindern, dass Benutzer die Gutscheinnummer ändern können. Führen Sie dazu die folgenden Schritte aus:

  1. Wählen Sie Microsoft Dynamics GP und dann Microsoft DynamicsGP-Tools>>Kaufzahlungen>einrichten> aus.

  2. Heben Sie die Markierung der Option Gutscheinnummer bei Transaktionseintrag außer Kraft , und wählen Sie dann OK aus.