Fehlermeldung "Nicht eingeschlossenes Anführungszeichen nach der Zeichenfolge" beim Ausführen des Historischen Testsaldos für die Kreditorenverwaltung in Microsoft Dynamics GP
Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie den Testsaldobericht für historische Altersalter für die Kreditverwaltung ausführen.
Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 2580792
Problembeschreibung
Wenn Sie den Testsaldobericht für Fälligkeitsmanagement (Historical Aged Trial Balance) für das Kreditverwaltungswesen ausführen, erhalten Sie eine der folgenden Fehlermeldungen:
Fehlermeldung 1 (für Gutschrift)
[Microsoft] [ODBC SQL Server Driver][SQL Server]Zeile 1: Falsche Syntax in der Nähe von 'XXXXX'.[ Microsoft][ODBC SQL Server Driver][SQL Server]Unclosed quotation mark before the character string ' and DocumentType=5'.
Fehlermeldung 2 (zur Zahlung)
[Microsoft] [SQL Native Client][SQL Server]falsche Syntax in der Nähe von 'S'[Microsoft][SQL Native Client][SQL Server] Nicht eingeschlossenes Anführungszeichen nach der Zeichenfolge 'and DocumentType = 6'
Es folgt die folgende Meldung:
Die gespeicherte Proc pmHistoricalAgedTrialBalance hat die folgenden Ergebnisse zurückgegeben: DBMS: 105, Microsoft Dynamics GP: 0
Ursache
Diese Fehler werden durch ein bekanntes Problem in Microsoft Dynamics GP verursacht, bei dem eine Gutschrift oder ein manuelles Zahlungsdokument mit einem Apostroph im Feld "Gutscheinnummer " eingegeben wird.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben:
Lösung 1
Führen Sie dieses Skript in SQL für die Unternehmensdatenbank aus, um nach einer beliebigen Gutscheinnummer, Dokumentnummer oder Lieferanten-ID mit einem einzigen Apostroph darin zu suchen, das vom Prozess als nicht eingeschlossenes Angebot gelesen wird. Alle Ergebnisse für die Gutscheinnummer (CONTRLNUM) sind wahrscheinlich die Klausel, aber die Dokumentnummer und die Lieferanten-ID werden ebenfalls dem Skript hinzugefügt und können ein Problem sein oder nicht:
SELECT * FROM PM00400 WHERE CNTRLNUM LIKE '%''%' or DOCNUMBR LIKE '%''%' or VENDORID LIKE '%''%'
Führen Sie für alle Ergebnisse, die vom obigen Skript zurückgegeben werden, das Skript "ALLE Verbindlichkeiten" für jedes oben zurückgegebene Ergebnis aus. (Da das Problem mehr als wahrscheinlich eine Gutscheinnummer ist, da dies ein bearbeitbares Feld für den Benutzer ist. Überprüfen Sie Ihre Kreditoreneinrichtung, um sicherzustellen, dass sie kein Apostroph in der standardmäßigen nächsten Gutscheinnummer haben.)
Hinweis
Wenn Sie nicht über dieses Skript verfügen, möchten Sie möglicherweise einen Supportfall für Unterstützung öffnen, um dieses Skript abzurufen und alle Tabellen zu identifizieren, in denen sich dieses Dokument möglicherweise befindet.
Korrigieren Sie die Gutscheinnummer manuell mit einer direkten "Update"-Anweisung in SQL für alle Tabellen, die vom Skript "ALLE Verbindlichkeiten" zurückgegeben werden, um das einzelne Apostroph aus einer Gutscheinnummer und dokumentnummer zu entfernen. Achten Sie darauf, dass Sie das Feld so schreiben, dass es in allen Feldern/Tabellen, in denen Sie es ändern, identisch ist. (Wenn das Problem mit der Anbieter-ID auftritt, führen Sie diese Schritte nicht aus. Sie können das Anbietermodifizierer-Tool in PSTL verwenden, um eine Lieferanten-ID zu ändern.)
Wenn Sie Unterstützung benötigen, können Sie einen Supportfall für weitere Unterstützung öffnen. Um den Kundendienst telefonisch zu erreichen, rufen Sie 888-477-7877 an.
Weitere Informationen
Um zu verhindern, dass dieses Problem in Zukunft auftritt, können Sie das Feld "Gutscheinnummer " sperren, um zu verhindern, dass Benutzer die Gutscheinnummer ändern. Führen Sie dazu die folgenden Schritte aus:
Wählen Sie Microsoft Dynamics GP und dann Microsoft Dynamics GP>Tools>Setup>Purchasing>Payables aus.
Heben Sie die Markierung der Option "Gutscheinnummer bei Transaktionseintrag überschreiben" auf , und wählen Sie dann "OK" aus.