Fehler, wenn ein Benutzer zertifikatsbasierte Zertifizierungsstellen-Webregistrierungsseiten anfordert: Es konnten keine Zertifikatvorlagen gefunden werden.

Dieser Artikel enthält Hilfe zum Beheben des Fehlers "Es wurden keine Zertifikatvorlagen gefunden", der auftritt, wenn Sie Zertifikate von Ca-Webregistrierungsseiten anfordern.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 811418

Problembeschreibung

Wenn ein Benutzer versucht, ein Zertifikat von den Websiteregistrierungsseiten der Zertifizierungsstelle (Ca) anzufordern, erhält der Benutzer möglicherweise die folgende Fehlermeldung:

Es wurden keine Zertifikatvorlagen gefunden. Sie sind nicht berechtigt, ein Zertifikat von dieser Zertifizierungsstelle anzufordern, oder beim Zugriff auf Active Directory ist ein Fehler aufgetreten.

Dieses Verhalten tritt auf, wenn sich die Webregistrierungsseiten in einer Active Directory-Domäne auf einem Enterprise CA-Server befinden. Es tritt auf, ob sich die Webregistrierungsseiten auf demselben Server oder auf einem anderen Mitgliedsserver befinden.

Ursache

Auf den Websiteregistrierungsseiten der Zertifizierungsstelle wird ein Vergleich zweier Werte unter Beachtung der Groß-/Kleinschreibung durchgeführt. Ein Wert ist der sServerConfig-Wert in der Datei "Certdat.inc" im %systemroot%\System32\Certsrv Ordner auf dem Zertifikatserver, und der andere Wert ist das attribut "dnsHostName " für das pkiEnrollmentService-Objekt in Active Directory. Wenn die beiden Zeichenfolgen nicht übereinstimmen, einschließlich der Groß-/Kleinschreibung, schlägt die Registrierung fehl.

Lösung

Führen Sie die folgenden Schritte aus, um dieses Verhalten zu korrigieren:

  1. Anzeigen des Active Directory dNSHostName-Attributs für das pkiEnrollmentService-Objekt . Dieses Objekt befindet sich an der folgenden Stelle:

    CN= CertificateServer,CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC= MyDomain,DC=com

    Verwenden Sie zum Anzeigen des dNSHostName-Attributs ADSIEdit.msc oder LDP.exe.

  2. Bearbeiten Sie die Datei "Certdat.inc", sodass der Wert für "sServerConfig" mit dem Wert für das Attribut "dNSHostName" gefolgt vom Namen der Zertifizierungsstelle identisch ist.

    Hinweis

    Der sServerConfig-Wert muss genau so groß sein wie das dNSHostName-Attribut. Wenn dies nicht zutrifft, erhalten Sie weiterhin denselben Fehler.

  3. Wenn beispielsweise der DNS-Hostname für die Zertifizierungsstelle "server1.domain.local " und der Name der Zertifizierungsstelle "MYCA" lautet, stellen Sie dann sicher, dass das dNSHostName-Attribut für CN=MYCA,CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC= Domain,DC=local object auf server1.domain.local und sServerConfig in der Datei "certdat.inc" im %systemroot%\system32\certsrv Ordner der Zertifizierungsstelle auf "server1.domain.local\MYCA" festgelegt sein sollte. .

  4. Bitten Sie den Benutzer, das Zertifikat anzufordern, Internet Explorer neu zu starten. Dadurch können die neuen Anmeldeinformationen an die Zertifizierungsstelle übergeben werden.

    Hinweis

    Stellen Sie außerdem sicher, dass dem Benutzer Lese- und Registrierungsberechtigungen für die Zertifikatvorlage erteilt werden, die der Benutzer anfordert. Sie können diese Berechtigungen entweder mithilfe des ADSIEdit-Snap-Ins oder des Zertifikatvorlagen-Snap-Ins erteilen.