Teilen über


Szenario: Timeouts mit dem Befehl „hbase hbck“ in Azure HDInsight

In diesem Artikel werden Schritte zur Problembehandlung und mögliche Lösungen für Probleme bei der Interaktion mit Azure HDInsight-Clustern beschrieben.

Problem

Timeouts mit dem Befehl hbase hbck beim Korrigieren von Regionszuweisungen.

Ursache

Eine mögliche Ursache für Timeoutprobleme beim Verwenden des Befehls hbck kann darin bestehen, dass sich verschiedene Regionen über einen langen Zeitraum im „Übergangszustand“ befinden. Diese Regionen werden in der HBase-Master-Benutzeroberfläche als offline angezeigt. Aufgrund der großen Anzahl von Regionen, die den Übergang versuchen, könnte ein HBase Master-Timeout aufgetreten sein, sodass HBase Master diese Regionen nicht wieder online schalten kann.

Lösung

  1. Melden Sie sich mithilfe von SSH beim HDInsight-HBase-Cluster an.

  2. Führen Sie den Befehl hbase zkcli aus, um eine Verbindung mit der Apache ZooKeeper-Shell herzustellen.

  3. Führen Sie den Befehl rmr /hbase/regions-in-transition oder rmr /hbase-unsecure/regions-in-transition aus.

  4. Verwenden Sie den Befehl exit, um die Shell hbase zkcli zu beenden.

  5. Starten Sie den Active HBase Master-Dienst aus der Apache Ambari-Benutzeroberfläche neu.

  6. Führen Sie den Befehl hbase hbck -fixAssignments aus.

  7. Überwachen Sie auf der HBase Master-Benutzeroberfläche den Abschnitt mit den Regionen, für die ein Übergang vorgesehen ist, um sich zu vergewissern, dass keine Region hängen bleibt.

Nächste Schritte

Wenn Ihr Problem nicht aufgeführt ist oder Sie es nicht lösen können, besuchen Sie einen der folgenden Kanäle, um weitere Unterstützung zu erhalten:

  • Nutzen Sie den Azure-Communitysupport, um Antworten von Azure-Experten zu erhalten.

  • Setzen Sie sich mit @AzureSupport in Verbindung, dem offiziellen Microsoft Azure-Konto zum Verbessern der Kundenfreundlichkeit. Verbinden der Azure-Community mit den richtigen Ressourcen: Antworten, Support und Experten.

  • Sollten Sie weitere Unterstützung benötigen, senden Sie eine Supportanfrage über das Azure-Portal. Wählen Sie dazu auf der Menüleiste die Option Support aus, oder öffnen Sie den Hub Hilfe und Support. Ausführlichere Informationen hierzu finden Sie unter Erstellen einer Azure-Supportanfrage. Zugang zu Abonnementverwaltung und Abrechnungssupport ist in Ihrem Microsoft Azure-Abonnement enthalten. Technischer Support wird über einen Azure-Supportplan bereitgestellt.