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Behandeln von Konnektivitätsproblemen mit Azure Lab Services

Dieser Artikel enthält Informationen zur Behandlung allgemeiner Konnektivitätsprobleme mit Azure Lab Services.

Wichtig

Azure Lab Services ist ein verwaltetes Angebot, bei dem einige der zugrunde liegenden Ressourcen für ein Lab nicht direkt zugänglich sind. Dies führt dazu, dass andere Anleitungen zur Behandlung von Problemen mit virtuellen Azure-Computern wie etwa Behandeln von Problemen bei Remotedesktopverbindungen mit einem virtuellen Azure-Computer möglicherweise nicht wie beschrieben verwendet werden können.

Langsame Verbindung

Problembeschreibung

  • Langsame RDP-Verbindung (Remotedesktopprotokoll)

Ursachen

  • Spezifischer virtueller Lab-Computer
  • VPN-Verwendung
  • Firewall im Netzwerk
  • Spezifischer Internetdienstanbieter (Internet Service Provider, ISP)

Lösung

  • Quantifizieren der RDP-Verbindungsgeschwindigkeit

    Das Hilfsprogramm PsPing kann verwendet werden, um die Antwortzeit für den Computer zu messen. Eine entsprechende Anleitung finden Sie im Blog Sicherstellen der besten RDP-Erfahrung für Lab-Benutzer.

  • Ermitteln des Umfangs des Problems:

    • Ist ein bestimmter Computer betroffen?
    • Wird ein VPN verwendet?
    • Ist die Verbindung in einem bestimmten Netzwerk langsam?
    • Gibt es eine Firewall im Netzwerk?
    • Ist die Verbindung bei einem bestimmten ISP langsam?
Bestimmter Computer

Passen Sie die Einstellungen in der Clientumgebung an, um den Umfang der übertragenen Daten zu reduzieren.

VPN-Verwendung

Ein guter Schritt zur Problembehandlung besteht darin, das VPN zu deaktivieren, um festzustellen, ob sich dadurch die Verbindungsgeschwindigkeit verbessert. Wenn das Problem mit dem VPN zusammenhängt und das VPN erforderlich ist, überprüfen Sie in den VPN-Einstellungen und in der Konfiguration, ob RDP- oder SSH-Verbindungen ggf. „durchgeschleust“ werden können oder ob Verbindungen falsch oder nicht an entfernte Regionen weitergeleitet werden.

Bestimmtes Netzwerk oder Firewall

Ein Netzwerk kann sich auf die Konnektivität mit Azure Lab Services auswirken – von einem Netzwerk auf Unternehmensebene bis hin zur Kombination aus Heimrouter/WLAN von Lernenden. So kann es beispielsweise sein, dass Heimrouter von Lernenden über integrierte Firewalls verfügen, die RDP- bzw. SSH-Verbindungen blockieren oder einschränken. Überprüfen Sie, ob im Netzwerk eine Firewall aktiviert ist und ob sie so konfiguriert ist, dass RDP- bzw. SSH-Verbindungen eingeschränkt werden.

Spezifischer Internetdienstanbieter (Internet Service Provider, ISP)

Es ist nicht üblich, dass eine Verbindung mit mehreren ISPs hergestellt wird. Wenn die Verlangsamung in einem bestimmten Netzwerk auftritt und andere Optionen untersucht wurden, können Sie sich an Ihren ISP wenden, um zu ermitteln, ob Einschränkungen für RDP- bzw. SSH-Verbindungen vorhanden sind.

Keine Verbindung mit dem Remotecomputer möglich

Problembeschreibung

  • Lernende erhalten die Meldung „Remotedesktop kann aus einem dieser Gründe keine Verbindung mit dem Remotecomputer herstellen: (...) Stellen Sie sicher, dass der Remotecomputer eingeschaltet und mit dem Netzwerk verbunden ist und dass der Remotezugriff aktiviert ist.“

    Modal for Remote Desktop Connection that shows an error stating that 'Remote Desktop can't connect to the remote computer … Make sure the remote computer is turned on and connected to the network, and that remote access is enabled'

Ursachen

  • Der virtuelle Computer, mit dem die Lernenden eine Verbindung herstellen möchten, wird nicht ausgeführt.
  • Der virtuelle Lab-Computer startet möglicherweise noch.
  • Leerlaufeinstellungen können sich auf Verbindungen mit virtuellen Lab-Computern auswirken.

Lösung

Öffnen Sie das Lab-Portal, und überprüfen Sie, ob der virtuelle Computer als ausgeführt angezeigt wird. Wird er nicht ausgeführt, können Lernende den virtuellen Computer über das Lab-Portal starten. Es kann zwischen zwei und fünf Minuten dauern, bis der Computer vollständig ausgeführt wird.

Die Verbindung der Lernenden lässt sich ggf. durch Anpassen der Einstellungen für das automatische Herunterfahren von Labs verbessern. Da das Aktivieren und Deaktivieren des virtuellen Computers Zeit in Anspruch nimmt, kann das Anpassen der Einstellungen die Wahrscheinlichkeit verringern, dass Lernende versuchen, eine Verbindung herzustellen, während sich der Zustand des Computers ändert. Die Einstellungen für das automatische Herunterfahren sind Teil einer Kosteneinsparungsstrategie, aber sie müssen möglicherweise angepasst werden, um die Benutzerfreundlichkeit zu verbessern.

  • Herunterfahren von virtuellen Computern im Leerlauf: Ist die Dauer zu kurz, reicht möglicherweise die Zeit nicht aus, wenn Lernende den Computer starten und dann eine Verbindung herstellen. Außerdem kann es vorkommen, dass der virtuelle Computer heruntergefahren wird, wenn Lernende nicht aktiv sind (z. B. im Unterricht).
  • VMs bei Trennen der Benutzerverbindung herunterfahren: Bei einer zu geringen Zeitverzögerung können Probleme auftreten, wenn eine versehentliche Trennung der Verbindung dazu führt, dass der Computer heruntergefahren wird. In diesem Fall müssen Lernende den virtuellen Computer erneut starten, um eine Verbindung herzustellen.
  • Herunterfahren virtueller Computer, wenn Benutzer keine Verbindung herstellen: Wenn Lernende nicht innerhalb einer gewissen Zeit eine Verbindung mit dem virtuellen Computer herstellen und die Dauer zu kurz ist, wird der virtuelle Computer heruntergefahren. Die Zeiteinstellung kann sich auf das Starten des virtuellen Computers durch Lernende auswirken oder problematisch sein, wenn im Lab Zeitpläne verwendet werden. Das Ändern der Inaktivitätseinstellung auf einen längeren Zeitraum ist eine Option, hat aber potenzielle Auswirkungen auf die Kosten. Bei Einsatz von Zeitplänen können die virtuellen Computer näher am Zeitpunkt des Kursbeginns gestartet werden.

Eingeschränkte ausgehende Verbindung

Problembeschreibung

  • Das Netzwerk kann ein Störfaktor sein, wenn RDP- bzw. SSH-Ports (3389 bzw. 22) durch Firewalls, Switches, Router oder andere Netzwerkappliances blockiert oder eingeschränkt werden.

Ursachen

  • Lokale Firewall einer Schule, einer Universität, eines Unternehmens oder eines Heimnetzwerk, die ausgehende RDP- bzw. SSH-Verbindungen einschränkt
  • Von modernen Routern (insbesondere mit WLAN 6) werden RDP- bzw. SSH-Verbindungen standardmäßig blockiert oder eingeschränkt.
  • Einschränkung von ausgehender RDP- bzw. SSH-Konnektivität durch das Betriebssystem

Lösung

Erwägen Sie, die RDP- bzw. SSH-Einschränkung zu entfernen oder eine Ausnahme für die öffentliche IP-Adresse des Labs hinzuzufügen. Diese kann der Positivliste für die Firewall oder den Router hinzugefügt werden.

Problem mit der Lab-Verbindung nach Administratoränderung

Problembeschreibung

  • Lernende sind Personen mit Administratorrechten für ihren jeweiligen virtuellen Lab-Computer und können dort Systemänderungen vornehmen, was auch Änderungen an der Netzwerkkonfiguration einschließt.

Ursachen

  • Aktualisieren der IP-Adresse auf eine statische IP, statt sie als dynamische IP anzugeben
  • Deaktivieren von DCHP (was das automatische Abrufen einer IP-Adresse verhindert)
  • Angeben von DNS-Servern
  • Aktualisieren lokaler Benutzergruppen und Berechtigungen

Lösung

Eine Lab-Vorlage kann mit einem Skript zum automatischen Zurücksetzen des Netzwerks beim Herunterfahren des Computers eingerichtet werden. Andernfalls müssten Lernende oder Lehrkräfte ein Reimaging für den virtuellen Lab-Computer durchführen, um wieder einen ordnungsgemäßen Zustand herzustellen.

Wenn benutzerdefiniertes DNS erforderlich ist, verwenden Sie Erweitertes Networking, und geben Sie benutzerdefinierte DNS-Server im virtuellen Netzwerk an.

Verbindung des virtuellen Lab-Computers über ausgehendes VPN nicht möglich

Problembeschreibung

  • Lernende versuchen, von ihrem virtuellen Computer aus eine VPN-Verbindung herzustellen, die Verbindung kann aber nicht hergestellt werden.

Ursachen

  • Das VPN hat Probleme mit der Azure Lab Services-Netzwerkkonfiguration.

Lösung

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support.

Wenn Sie eine Azure-Supportanfrage erstellen, geben Sie die folgenden Informationen in den Anforderungsdetails an, um die Problembehebung zu beschleunigen:

  • ID des Lab-Plans. Wählen Sie den Lab-Plan im Azure-Portal aus, und navigieren Sie zur Seite Eigenschaften.
  • Die Lab-ID. Wählen Sie das Lab im Azure-Portal aus, und navigieren Sie zur Seite Eigenschaften. Wählen Sie alternativ die URL des Labs auf der Azure Lab Services-Websiteaus.
  • Ungefährer Zeitpunkt, zu dem die Probleme aufgetreten sind.
  • Alle ggf. im Azure-Aktivitätsprotokoll aufgeführten Fehler. Wählen Sie den Lab-Plan oder das Lab im Azure-Portal aus, und navigieren Sie zur Seite Aktivitätsprotokoll. Informationen zum Anzeigen und Herunterladen des Aktivitätsprotokolls finden Sie hier.

Nach der Bereitstellung keine Verbindung mit dem virtuellen Lab-Computer möglich

Problembeschreibung

  • Im Falle eines Lab-Fehlers funktionieren die Computerverbindungen möglicherweise nicht ordnungsgemäß.

Ursachen

  • Das Azure-Aktivitätsprotokoll ist die umfassendste Liste mit Ereignissen und Ergebnissen.

Lösung

Das Aktivitätsprotokoll kann nach der Ressourcengruppe gefiltert werden, in der sich das Lab befindet. Es kann einige Minuten dauern, bis die Ereignisse im Protokoll verfügbar sind. Diese Ereignisprotokolle enthalten detailliertere Informationen, die zur Problembehandlung verwendet werden können, und sollten mit angegeben werden, wenn ein Supportticket erstellt werden muss.

Anmeldung mit Benutzername und Kennwort nicht möglich

Problembeschreibung

  • Verbindungsherstellung mit dem virtuellen Lab-Computer mit Benutzername und Kennwort nicht möglich
  • Fehlermeldung: „Mit den Anmeldeinformationen konnte keine Verbindung hergestellt werden“

Ursachen

  • Lernende verwenden falsche Anmeldeinformationen.
  • Lernende haben ihr Kennwort vergessen.
  • Dem Azure Compute Gallery-Image zugeordnetes Kennwort
  • Kompromittierter Computer

Lösung

Lernende verwenden falsche Anmeldeinformationen.

Vergewissern Sie sich, dass die Lernenden den korrekten Benutzernamen und das korrekte Kennwort für ihre virtuellen Lab-Computer verwenden. Wenn bei der Erstellung des Labs die Option „Dasselbe Kennwort für alle VMs verwenden“ aktiviert war, sollten Benutzername und Kennwort für alle Lernenden identisch sein.

Lernende haben ihr Kennwort vergessen.

Lernende, die ein benutzerdefiniertes Kennwort vergessen haben, können das Kennwort auf dem Computer vom Lab aus zurücksetzen. Darüber hinaus können Lernende ein Reimaging des Computers durchführen. Dabei werden allerdings alle Benutzerdaten unwiderruflich gelöscht.

Wenn andere Lernende sich nicht mit dem gemeinsamen Benutzernamen und Kennwort des Labs anmelden können und das Lab mit einem vorhandenen benutzerdefinierten Image erstellt wurde, kann dies auf eine bekannte Einschränkung zurückzuführen sein. Die Problemumgehung besteht darin, den Benutzernamen und das Passwort zu verwenden, mit dem das Image erstellt wurde, oder das Passwort zurückzusetzen.

Kompromittierter Computer

Es gibt Situationen, in denen das Kennwort Lernender durch böswillige Akteure mit betrügerischer Absicht geändert wird. Lernende können ihr Kennwort zwar zurücksetzen, um wieder Zugriff auf den Computer zu erhalten, hier sind jedoch einige Empfehlungen, um die Wahrscheinlichkeit einer solchen Situation zu verringern:

  • Verwenden Sie keine gängigen Kennwörter, und deaktivieren Sie beim Erstellen des Labs die Option für die Verwendung des gleichen Kennworts. Die Verwendung einzelner spezifischer Kennwörter verkleinert den Bereich, der im Falle einer Kennwortkompromittierung betroffen ist.
  • Verwenden Sie sichere Kennwörter, und schützen Sie sie.
  • Beschränken Sie den Zugriff auf das Lab, sodass nur die am Kurs teilnehmenden Lernenden auf die Computer zugreifen können. Der Zugriff auf das Lab ist standardmäßig eingeschränkt.
Remotedesktopgateway

Für den von den Lernenden verwendeten Remotedesktopclient kann ein Remotedesktopgateway konfiguriert sein (auch wenn dies eher ungewöhnlich ist). Wenn das der Fall ist, müssen sie zuerst ihre Anmeldedaten für das Gateway eingeben (um sich beim Gateway zu authentifizieren), bevor sie eine Verbindung mit dem virtuellen Computer für Lernende herstellen.

Behandeln von Problemen mit erweitertem Networking

Einige Problembehandlungsszenarien gelten nur für Labs mit erweitertem Networking.

Fehlende Netzwerksicherheitsgruppe

Bei einem Lab-Plan, der mit erweitertem Networking konfiguriert ist, muss zunächst überprüft werden, ob das Subnetz des Lab Services-Netzwerks mit einer Netzwerksicherheitsgruppe verbunden ist. Dadurch können die RDP- bzw. SSH-Verbindungen zugelassen werden. Ohne Netzwerksicherheitsgruppe werden alle Verbindungen mit den virtuellen Computern (Vorlagen-VM und Lernenden-VMs) blockiert.

Verwendung der Problembehandlung für RDP bei virtuellen Azure-Computern

Es gibt spezielle Problembehandlungstechniken bei Labs, die mit erweiterten Netzwerken konfiguriert sind. Erweitertes Networking bietet weitere Problembehandlungsmöglichkeiten, indem ein virtueller Azure-Computer erstellt wird, der direkt mit dem virtuellen Netzwerk verbunden ist, mit dem auch der Lab-Plan verbunden ist. Unter Verwendung dieses virtuellen Azure-Computers (außerhalb von Azure Lab Services) können Sie anhand des Leitfadens zur Problembehandlung für RDP bei virtuellen Azure-Computern, einschließlich der Azure-internen Problembehandlung für Verbindungen, ermitteln, ob das Netzwerk ordnungsgemäß konfiguriert ist.

NSG-Regeln blockieren RDP-/SSH-Verbindungen

Mithilfe des virtuellen Azure-Computers, der direkt mit dem virtuellen Netzwerk verbunden ist (aus dem vorherigen Abschnitt), können Sie die Netzwerkkonnektivität virtueller Computer direkt im Azure-Portal diagnostizieren. Das Blockieren oder Einschränken der RDP- bzw. SSH-Verbindungen über Sicherheitsregeln kann im Subnetz mit einer Netzwerksicherheitsgruppe oder mithilfe von Azure Virtual Network Manager erfolgen. Die einfachste Möglichkeit, die vollständige Liste der Regeln anzuzeigen, sind die effektiven Sicherheitsregeln des Netzwerks des virtuellen Azure-Computers.

Standardmäßige benutzerdefinierte Route (Problem bei der Routingtabelle)

Mit erweiterten Netzwerken kann das Netzwerk nach Bedarf angepasst werden und auch die Routingtabelle kann geändert werden. Eine benutzerdefinierte Routingtabelle leitet den Datenverkehr an die entsprechenden Ziele weiter. Es gibt eine spezielle Route: die „Internetroute“ (0.0.0.0/0). Sie leitet Datenverkehr, der nicht für eine andere lokale Adresse bestimmt ist, an das Internet weiter. Das erweiterte Networking von Azure Lab Services unterstützt keine Aktualisierung des nächsten Hops für die Route 0.0.0.0/0 auf ein anderes Ziel als das Internet. Wenn Sie diese Einstellung auf eine bestimmte IP-Adresse festlegen (z. B., um ausgehenden Internetdatenverkehr an eine Firewall oder an eine andere Netzwerkappliance zu leiten), wird die Verbindung mit dem Lab unterbrochen, da ein asymmetrisches Routingproblem eingeführt wird. Überprüfen Sie beim Debuggen, ob es eine benutzerdefinierte Routingtabelle gibt, und stellen Sie sicher, dass die Standardroute auf 0.0.0.0/0 für das Internet festgelegt ist.

Weitere Problembehandlungen

Sollten nach den obigen Schritten weiterhin Probleme auftreten, müssen möglicherweise weitere Daten zur weiteren Problembehandlung gesammelt werden. Das können beispielsweise Protokolle von Ihrem virtuellen Computer, Netzwerkablaufverfolgungsdaten oder andere relevante Informationen sein.

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support.

Wenn Sie eine Azure-Supportanfrage erstellen, geben Sie die folgenden Informationen in den Anforderungsdetails an, um die Problembehebung zu beschleunigen:

  • ID des Lab-Plans. Wählen Sie den Lab-Plan im Azure-Portal aus, und navigieren Sie zur Seite Eigenschaften.
  • Die Lab-ID. Wählen Sie das Lab im Azure-Portal aus, und navigieren Sie zur Seite Eigenschaften. Wählen Sie alternativ die URL des Labs auf der Azure Lab Services-Websiteaus.
  • Ungefährer Zeitpunkt, zu dem die Probleme aufgetreten sind.
  • Alle ggf. im Azure-Aktivitätsprotokoll aufgeführten Fehler. Wählen Sie den Lab-Plan oder das Lab im Azure-Portal aus, und navigieren Sie zur Seite Aktivitätsprotokoll. Informationen zum Anzeigen und Herunterladen des Aktivitätsprotokolls finden Sie hier.