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Installationsfehlermeldung

Nach der Installation des Microsoft BizTalk-Adapters für TIBCO Enterprise Message Service kann es beim Definieren eines Sende- oder Empfangsspeicherorts für den Adapter zu dem folgenden Fehler kommen:

Die Messaging-Engine konnte dem Adapter "TIBCO EMS" keine Empfangs-URL "< Send/Receive Location URL>" hinzufügen. Grund: "Datei- oder Assemblyname TIBCO. EMS oder eine seiner Abhängigkeiten wurde nicht gefunden."

Mögliche Ursachen

Dieser Fehler ist normalerweise auf eine der folgenden Ursachen zurückzuführen:

Assembly nicht im globalen Assemblycache vorhanden

Der BizTalk-Adapter für TIBCO EMS ist eine .NET Framework-Anwendung und verwendet die .NET Framework Assembly TIBCO. EMS. Diese Assembly muss im .NET Framework globalen Assemblycache (GAC) vorhanden sein, damit der .NET Framework sie zur Laufzeit finden kann.

Lösung

Überprüfen Sie, ob sich die Assembly im globalen Assemblycache befindet. Öffnen Sie dazu eine Eingabeaufforderung, und geben Sie den folgenden Befehl ein:

GACUTIL /L TIBCO.EMS

Wenn das Ergebnis kein Element enthält, müssen Sie die Assembly dem globalen Assemblycache hinzufügen. Öffnen Sie dazu eine Eingabeaufforderung, wechseln Sie in der TIBCO EMS-Installation zum Verzeichnis clients\cs (das Standardverzeichnis für die Installation ist C:\TIBCO\EMS\Clients\CS), und führen Sie den folgenden Befehl aus:

GACUTIL /i TIBCO.EMS.DLL

Abweichende Version der Assembly im globalen Assemblycache

Die Assembly TIBCO.EMS.dll befindet sich im globalen Assemblycache, weist jedoch eine andere Version auf als die zum Erstellen des BizTalk-Adapters für TIBCO EMS verwendete Assembly. Wenn die auf dem Computer installierte Datei TIBCO.EMS.dll aus der Produktversion 4.2 oder höher stammt, sollte sie mit der Version kompatibel sein, die zum Erstellen des Adapters verwendet wurde (nähere Informationen dazu erhalten Sie von TIBCO).

Lösung

In .NET Framework lässt sich dieses Problem umgehen, und zwar Es wird als Bindungsumleitung bezeichnet, die eine Konfigurationsdatei verwendet.

Führen Sie die folgenden Schritte aus, um die Fehlermeldung zu vermeiden:

  1. Öffnen Sie die Datei BTSNTSVC.exe.config in einem beliebigen Texteditor.

    Die Datei befindet sich im Verzeichnis BizTalk Server (Der Standardinstallationsspeicherort lautet \Programme (x86)\Microsoft BizTalk Server <VERSION>).

  2. Fügen Sie der datei BTSNTSVC.exe.config als untergeordnetes Element des assemblyBinding-Elements> den <folgenden Eintrag hinzu:

<dependentAssembly>  
    <assemblyIdentity name='TIBCO.EMS'  
        publicKeyToken='5b83db8ff05c64ba ' culture='neutral' />  
    <bindingRedirect oldVersion='1.0.0.0-65535.65535.65535.65535'  
        newVersion='1.0.0.0' />  
</dependentAssembly>  

Wenn die datei BTSNTSVC.exe.config zuvor nicht geändert wurde, sieht das <assemblyBinding-Element> nicht wie folgt aus:

<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">  
    <probing privatePath="BizTalk Assemblies;Developer  
        Tools;Tracking;Tracking\interop" />  
    <dependentAssembly>  
        <assemblyIdentity name='TIBCO.EMS'  
            publicKeyToken='5b83db8ff05c64ba ' culture='neutral' />  
        <bindingRedirect oldVersion='1.0.0.0-65535.65535.65535.65535'  
            newVersion='1.0.0.0' />  
    </dependentAssembly>  
</assemblyBinding>  
  1. Geben Sie an einer Eingabeaufforderung den Folgenden Befehl ein: GACUTIL /L TIBCO.EMS.

  2. Kopieren Sie die Versionsnummer der Assembly TIBCO.EMS, die in der Ausgabe angezeigt wird.

    Achtung

    Es werden zwei Versionsnummern angezeigt: Eine ist die Versionsnummer des Hilfsprogramms gacutil. Sie möchten die zweite Versionsnummer, die direkt nach Version= angezeigt wird.

  3. Fügen Sie die Versionsnummer in die BTSNTSVC.exe.config-Datei zwischen den Anführungszeichen direkt hinter newVersion= ein (fett formatierte Zeichen im vorherigen XML-Beispiel).

  4. Speichern Sie die geänderte Datei BTSNTSVC.exe.config.

  5. Starten Sie den BizTalk Server Host neu.

Weitere Informationen

Fehlerbehebung für TIBCO Enterprise Message Service