Behandeln von Lizenzproblemen für Microsoft Defender for Endpoint unter macOS
Gilt für:
- Microsoft Defender für Endpunkt unter macOS
- Microsoft Defender für Endpunkt Plan 1
- Microsoft Defender für Endpunkt Plan 2
- Microsoft Defender XDR
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Keine Lizenz gefunden
Wenn Microsoft Defender for Endpoint unter macOS bereitgestellt wird, wird eine Fehlermeldung mit einem x über dem Microsoft Defender for Endpoint unter macOS-Schutz angezeigt.
Wählen Sie das x-Symbol aus.
Nachricht
Wenn Sie das x-Symbol auswählen, werden optionen angezeigt, wie im folgenden Screenshot gezeigt:
Wenn Sie Aktion erforderlich auswählen, wird die Fehlermeldung angezeigt, wie im folgenden Screenshot gezeigt:
Diese Meldung wird auf eine andere Weise angezeigt: Wenn Sie das Terminal verwenden, um die mdatp-Integrität ohne die doppelten Anführungszeichen einzugeben, wird die Meldung wie im folgenden Screenshot gezeigt angezeigt:
Ursache
Es kann ein Fehler auftreten, wenn Sie die Microsoft Defender for Endpoint unter macOS-Paket installationspakete herunterladen bereitgestellt und/oder installiert haben, aber möglicherweise nicht das Konfigurationsskript Herunterladen des Onboardingpakets, das die Lizenzeinstellungen enthält. Informationen zur Problembehandlung in diesem Szenario finden Sie unter Wenn Sie das Konfigurationsskript nicht ausgeführt haben.
Es kann eine Fehlermeldung auftreten, wenn die Microsoft Defender for Endpoint unter dem macOS-Agent nicht auf dem neuesten Stand ist. Informationen zur Problembehandlung in diesem Szenario finden Sie unter Wenn Microsoft Defender for Endpoint unter macOS nicht auf dem neuesten Stand ist.
Sie können eine Fehlermeldung erhalten, wenn Sie Mac von Microsoft Defender for Endpoint unter macOS offboardet und erneut gestartet haben.
Wenn einem Benutzer keine Lizenz zugewiesen ist, kann eine Fehlermeldung angezeigt werden. Informationen zur Problembehandlung in diesem Szenario finden Sie unter Wenn einem Benutzer keine Lizenz zugewiesen ist.
Lösungen
Wenn Sie das Konfigurationsskript nicht ausgeführt haben
In diesem Abschnitt werden die Maßnahmen zur Problembehandlung beschrieben, wenn die Fehler-/Warnmeldung durch die Nichtausführung des Konfigurationsskripts verursacht wird. Das Skript enthält die Lizenzeinstellungen, wenn das Microsoft Defender for Endpoint unter macOS installiert und bereitgestellt wird.
Befolgen Sie abhängig vom verwendeten Bereitstellungsverwaltungstool die toolspezifischen Anweisungen zum Onboarding des Pakets (Registrieren der Lizenz), wie in der folgenden Tabelle beschrieben:
Verwaltung | Anweisungen zur Lizenzbereitstellung (Onboardinganweisungen) |
---|---|
Intune | Herunterladen des Onboardingpakets |
JamF | Schritt 1: Abrufen des Microsoft Defender for Endpoint Onboarding-Pakets |
Andere MDM | Lizenzeinstellungen |
Manuelle Installation | Herunterladen von Installations- und Onboardingpaketen; und Onboardingpaket |
Hinweis
Wenn das Onboardingpaket ordnungsgemäß ausgeführt wird, befinden sich die Lizenzierungsinformationen in /Library/Application Support/Microsoft/Defender/com.microsoft.wdav.atp.plist
.
Wenn Microsoft Defender for Endpoint unter macOS nicht auf dem neuesten Stand ist
In Szenarien, in denen Microsoft Defender for Endpoint unter macOS nicht auf dem neuesten Stand ist, müssen Sie den Agent aktualisieren.
Wenn Microsoft Defender for Endpoint unter macOS offboarded wurde
Wenn das Offboardingskript unter macOS ausgeführt wird, speichert es eine Datei in /Library/Application Support/Microsoft/Defender/
und heißt com.microsoft.wdav.atp.offboarding.plist
.
Wenn die Datei vorhanden ist, wird verhindert, dass macOS erneut integriert wird. Löschen Sie com.microsoft.wdav.atp.offboarding.plist , indem Sie das Onboardingskript erneut ausführen.
Wenn einem Benutzer keine Lizenz zugewiesen ist
Wählen Sie im Microsoft Defender-Portal (security.microsoft.com) einstellungen und dann Endpunkte aus.
Wählen Sie Lizenzen aus.
Wählen Sie Im Microsoft 365 Admin Center Lizenzen anzeigen und kaufen aus. Der folgende Bildschirm im Microsoft 365 Admin Center-Portal wird angezeigt:
Aktivieren Sie das Kontrollkästchen der Lizenz, die Sie bei Microsoft erwerben möchten, und aktivieren Sie sie. Der Bildschirm mit details der ausgewählten Lizenz wird angezeigt:
Wählen Sie den Link Lizenzen zuweisen aus.
Der folgende Bildschirm wird angezeigt:
Wählen Sie + Lizenzen zuweisen aus.
Geben Sie den Namen oder die E-Mail-Adresse der Person ein, der Sie diese Lizenz zuweisen möchten. Der folgende Bildschirm wird angezeigt, in dem die Details des ausgewählten Lizenzempfängers und eine Liste mit Optionen angezeigt werden.
Aktivieren Sie die Kontrollkästchen für Microsoft 365 Advanced Auditing, Microsoft Defender XDR und Microsoft Defender for Endpoint. Klicken Sie dann auf Speichern.
Wenn die Lizenzierungsprobleme behoben wurden und Sie dann mdatp health ausführen, sollten bei der Implementierung dieser Lösungsoptionen (einer von beiden) die folgenden Ergebnisse angezeigt werden:
Anmelden mit Ihrem Microsoft-Konto
Nachricht
Melden Sie sich mit Ihrem Microsoft-Konto an, um zu beginnen.
Create neues Konto oder Wechseln zur Unternehmens-App.
Ursache
Sie haben Microsoft Defender für Einzelpersonen unter macOS zusätzlich zu zuvor installierten Microsoft Defender for Endpoint heruntergeladen und installiert.
Lösung
Wählen Sie Zur Unternehmens-App wechseln aus, um zur Unternehmensumgebung zu wechseln.
Sie können auch den Wechsel zur Erfahrung für Einzelpersonen auf MDM-registrierten Computern unterdrücken, indem Sie userInterface/consumerExperience in die Defender-Einstellungen einschließen:
<key>userInterface</key>
<dict>
<key>consumerExperience</key>
<string>disabled</string>
</dict>
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Tipp
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