Es kann keine Verbindung mit Access Database Engine OLE DB hergestellt werden.

Dieser Artikel bietet eine Lösung für ein Problem, bei dem Sie keine Verbindung mit Access Database Engine OLE DB in Microsoft Power Automate für Desktop herstellen können.

Gilt für: Power Automate
Ursprüngliche KB-Nummer: 5004577

Symptome

Betrachten Sie das folgende Szenario in Microsoft Power Automate für Desktop:

  1. Access Database Engine OLE DB-Anbieter wird nicht in der Fensterliste Datenlinkeigenschaften angezeigt, wenn Sie eine Verbindung mit Datenbankaktionen herstellen.

  2. Wenn Sie eine Verbindungszeichenfolge direkt verwenden, erhalten Sie möglicherweise die folgende Fehlermeldung:

    Es kann keine Verbindung mit der Datenquelle "Microsoft.ACE.OLEDB.1x.0" hergestellt werden. anbieter ist nicht auf dem lokalen Computer registriert.

Ursache

Diese Fehlermeldung tritt auf, weil der entsprechende 64-Bit-Treiber nicht auf Ihrem Computer installiert ist. Bitte beachten Sie, dass Power Automate für Desktop auf einer 64-Bit-Architektur basiert und daher nur mit 64-Bit-Datenbanktreibern kompatibel ist.

Lösung

Überprüfen Sie, ob der 64-Bit-Access-Datenbanktreiber auf Ihrem Computer installiert ist, indem Sie unter Windows zur ODBC-Datenquellenadministratoranwendung (64-Bit) und dann zur Registerkarte Treiber wechseln. Wenn "Microsoft Access-Treiber" in der Liste nicht angezeigt wird, müssen Sie die 64-Bit-Version von Microsoft Access Database Engine 2016 Redistributable herunterladen und installieren.

Tipp

Wenn Sie die 32-Bit-Version von Office auf Ihren Windows installiert haben und kein Upgrade auf die 64-Bit-Version von Office durchführen können, lesen Sie den Rest des Artikels weiter.

Führen Sie die folgenden Schritte aus, damit sowohl 32-Bit- als auch 64-Bit-Zugriffstreiber auf Ihrem Computer vorhanden sind:

  1. Deinstallieren Sie alle Access-Treiberversionen von Ihrem Computer.

  2. Wechseln Sie zum Registrierungs-Editor auf Ihrem Desktop (Sie können in der Suchleiste danach suchen), und navigieren Sie zu den beiden folgenden Pfaden, sofern vorhanden:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

  3. Überprüfen Sie, ob der Registrierungsschlüssel "mso.dll" in beiden oben genannten Pfaden vorhanden ist. Wenn der Schlüssel vorhanden ist, bedeutet dies, dass Sie nicht alle Treiber deinstalliert haben. Überprüfen Sie die Treiber auf Ihrem System, deinstallieren Sie alle Access-Treiber, und überprüfen Sie erneut die in Schritt 2 erwähnten Pfade der Registrierungs-Editoren.

  4. Laden Sie eine neue Version der Microsoft Access-Datenbank-Engine von der offiziellen Microsoft-Website herunter, und installieren Sie dann den 64-Bit-Treiber über die Eingabeaufforderung (CMD) mit dem Befehl AccessDatabaseEngine_x64.exe /quiet für 2016 Redistributable.

  5. Zurück in den Registrierungs-Editor, und löschen Sie den Registrierungsschlüssel "mso.dll" und seinen Wert im folgenden Pfad:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Installieren Sie schließlich den 32-Bit-Treiber über die Eingabeaufforderung (CMD) mit dem Befehl AccessDatabaseEngine.exe /quiet für 2016 Redistributable. Dadurch können sowohl der 32-Bit- als auch der 64-Bit-Treiber auf Ihrem Computer gleichzeitig vorhanden sein.