Behandeln von Problemen mit Azure Automation-Konten

In diesem Artikel werden Lösungen für Probleme beschrieben, die bei Verwendung eines Azure Automation-Kontos auftreten können. Allgemeine Informationen zu Automation-Konten finden Sie unter Übersicht über die Azure Automation-Kontoauthentifizierung.

Szenario: Ein Automation-Konto kann nicht erstellt werden, wenn die GUID als Kontoname verwendet wird.

Problem

Wenn Sie ein Automation-Konto mit einer GUID als Kontonamen erstellen, tritt ein Fehler auf.

Ursache

Eine accountid ist ein eindeutiger Bezeichner für alle Automation-Konten in einer Region. Wenn der Kontoname eine GUID ist, behalten wir sowohl die Konto-ID als auch den Namen des Automation-Kontos als GUID bei. Wenn Sie in diesem Szenario ein neues Automation-Konto erstellen und eine GUID (als Kontonamen) angeben, tritt bei einem Konflikt mit einer vorhandenen Automation-Konto-ID ein Fehler auf.

Wenn Sie beispielsweise versuchen, ein Automation-Konto mit dem Namen 8a2f48c1-9e99-472c-be1b-dcc11429c9ff zu erstellen und bereits eine Automation-Konto-ID für alle Automation-Konten in dieser Region vorhanden ist, wird bei der Kontoerstellung der folgende Fehler angezeigt:

   {

   "code": "BadRequest",

   "message": Automation account already exists with this account id. AccountId: 8a2f48c1-9e99-472c-be1b-dcc11429c9ff. 

   }

Lösung

Stellen Sie sicher, dass Sie ein Automation-Konto mit einem neuen Namen erstellen.

Szenario: Der Automation-Ressourcenanbieter für Abonnements kann nicht registriert werden.

Problem

Beim Arbeiten mit Verwaltungsfeatures, wie z. B. der Updateverwaltung, in Ihrem Automation-Konto tritt der folgende Fehler auf:

Error details: Unable to register Automation Resource Provider for subscriptions:

Ursache

Der Automation-Ressourcenanbieter ist nicht im Abonnement registriert.

Lösung

Führen Sie im Azure-Portal die folgenden Schritte aus, um den Automation-Ressourcenanbieter zu registrieren:

  1. Navigieren Sie in Ihrem Browser zum Azure-Portal.

  2. Wählen Sie unter Abonnements Ihr Abonnement aus.

  3. Wählen Sie unter Einstellungen die Option Ressourcenanbieter aus.

  4. Überprüfen Sie in der Liste der Ressourcenanbieter, ob der Ressourcenanbieter Microsoft.Automation registriert ist.

  5. Wenn der Anbieter nicht aufgeführt ist, registrieren Sie ihn, so wie unter Beheben von Fehlern bei der Ressourcenanbieterregistrierung beschrieben.

Nächste Schritte

Wenn Sie Ihr Problem nicht mit diesem Artikel lösen konnten, besuchen Sie einen der folgenden Kanäle, um weitere Unterstützung zu erhalten:

  • Erhalten Sie Antworten von Azure-Experten über Azure-Foren.
  • Verbinden mit @AzureSupport. Dies ist das offizielle Microsoft Azure-Konto, über das die Azure-Community Zugriff auf die richtigen Ressourcen erhält: Antworten, Support und Experten.
  • Erstellen Sie einen Azure-Supportfall. Wechseln Sie zur Azure-Supportwebsite, und wählen Sie Support erhalten aus.