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Problembehandlung bei BizTalk Accelerator für RosettaNet (BTARN): Probleme und Lösung

In diesem Thema werden Probleme im Zusammenhang mit der Ausführung von Microsoft® BizTalk Accelerator for RosettaNet (BTARN) behandelt. Die einzelnen Probleme beschreiben ein bestimmtes Symptom, eine mögliche Ursache und eine Lösung.

Fehler beim Veröffentlichen eines Batches von "n"-Nachrichten

Symptom

Sie erhalten den folgenden oder einen ähnlichen Fehler im Ereignisprotokoll:

Bei der Messaging-Engine ist ein Fehler beim Veröffentlichen eines Batches von "n"-Nachrichten in der Message Box-Datenbank für den Transportadapter "BizTalk HTTP Receiver" aufgetreten. Ausführlichere Informationen zu diesem Fehler finden Sie unter Integritäts- und Aktivitätsnachverfolgungstool, und überprüfen Sie, ob die Endpunktbindungen ordnungsgemäß konfiguriert sind.

Mögliche Ursache

Dieser Fehler kann auf einen der folgenden Gründe zurückzuführen sein:

  • Fehlendes Entschlüsselungszertifikat

  • Falsch verschlüsselte Nachricht

  • Nicht autorisierte Nachricht (Quelle nicht als gültiger Partner erkannt)

  • Fehlerüberprüfung von Nachrichten eines Beliebigen Headerteils: Präambel, Übermittlungsheader oder Dienstheader.

    Dieser Meldung kann eine weitere Fehlermeldung vorangestellt werden, die die Ursache aufzeigt.

Lösung

Weitere Hilfe finden Sie in den In der Fehlermeldung angegebenen Details. Durch den Neustart von Microsoft SQL Server ™ kann dieses Problem behoben werden.

Sie können nicht alle Artefakte aufheben.

Symptom

Wenn Sie das BTARNClean-Hilfsprogramm ausführen, werden nicht alle Artefakte auflisten.

Mögliche Ursache

Wenn Sie das Hilfsprogramm BTARNClean ausführen, bevor Sie Vereinbarungen und Partner aus der Microsoft® Management Console (MMC) löschen, kann das BtarnClean-Hilfsprogramm nicht alle Artefakte aufheben, da sie weiterhin verwendet werden.

Lösung

So entfernen Sie Artefakte mithilfe des Loopback-Hilfsprogramms
  1. Geben Sie an der Eingabeaufforderung Folgendes ein:

    lookback.exe /disable <home org or partner>  
    
  2. Führen Sie die datei BtarnClean.exe aus.

  3. Löschen Sie in BizTalk Explorer die Parteien.

Die Installation von BTARN auf einem Computer ohne BizTalk Server verursacht fehlende Dateien

Symptom

Das Ausführen der ConfigFramework.exe-Datei führt zu keinem Ergebnis auf einem Computer, auf dem MicrosoftBizTalk Server oder Microsoft Visual Studio nicht installiert ist. Sie können diese BTARN-Konfiguration nur als HTTP-Client verwenden.

Mögliche Ursache

Zwei DLL-Dateien fehlen bei der Installation.

Lösung

Installieren Sie SQLXML auf dem Computer, und kopieren Sie dann die dateien Msxml4.dll und Atl71.dll manuell in den Ordner System.

Beim Ändern der BTARN-Konfiguration erhalten Sie einen Zugriffsfehler.

Symptom

Beim Importieren einer Konfigurationsdatei mit der BTARN-Verwaltungskonsole wird die folgende Fehlermeldung angezeigt:

Es konnte keine Transporttypdaten für den primären Transport des Sendeports 'RNSTT gespeichert werden. Asynchron" für den Konfigurationsspeicher. Zugriff verweigert.“

Diese Fehlermeldung kann auch angezeigt werden, wenn Sie versuchen, die Konfiguration zu ändern, z. B. durch Erstellen eines neuen Partners.

Mögliche Ursache

Der aktuelle Benutzer ist kein Mitglied der BizTalk-Administratorengruppe.

Lösung

Stellen Sie sicher, dass der aktuelle Benutzer Mitglied der Gruppe BizTalk-Administratoren ist.

Sie erhalten BAM-Fehler.

Symptom

Sie erhalten die folgenden Fehlermeldungen im Ereignisanzeige:

Fehler beim Nachverfolgen der Nachrichtenaktivität. Fehlermeldung: Gespeicherte Prozedur ist nicht vorhanden.

Oder

Fehler beim Beenden der BAM-Nachrichtenaktivität mit ID-ID-Nummer<>.

Mögliche Ursache

Das BAM-Überwachungstool (Business Activity Monitoring) ist nicht installiert.

Lösung

Installieren Sie das BAM-Nachverfolgungstool mithilfe der Option Benutzerdefinierte Installation . Wenn Sie keine BAM-Funktionalität benötigen, können Sie diese Nachrichten ignorieren oder die Nachverfolgung mithilfe der BTARN-Verwaltungskonsole deaktivieren. Nachdem Sie die Nachverfolgung deaktiviert haben, müssen Sie BizTalk Server und Internet- und Informationsdienste (IIS) neu starten.

Ihr XSD-Schema wird im BizTalk-Editor nicht ordnungsgemäß angezeigt.

Symptom

Sie können den Inhalt eines Schemas nicht ordnungsgemäß im BizTalk-Editor anzeigen.

Mögliche Ursache

Dem Schema fehlt das displayroot_reference Attribut für das schemaInfo -Element.

Lösung

Öffnen Sie das Schema in Editor oder einem anderen Text-Editor, und fügen Sie das displayroot_reference Attribut dem schemaInfo -Element hinzu. Der Wert des displayroot_reference Attributs sollte mit dem root_reference Attribut identisch sein.

Beispiel:

<schemaInfo document_type="4A1" version="V02_00" xmlns="<http://schemas.microsoft.com/BizTalk/2003>" displayroot_reference="Pip4A1StrategicForecastNotification" root_reference="Pip4A1StrategicForecastNotification" \>  

404 Fehler beim Senden einer HTTP-Anforderung nicht gefunden

Symptom

Beim Senden einer HTTP-Anforderung erhalten Sie folgende oder ähnliche Fehler:

Der Remoteserver hat einen Fehler zurückgegeben: (404) Nicht gefunden.

Die Nachricht kann nicht an gesendet werden. /BTSHttpReceive.dll.

Mögliche Ursache

Die BizTalk Server ISAPI-Erweiterungs-DLL (BTSHttpReceive.dll) wurde in Internetinformationsdienste (IIS) nicht konfiguriert. Dies tritt auf, wenn die HttpReceive-Webdiensterweiterung von HwsMessages nicht konfiguriert ist und wenn diese Webdiensterweiterung konfiguriert, aber nicht zulässig ist.

Lösung

Führen Sie das folgende Verfahren aus, um zu bestimmen, ob die HttpReceive-Webdiensterweiterung von HwsMessages konfiguriert ist, und wenn sie nicht konfiguriert ist, um sie zuzulassen.

So konfigurieren Sie die BizTalk ISAPI-Erweiterungs-DLL in IIS
  1. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetinformationsdienste-Manager.

  2. Erweitern Sie <Computername> (lokaler Computer), und klicken Sie dann auf Webdiensterweiterungen.

  3. Überprüfen Sie im Bereich Webdiensterweiterung, ob die status für HwsMessages HttpReceive zulässig ist. Wenn nicht, klicken Sie mit der rechten Maustaste auf HwsMessages HttpReceive, und klicken Sie dann auf Zulassen.

    Wenn die HwsMessages HttpReceive-Webdiensterweiterung nicht konfiguriert ist (sie ist nicht in der Liste Webdiensterweiterungen im IIS-Manager enthalten), führen Sie das folgende Verfahren aus.

So konfigurieren Sie die BizTalk ISAPI-Erweiterungs-DLL in IIS
  1. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetinformationsdienste-Manager.

  2. Erweitern Sie <Computername> (lokaler Computer), klicken Sie mit der rechten Maustaste auf Webdiensterweiterungen, und klicken Sie dann auf Neue Webdiensterweiterung hinzufügen.

  3. Geben Sie im Dialogfeld Neue Webdiensterweiterung im Feld Erweiterungsname den Namen BizTalk ISAPI-Erweiterung ein, und klicken Sie dann auf Hinzufügen.

  4. Geben Sie im Dialogfeld Datei hinzufügen im Feld Pfad zur Datei laufwerk>:\Programme\Microsoft BizTalk Server <Version>\HttpReceive\BTSHttpReceive.dllein, und klicken Sie dann auf OK.<

  5. Wählen Sie im Dialogfeld Neue Webdiensterweiterung die Option Erweiterung status auf Zulässig festlegen aus, und klicken Sie dann auf OK.

Beim Ausführen des Konfigurations-Assistenten tritt eine Zugriffsverletzung auf.

Symptom

Sie erhalten den folgenden oder einen ähnlichen Fehler im Ereignisprotokoll:

Ein isolierter BizTalk-Host instance mit dem Benutzerkonto "\HostSvc" konfiguriert wurde, wurde entweder nicht ausgeführt oder ist auf diesem Computer nicht vorhanden. Verwenden Sie die BizTalk-Verwaltungskonsole, um einen neuen isolierten Host zu erstellen, oder konfigurieren Sie einen vorhandenen für die Ausführung als "\hostsvc".

Mögliche Ursache

Zum Ausführen des Konfigurations-Assistenten sollte der Benutzer als "<Computername>\hostsvc" und nicht als "\hostsvc" konfiguriert werden.

Lösung

Öffnen Sie die BizTalk-Verwaltungskonsole, und ändern Sie Hosts, die unter dem Konto "\hostsvc" ausgeführt werden, sodass sie unter dem Konto "<Computername>\hostsvc" ausgeführt werden.

Beim Importieren und Kompilieren eines RosettaNet-PIP-Schemas der nächsten Generation erhalten Sie eine Fehlermeldung.

Symptom

Sie erhalten den folgenden oder einen ähnlichen Fehler im Ereignisprotokoll:

Fehler CS0234: Der Typ- oder Namespacename "SerializableAttribute" ist in der Klasse oder dem Namespace "RosettaNet.Schemas.System" nicht vorhanden (fehlt ein Assemblyverweis?).

Mögliche Ursache

Eines Ihrer Schemas, z. B. StandardDocumentHeader.xsd, verfügt über den .NET-Namespace RosettaNet.Schemas.System.

Lösung

Entfernen Sie "System" aus dem .NET-Namespace für das Schema, sodass der Namespace RosettaNet.Schemas ist.

Beim Versuch, das BAM-Paket manuell bereitzustellen, wird eine Fehlermeldung angezeigt.

Symptom

Wenn Sie manuell versuchen, das BAM-Paket für BTARN bereitzustellen, erhalten Sie eine Fehlermeldung, die angibt, dass Sie das Paket nicht bereitstellen können.

Mögliche Ursache

Die DTS-Pakete BAM_DM_Process und BAM_DM_Message werden auf Ihrem System installiert, wodurch die Bereitstellung des BAM-Pakets verhindert wird.

Lösung

So stellen Sie die Fehlerbedingung wiederherzustellen und das BAM-Paket bereit
  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie in Enterprise Manager Microsoft SQL Server, SQL Server Gruppe, (lokal) (Windows NT) und Data Transformation Services.

  3. Klicken Sie auf Lokale Pakete, klicken Sie mit der rechten Maustaste auf BAM_DM_Message, und klicken Sie dann auf Löschen.

  4. Klicken Sie mit der rechten Maustaste auf BAM_DM_Process, und klicken Sie dann auf Löschen.

  5. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie cmd ein, und klicken Sie dann auf OK.

  6. Geben Sie an der Eingabeaufforderung den folgenden Code ein, um die Überwachungsdatei bereitzustellen, und klicken Sie dann auf OK.

    cd %ProgramFiles%\Microsoft BizTalk Server <version>\Tracking  
    bm deploy all  "%ProgramFiles%\Microsoft BizTalk <version> Accelerator for RosettaNet\BAMTracking\tracking.xml"  
    

Beim Hinzufügen eines neuen PIP wird eine Fehlermeldung angezeigt.

Symptom

Sie erhalten den folgenden oder einen ähnlichen Fehler im Ereignisprotokoll:

UNP. SCON. VALERR: Beim Überprüfen des Dienstinhalts ist ein Fehler aufgetreten.

Details: Fehler beim Ermitteln der Dokumentspezifikation nach Nachrichtentyp. Vergewissern Sie sich, dass das Schema ordnungsgemäß bereitgestellt wurde.

Mögliche Ursache

Entweder der Dokumentnamespace oder die Stammknoteneigenschaft das bereitgestellte Schema für die instance Pip4A5NotifyofForecastReply ist falsch.

Lösung

Vergewissern Sie sich, dass der Dokumentnamespace und die Stammknoteneigenschaft für das bereitgestellte Schema für instance Pip4A5NotifyofForecastReply richtig sind.

Fehler während der Konfiguration von BTARN zur Installationszeit, verursacht durch vermutete Probleme mit der Netzwerkkonnektivität

Symptom

Während des Konfigurationsprozesses erhalten Sie im Fehlerdialogfeld eine Fehlermeldung, die angibt, dass der Computer nicht ordnungsgemäß mit dem Netzwerk verbunden ist, wenn er tatsächlich ist.

Mögliche Ursache

Dieser Fehler kann durch das BTARN-Konfigurationsprogramm verursacht werden, das IP-Adressen falsch interpretiert. Die Hostdatei in C:\Windows\system32\drivers\etc enthält einen Eintrag, der den localhost-Hostnamen der IP-Adresse 127.0.0.1 zugeordnet. Das Konfigurationsprogramm verwechselt diesen Wert möglicherweise mit der Loopbackadresse und geht davon aus, dass der Computer nicht ordnungsgemäß mit dem Netzwerk verbunden ist.

Lösung

So vermeiden Sie diesen Fehler, und schließen Sie den Konfigurationsprozess ab
  1. Wechseln Sie in Windows Explorer zu C:\Windows\system32\drivers\etc, und öffnen Sie die Hosts-Datei mit Editor.

  2. Kommentieren Sie die Zeile "127.0.0.1 localhost", indem Sie "# " am Anfang der Zeile platzieren. Speichern Sie die geänderte Hostdatei.

  3. Klicken Sie im Fehlerdialogfeld auf Wiederholen .

  4. Nachdem die Konfiguration erfolgreich abgeschlossen wurde, öffnen Sie die Hosts-Datei erneut in Editor, entfernen Sie das Kommentarzeichen am Anfang der Zeilenzuordnung localhost, und speichern Sie dann die Hosts-Datei.

Sie erhalten eine Fehlermeldung bezüglich falscher Signaturlänge.

Symptom

Sie erhalten den folgenden oder einen ähnlichen Fehler im Ereignisprotokoll:

Fehler beim Ausführen der Empfangspipeline: "Microsoft.Solutions.BTARN.Pipelines.Receive" Quelle: "MIME/SMIME-Decoder" Empfangsspeicherort: "/BTARNHttpReceive/BTSHTTPReceive.dll?xRNResponseType=async" Grund: Falsche Signaturlänge, Wert = 1935897193.

Mögliche Ursache

Diese Fehlermeldung gibt an, dass die Signaturlänge falsch ist. Zusätzlich zur oben genannten Ursache kann dieser Fehler auch auf die falsche oder unvollständige Headerinhaltslänge zurückzuführen sein, die dazu führt, dass die falschen Bytes auf der Signaturlänge gelesen werden.

Lösung

Vergewissern Sie sich, dass sowohl die Signaturlänge als auch die Länge des Headerinhalts richtig sind.

Sie erhalten "503: Dienst nicht verfügbar" von Internet Explorer auf einem 64-Bit-Computer

Symptom

Nach Abschluss der BTARN-Konfiguration erhalten Sie möglicherweise den folgenden oder ähnlichen Fehler, wenn Sie versuchen, auf oder http://localhost/BtarnApp/RnifSend.aspxzuzugreifenhttp://localhost:

503: Dienst nicht verfügbar

Mögliche Ursache

Dieser Fehler kann durch den ISAPI-Filter verursacht werden, der unter C:\windows\system32\rpcproxy\rpcproxy.dll auf IIS-Websites festgelegt wird.

Lösung

So entfernen Sie den RpcProxy-Filtereintrag in IIS
  1. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetinformationsdienste-Manager.

  2. Erweitern Sie <Computername> (lokaler Computer), klicken Sie mit der rechten Maustaste auf Websites, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte ISAPI-Filter aus .

  4. Wählen Sie RpcProxy-Filter aus, und klicken Sie auf Entfernen.

  5. Klicken Sie auf OK.

  6. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie cmd ein, und klicken Sie dann auf OK.

  7. Geben Sie an der Eingabeaufforderung den folgenden Code ein, um IIS zurückzusetzen.

    iisreset  
    

Hinweis

Wenn Sie versuchen, auf die oben genannten Schritte zuzugreifen http://localhost oder http://localhost/BtarnApp/RnifSend.aspx erneut, erhalten Sie eine HTTP 400-Nachricht aus dem Internet Explorer was bedeutet, dass IIS jetzt ordnungsgemäß funktioniert.

Das HubScenario-Beispiel wird nicht ordnungsgemäß installiert, wenn die Assemblyschlüsseldateien nicht für die Projekte eingegeben werden.

Symptom

Wenn Sie setup.bat in <Laufwerk>:\Programme\Microsoft BizTalk <Version> Accelerator for RosettaNet\SDK\HubScenario ausführen, um das HubScenario-Beispiel einzurichten, schlägt der Vorgang fehl.

Mögliche Ursache

Die Assemblys HubScenario und HubHelper wurden nicht ordnungsgemäß bereitgestellt, da die Assemblyschlüsseldateien in den Projekten nicht festgelegt wurden.

Lösung

Legen Sie die Assemblyschlüsseldateien für die Projekte HubScenario und HubHelper fest. Weitere Informationen finden Sie unter HubScenario-Beispiel.

Führen Sie setupx64.bat aus, um das Double Action PIPAutomation Orchestration-Beispiel für SQL Server 2008 R2/2008 SP1 einzurichten.

Symptom

Wenn Sie setup.bat ausführen, um das Double Action PIPAutomation Orchestration-Beispiel zu erstellen und zu initialisieren, wird die gespeicherte PipAutomationGetAction-Prozedur in der BTARNData-Datenbank nicht erstellt.

Mögliche Ursache

Sie haben setup.bat auf einem 64-Bit-Computer oder auf einer BizTalk Server-Installation ausgeführt, die unter SQL Server 2008 R2/2008 SP1 ausgeführt wird. Für beide Instanzen müssen Sie setupx64.bat ausführen.

Lösung

Führen Sie setupx64.bat aus, um die gespeicherte Prozedur zu erstellen. Weitere Informationen finden Sie unter Double Action PIPAutomation Orchestration.

Aktivieren der BTARN-Anwendungspools für 32 Bit unter Windows Server 2008, 64-Bit-Windows-Betriebssystem

So führen Sie das BTARN End-to-End-Szenario unter Windows Server 2008,64-Bit-Windows-Betriebssystem aus, Internetinformationsdienste-Manager 7.5/7.0.

  1. Aktivieren Sie die BTARN-Anwendungspools für 32 Bit.

  2. Fügen Sie einen HTTP-Handler für *.dll hinzu, der auf die IsapiModule-Filter verweist.

Weitere Informationen

BtarnClean
Loopback