Share via


Compilerfehler CS1617

Ungültige Option „option“ für LangVersion. Verwenden Sie <LangVersion>?</LangVersion>, um unterstützte Werte aufzulisten.

Dieser Fehler tritt auf, wenn Sie den Befehlszeilenschalter oder die Projekteinstellung LangVersion verwendet, aber keine gültige Sprachoption angegeben haben. Überprüfen Sie die Syntax der Befehlszeile oder die Projekteinstellung, und ändern Sie sie in eine der aufgeführten Optionen, um diesen Fehler zu beheben.

Beim Kompilieren mit csc -langversion:ISO wird z. B. der Fehler CS1617 generiert.

Gültige Werte für -LangVersion

Die gültigen Werte für die Sprachversionen hängen von der verwendeten .NET-Version ab. Weitere Informationen dazu, welche Sprachversion für die jeweilige .NET-Version verfügbar ist, finden Sie in den Sprachversionsregeln. Falls Sie diesen Fehler erhalten, während Sie versuchen, eine neuere Sprachversion zu verwenden, nehmen Sie entweder ein Downgrade auf eine niedrigere Sprachversion vor, oder aktualisieren Sie Ihr .NET SDK auf eine Version, die diese Sprachversion unterstützt.

Die folgende Tabelle enthält die aktuell gültigen Werte für -langversion:

Wert Bedeutung
preview Der Compiler akzeptiert jede gültige Sprachsyntax der letzten Vorschauversion.
latest Der Compiler akzeptiert die Syntax der neuesten veröffentlichte Version des Compilers (einschließlich Nebenversionen).
latestMajor
oder default
Der Compiler akzeptiert die Syntax der neuesten veröffentlichte Hauptversion des Compilers.
12.0 Der Compiler akzeptiert nur Syntax von C# 12 oder niedriger.
11.0 Der Compiler akzeptiert nur Syntax von C# 11 oder niedriger.
10.0 Der Compiler akzeptiert nur Syntax, die in C# 10 oder niedriger enthalten ist.
9.0 Der Compiler akzeptiert nur Syntax, die in C# 9 oder niedriger enthalten ist.
8.0 Der Compiler akzeptiert nur Syntax, die in C# 8.0 oder niedriger enthalten ist.
7.3 Der Compiler akzeptiert nur Syntax, die in C# 7.3 oder früher enthalten ist.
7.2 Der Compiler akzeptiert nur Syntax, die in C# 7.2 oder früher enthalten ist.
7.1 Der Compiler akzeptiert nur Syntax, die in C# 7.1 oder früher enthalten ist.
7 Der Compiler akzeptiert nur Syntax, die in C# 7.0 oder früher enthalten ist.
6 Der Compiler akzeptiert nur Syntax, die in C# 6.0 oder früher enthalten ist.
5 Der Compiler akzeptiert nur Syntax, die in C# 5.0 oder früher enthalten ist.
4 Der Compiler akzeptiert nur Syntax, die in C# 4.0 oder früher enthalten ist.
3 Der Compiler akzeptiert nur Syntax, die in C# 3.0 oder früher enthalten ist.
ISO-2
oder 2
Der Compiler akzeptiert nur Syntax, die in ISO/IEC 23270:2006 C# (2.0) enthalten ist.
ISO-1
oder 1
Der Compiler akzeptiert nur Syntax, die in ISO/IEC 23270:2003 C# (1.0/1.2) enthalten ist.