Behandeln von Problemen mit Vorhersagen
Dieser Artikel hilft Ihnen bei der Problembehandlung und Behebung von Problemen im Zusammenhang mit vorhersagen in Microsoft Dynamics 365 Sales.
Problem 1: Beim Versuch, eine gebietsbasierte Vorhersage zu erstellen, wird ein Fehler angezeigt.
Symptome
Wenn Sie versuchen, eine gebietsbasierte Vorhersage zu erstellen, wird ein Fehler angezeigt. Außerdem werden die Daten in einer gebietsbasierten Vorhersage möglicherweise nicht aktualisiert.
Ursache
Wenn Systemupdates ausgeführt werden, wird die Hierarchie der Gebietsentität deaktiviert (obwohl Sie sie zuvor aktiviert haben), wodurch dieser Fehler verursacht wird.
Lösung
Um dieses Problem zu beheben, müssen Sie die Hierarchie in der territory_parent_territory Beziehungsdefinition aus Beziehungen aktivieren. Gehen Sie folgendermaßen vor:
Wechseln Sie zu Erweiterte Einstellungen.
Die Seite erweiterte Einstellungen wird auf einer Registerkarte geöffnet.
Wählen Sie Einstellungen>Anpassungen anpassungen>aus.
Die Power Apps-Einstellungsseite wird geöffnet.
Wählen SieDatenentitäten> und dann Gebiet aus.
Wählen Sie auf der Seite Gebiet die Registerkarte Beziehungen und dann Übergeordnetes Element aus.
Aktivieren Sie im Dialogfeld n :1 das Kontrollkästchen Hierarchisch , und wählen Sie dann Fertig aus.
Speichern und schließen Sie die Entität.
Problem 2: Das Feld für die Vorhersagekategorie kann in Verkaufschancenformularen nicht ausgeblendet werden.
Ursache
Manchmal zeigt die App das Feld Prognosekategorie in Verkaufschancenformularen an, auch nachdem es standardmäßig durch Formularanpassungen als unsichtbar konfiguriert wurde.
Lösung
Um diesen Fehler zu beheben, müssen Sie das Feld Prognosekategorie aus dem Formular löschen. Gehen Sie folgendermaßen vor:
Wählen Sie in Ihrer App auf der Navigationsleiste das Symbol Einstellungen und dann Erweiterte Einstellungen aus.
Die Seite Geschäftsverwaltungseinstellungen wird in einer neuen Browserregisterkarte geöffnet.
Wählen Sie auf der Navigationsleiste Einstellungen und dann unter Anpassungdie Option Anpassungen aus.
Wählen Sie System anpassen aus.
Erweitern Sie unter Komponenten im Projektmappen-Explorer Entitäten, erweitern Sie Verkaufschance, und wählen Sie dann Formulare aus.
Öffnen Sie das Formular Verkaufschance des Formulartyps Main.
Das Verkaufschancenformular wird in einem neuen Fenster geöffnet.
Wählen Sie im Abschnitt Zusammenfassung das Feld Prognosekategorie und dann Entfernen aus.
Speichern und veröffentlichen Sie die Konfiguration.
Problem 3: Vorhersagen können nicht angezeigt werden
Ursache
Wenn Sie die vorherige Version der Vorhersage verwendet und auf die neueste Version aktualisiert haben, wird die Vorhersagewebsiteübersicht möglicherweise nicht aktualisiert. Dies kann durch das Vorhandensein einer nicht verwalteten Ebene der Sales Hub-App verursacht werden, die es der Websiteübersicht der Vorhersage ermöglicht, die vorherige Version der Vorhersage zu öffnen.
Die folgende Abbildung ist ein Beispiel für die vorherige Version der Vorhersagestartseite.
Lösung
Um dieses Problem zu beheben, aktualisieren Sie den Vorhersage-Siteübersichtseintrag in das Raster für den letzten Vorhersageeintrag. Weitere Informationen finden Sie unter Hinzufügen von Vorhersageraster- und Konfigurationsoptionen in der Siteübersicht.
Problem 4: Das Vorhersageraster kann nicht geladen werden, und ein Fehler wird angezeigt.
Ursache
Der ForecastInstanceActions-Prozess wird deaktiviert. Der Grund kann sein, dass sich der Besitzer eines organization geändert hat, was dazu führt, dass das Vorhersageraster nicht geladen wird. Der in der folgenden Abbildung gezeigte Fehler wird angezeigt.
Die Aktion (ForecastInstanceActions) zum Abrufen von Vorhersagen wurde deaktiviert.
Lösung
Um diesen Fehler zu beheben, aktivieren Sie den ForecastInstanceActions-Prozess . Gehen Sie folgendermaßen vor:
Wechseln Sie zu Erweiterte Einstellungen, und wählen Sie dann Einstellungen>Prozesscenterprozesse> aus.
Geben Sie in das Suchfeld ForecastInstanceActions ein. Sie können sehen, dass sich der Prozess im Status Entwurf befindet.
Wählen Sie den Prozess und dann Aktivieren aus.
Wählen Sie in der Bestätigungsmeldung Aktivieren aus.
Vergewissern Sie sich, dass der Prozessstatus Aktiviert lautet, und schließen Sie dann Einstellungen.
Problem 5: Drilldowndaten können in einem Vorhersageraster nicht angezeigt werden
Ursache
Sie verfügen nicht über genügend Berechtigungen für die Entität Forecast Configuration , um Drilldowndaten im Vorhersageraster anzuzeigen. Der in der folgenden Abbildung gezeigte Fehler wird angezeigt.
Ein Problem ist aufgetreten.
Fehler beim Abrufen der Vorhersagedatensätze.
Laden Sie die Browserseite erneut neu.
Lösung
Um diesen Fehler zu beheben, muss Ihr Administrator Ihrer Sicherheitsrolle Leseberechtigungen für die Entität Forecast Configuration bereitstellen. Gehen Sie folgendermaßen vor:
Wechseln Sie zu Erweiterte Einstellungen, und wählen Sie dann Einstellungen>Sicherheitssicherheitsrollen> aus.
Wählen Sie die Sicherheitsrolle aus, für die Sie die Berechtigungen anwenden möchten.
Wählen Sie auf der Seite Sicherheitsrolle die Registerkarte Benutzerdefinierte Entitäten aus, und wechseln Sie zur Zeile Prognosekonfiguration .
Wählen Sie die Leseberechtigungen aus, und geben Sie sie an.
Schließen Sie die Einstellungen.
Problem 6: Vorhersagekategoriefelder werden nicht aktualisiert
Ursache
Nach dem Aktualisieren des Felds "Vorhersagekategorie" in "Gewonnen " oder " Verloren" in einer Vorhersage werden die Verkaufschancen weiterhin im vorherigen Pipelinebucket angezeigt. Dieser Fehler tritt auf, weil der Workflow Für die Zuordnung von Verkaufschancenprognosenkategorien in Ihrem organization deaktiviert ist.
Lösung
Um den Fehler zu beheben, aktivieren Sie den Workflow Opportunity Forecast Category Mapping Process . Gehen Sie folgendermaßen vor:
Wechseln Sie zu Erweiterte Einstellungen, und wählen Sie dann Einstellungen>Anpassungen>System anpassen aus.
Wählen Sie in der Sitemap die Option Prozesse aus.
Wählen Sie den Workflow Verkaufschance-Prognosekategoriezuordnungsprozess und dann Aktivieren aus.
Die Vorhersagekategorien in den Verkaufschancen werden ordnungsgemäß aktualisiert. Die Verkaufschancen, die vor der Aktivierung des Workflows geändert wurden, müssen manuell geändert werden. Öffnen Sie außerdem den Workflow Opportunity Forecast Category Mapping Process , und überprüfen Sie, ob die Bedingungen für jede Vorhersagekategorie ordnungsgemäß definiert sind.
Speichern und schließen Sie die Einstellungen.
Problem 7: Eine Vorhersage mit einer hierarchiebezogenen Spalte vom Suchtyp kann nicht aktiviert werden.
Ursache
Dieses Problem tritt auf, weil der Benutzer "Dynamics 365 Sales Forecasting" nicht über die Leseberechtigung für die hierarchiebezogene Suchentität verfügt.
Lösung
Führen Sie die folgenden Schritte aus, um das Problem zu beheben:
Wechseln Sie zu Erweiterte Einstellungen, und wählen Sie Einstellungen>Systemsicherheitsrollen>>aus.
Öffnen Sie die Rolle Prognose-AppBenutzer , und wählen Sie die Registerkarte aus, auf der der Entitätstyp vorhanden ist.
Aktivieren Sie die Leseberechtigung auf organization Ebene für den Entitätstyp des Nachschlagefelds.
Speichern Sie die Änderungen.
Problem 8: Aktivieren einer Vorhersage nicht möglich
Ursache
Die Vorhersageaktivierung schlägt aus mehreren Gründen fehl.
Lösung
Führen Sie die folgenden Schritte aus, um das Problem zu beheben:
- Stellen Sie sicher, dass Sie alle obligatorischen Konfigurationen für Ihr Vorhersagemodell ausgeführt haben.
- Stellen Sie sicher, dass Hierarchiefilter in der Vorhersagekonfiguration nicht die gesamte Hierarchie herausfiltern. Wechseln Sie im Schritt Allgemein zum Abschnitt Vorschau, um sicherzustellen, dass die Hierarchie vorhanden ist. Weitere Informationen finden Sie unter Hinzufügen zusätzlicher Filter zu einer Vorhersage.
Problem 9: Die Vorhersagekonfigurationsoption kann in den App-Einstellungen nicht gefunden werden
Ursache
Die Vorhersagekonfigurationsoption ist aus folgenden Gründen in den App-Einstellungen der Sales Hub-App möglicherweise nicht sichtbar:
- Sie verfügen nicht über die Leseberechtigung für die Vorhersagekonfigurationsentität.
- Ihr Administrator hat das Vorhersageraster und die Konfiguration nicht manuell im Abschnitt Leistungsverwaltung hinzugefügt.
Lösung
Führen Sie die folgenden Schritte aus, um das Problem zu beheben:
- Weisen Sie dem Benutzer, der Vorhersagekonfigurationen erstellen und verwalten kann, die Sicherheitsrolle "Forecast Manager" zu.
- In der Prognosekonfiguration müssen die Elemente des Vorhersagenavigationsbereichs in einer benutzerdefinierten App hinzugefügt werden.
Problem 10: Vorhersagen für die Benutzerhierarchie können nicht angezeigt werden
Ursache
Dieses Problem tritt aufgrund unzureichender Berechtigungen zum Anzeigen der Vorhersage auf.
Lösung
Um das Problem zu beheben, stellen Sie Folgendes sicher:
Eine der folgenden Bedingungen ist erfüllt:
Sie sind der Besitzer der Vorhersage. Das Feld Besitzersuche im Schritt Berechtigungen der Vorhersagekonfiguration zeigt an, wer der Besitzer ist.
Sie sind Teil der Sicherheitsrollen, die über die Leseberechtigung verfügen, wie im Schritt Berechtigungen der Vorhersagekonfiguration konfiguriert.
Jemand hat die Vorhersage für Sie freigegeben. Weitere Informationen finden Sie unter Aktivieren oder Deaktivieren der Vorhersagefreigabe.
Das Feld Besitzersuche im Schritt Berechtigungen der Vorhersagekonfiguration ist nicht auf Keine festgelegt. Wenn sie auf Keine festgelegt ist, kann niemand die Vorhersage anzeigen.
Problem 11: Vorhersagefeldwerte zeigen null oder leer im Vorhersageraster an
Ursache
Für die Spalten, die den Felden Selector, Amount und Date zugeordnet sind, ist möglicherweise die Sicherheit auf Feldebene aktiviert.
Lösung
Um das Problem zu beheben, müssen Sie dem Benutzer # Dynamics 365 Sales Forecasting in den Sicherheitsprofilen des Felds die Berechtigung Lesen erteilen. Andernfalls wird in der Spalte für alle Benutzer 0 angezeigt. Führen Sie die folgenden Schritte aus, um die Feldsicherheitsprofile zu konfigurieren:
- Wechseln Sie zu Einstellungen>Erweiterte Einstellungen>Sicherheitsfeld>Sicherheitsprofile.
- Wählen Sie das Feldsicherheitsprofil aus, das dem Feld zugeordnet ist, das 0 anzeigt.
- Wählen Sie Benutzer>Hinzufügen aus.
- Suchen Sie nach dem # Dynamics 365 Sales Forecasting-Benutzer, aktivieren Sie das Kontrollkästchen für den Benutzernamen, und wählen Sie dann Hinzufügen auswählen> aus.
- Wählen Sie Feldberechtigungen aus, und erteilen Sie dem Feld Leseberechtigung .
- Speichern und schließen Sie das Profil.
Berechnen Sie die Vorhersage neu, und überprüfen Sie, ob die Spalte geeignete Werte enthält.
Problem 12: Die Vorhersagespalte auf der Seite "Prognosen" kann nicht manuell neu berechnet werden.
Ursache
Die Vorhersagespalte auf der Seite Prognosen kann nicht manuell neu berechnet werden.
Lösung
Die Vorhersagespalte in der Prognose wird automatisch nach sieben Tagen neu berechnet und unterstützt keine manuelle Neuberechnung. Dies liegt daran, dass Vorhersagen auf KI-gesteuerten Modellen basieren, die historische Daten und die offene Vertriebspipeline betrachten, um zukünftige Umsatzergebnisse vorherzusagen. Die Vorhersagespalte zeigt den vorhergesagten Umsatz für jeden Verkäufer und Manager basierend auf dem Feld Status einer Verkaufschance an. Um die Genauigkeit der Vorhersagen zu optimieren, stellen Sie sicher, dass die Werte der Vorhersagekategorie mit dem Feld Status synchron gehalten werden. Für die out-of-the-box-Vorhersagekategorie stellt ein Workflow sicher, dass die Vorhersagekategorie mit dem richtigen Wert aktualisiert wird, wenn eine Verkaufschance als Gewonnen oder Verloren geschlossen wird.
Problem 13: Vorhersage der zugrunde liegenden Rasteransicht ist deaktiviert (schreibgeschützt), wenn die Seite geladen wird
Ursache
Ein in der Vorhersagekonfiguration konfiguriertes benutzerdefiniertes JavaScript verhindert, dass das Raster bearbeitet werden kann.
Lösung
Um das Problem zu beheben, überprüfen Sie den benutzerdefinierten JavaScript-Code, und überprüfen Sie, ob die zugrunde liegende Datensatzrasteransicht deaktiviert wird.