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Das Attribut "MailNickName" oder "Alias" in Exchange Online stimmt nicht mit dem wert überein, was in Exchange lokal festgelegt ist.

Symptome

Das Alias Attribut oder Mailnickname in Microsoft Exchange Online stimmt nicht mit dem überein, was in der lokalen Exchange-Umgebung für ein synchronisiertes Benutzerkonto festgelegt ist.

Ursache

Dieses Problem tritt auf, wenn Änderungen am Benutzerprinzipalnamen (UPN) für den Benutzer vorgenommen werden und der Mailnickname Attributwert in das Präfix des UPN geändert wird.

Lösung

Aktualisieren Sie das Alias Attribut oder Mailnickname , um dieses Problem zu beheben. Wenden Sie hierzu eine der folgenden Methoden an.

Methode 1: Verwenden der Exchange-Verwaltungsshell

  1. Ändern Sie den vorhandenen Alias Attributwert, sodass die Änderung von Microsoft Entra Connect gefunden wird. Dadurch sollte die Änderung mit Microsoft 365 synchronisiert werden. Verwenden Sie dazu entweder das Set-Mailbox Cmdlet oder Set-RemoteMailbox , basierend auf dem Empfängertyp in Exchange lokal.

    • Set-RemoteMailbox

      $alias=Get-remotemailbox <user@domain.com>
      Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)1"
      
    • Set-Mailbox

      $alias=Get-mailbox <user@domain.com>
      Set-Mailbox <user@domain.com> -alias "$($alias.alias)1"**
      
  2. Starten Sie eine Deltasynchronisierung über Microsoft Entra Connect, oder warten Sie, bis Microsoft Entra Connect das Delta ausführen kann. Im Idealfall sollten die in Schritt 1 vorgenommenen Änderungen mit Microsoft 365 synchronisiert werden.

  3. Ändern Sie den Wert des Alias Attributs in den ursprünglichen Wert. Führen Sie dazu eines der folgenden Cmdlets aus:

    Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)"
    
    Set-Mailbox <user@domain> -alias "$($alias.alias)"
    
  4. Starten Sie eine Delta-Synchronisierung über Microsoft Entra Connect, oder warten Sie, bis Microsoft Entra Connect das Delta> ausgeführt hat. Idealerweise sollten die Änderungen mit Microsoft 365 synchronisiert werden.

Methode 2: Verwenden des Active Directory PowerShell-Moduls

  1. Ändern Sie den Mailnickname Attributwert, sodass die Änderung von Microsoft Entra Connect erkannt wird. Dadurch sollte die Änderung mit Microsoft 365 synchronisiert werden. Führen Sie dazu den folgenden Satz von Cmdlets aus:

    $mailnickname=Get-ADUser -Properties * -Filter {name -like '<username>*'}
    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)1"
    
  2. Starten Sie eine Deltasynchronisierung über Microsoft Entra Connect, oder warten Sie, bis Microsoft Entra Connect das Delta ausführen kann. Im Idealfall sollten die in Schritt 1 vorgenommenen Änderungen mit Microsoft 365 synchronisiert werden.

  3. Ändern Sie den Wert des Mailnickname Attributs in den ursprünglichen Wert. Führen Sie dazu das folgenden Cmdlet aus:

    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)"
    
  4. Starten Sie eine Deltasynchronisierung über Microsoft Entra Connect, oder warten Sie, bis Microsoft Entra Connect das Delta ausführen kann. Im Idealfall sollten die in Schritt 1 vorgenommenen Änderungen mit Microsoft 365 synchronisiert werden.