OWA oder ECP funktioniert nach der Installation eines Sicherheitsupdates nicht mehr.

Problembeschreibung

Nachdem Sie ein Sicherheitsupdate auf einem Server installiert haben, auf dem Microsoft Exchange Server ausgeführt wird, funktionieren entweder Outlook im Web (OWA) oder Exchange Control Panel (ECP) oder beide Anwendungen auf dem Server nicht mehr.

OWA zeigt die folgende Fehlermeldung an:

Ein Fehler ist aufgetreten
Ihre Anfrage konnte nicht abgeschlossen werden. HTTP-Statuscode: 500

Screenshot der OWA-Fehlermeldung.

ECP zeigt die folgende Fehlermeldung an:

Serverfehler in der „/ecp“-Anwendung.
Datei oder Assembly „Microsoft.Exchange.Common, Version=15.0.0.0 ...Culture=neutral, PublicKeyToken=31bf3856ad364e54“ oder eine ihrer Abhängigkeiten konnte nicht geladen werden. Die angegebene Datei wurde nicht gefunden.

Screenshot der E C P-Fehlermeldung.

Ursache

Diese Fehler treten auf, wenn das Sicherheitsupdate manuell auf einem Server installiert wurde, auf dem die Benutzerkontensteuerung (User Account Control, UAC) aktiviert ist, jedoch ohne erhöhte Berechtigungen.

Lösung

Verwenden Sie erhöhte Berechtigungen, um das Sicherheitsupdate auf dem Server neu zu installieren.

  1. Wählen Sie Start aus, und geben Sie cmd ein.
  2. Klicken Sie in den Suchergebnissen mit der rechten Maustaste auf Eingabeaufforderung, und wählen Sie Als Administrator ausführen aus.
  3. Wenn das Fenster Benutzerkontensteuerung angezeigt wird, wählen Sie die Option zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten aus, und klicken Sie dann auf Weiter. Wenn das UAC-Fenster nicht angezeigt wird, fahren Sie mit dem nächsten Schritt fort.
  4. Geben Sie den vollständigen Pfad der MSP-Datei für das Sicherheitsupdate ein, und drücken Sie die EINGABETASTE .
  5. Nachdem das Update installiert wurde, starten Sie den Server neu.

Überprüfen Sie, ob Sie jetzt auf OWA und ECP auf dem Server zugreifen können, ohne eine Fehlermeldung zu erhalten.

Wenn die ECP-Fehlermeldung weiterhin angezeigt wird, gehen Sie wie folgt vor:

  1. Starten Sie den IIS-Manager auf dem Server.

  2. Navigieren Sie zu Exchange-Back-End-Website>Virtuelles ECP-Verzeichnis

  3. Wählen Sie Anwendungseinstellungen>BinsearchFolder aus.

  4. Überprüfen Sie die Pfade zu den aufgeführten Exchange-Verzeichnissen. Eventuell werden Verzeichnispfade angezeigt, die den folgenden ähneln:

                                 %ExchangeInstallDir%bin;
    %ExchangeInstallDir%bin\CmdletExtensionAgents;
    %ExchangeInstallDir%ClientAccess\Owa\bin

  5. Ersetzen Sie die Pfade durch die folgenden Pfade:

                                 C:\Programme\Microsoft\Exchange Server\V15\bin;
    C:\Programme\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;
    C:\Programme\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin

    Hinweis Die Pfade müssen auf den Speicherort zeigen, an dem Exchange Server installiert ist. In den folgenden Beispielen wird davon ausgegangen, dass das Programm auf Laufwerk C installiert ist und die Version Microsoft Exchange Server 2013 ist. Wenn es auf einem anderen Laufwerk Ihres Servers installiert ist oder Sie eine andere Version wie Microsoft Exchange Server 2010 verwenden, verwenden Sie den Pfad und die Versionsinformationen, die für Ihre Installation zutreffen.

  6. Navigieren Sie zu einem Ordner, der Exchange Server-Skripte enthält. Skripte befinden sich standardmäßig im folgenden Pfad für Exchange Server 2013:

    C:\Programme\Microsoft\Exchange Server\V15\v15\Bin

    Hinweis Für Exchange Server 2010 werden die Skripte stattdessen im Ordner V14 sein.

  7. Starten Sie Exchange Management Shell als Administrator und führen Sie die folgenden Skripte aus: .\UpdateCas.ps1 und .\UpdateConfigFiles.ps1.

  8. Beenden Sie Exchange Management Shell und öffnen Sie ein Eingabeaufforderungsfenster als Administrator.

  9. Ausführen iisreset.

  10. Starten Sie den Server neu, und stellen Sie sicher, dass beim Zugriff auf ECP keine Fehlermeldung mehr angezeigt wird.