Freigeben über


Beim Hochladen von Anlagen aus Outlook im Web werden zwei OneDrive-Konten angezeigt.

Symptome

Wenn Sie versuchen, Anlagen aus Outlook im Web hochzuladen, werden im Menü Hochladen anstelle eines one one-Kontos zwei OneDrive-Konten angezeigt.

Screenshot von zwei OneDrive-Konten im Menü

Ursache

Dieses Problem tritt auf, wenn Sie sich in einer Exchange-Hybridumgebung befinden, die über ein Postfach auf Microsoft Exchange Server lokal und ein OneDrive for Business Konto in Microsoft 365 verfügt, und wenn das OneDrive-Konto an einen anderen geografischen Standort verschoben wurde. Nach der OneDrive-Verschiebung werden die internen und externen Host-URLs von "Meine Website" in der OwaMailboxPolicy Einstellung nicht aktualisiert.

Lösung

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.

Methode 1: Aktualisieren der Host-URLs für meine Website

Führen Sie das folgende Cmdlet aus, um die internen und externen Host-URLs für Meine Website in der OwaMailboxPolicy Einstellung auf die Werte für den neuen geografischen Standort von OneDrive zu aktualisieren:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL <new_OneDrive_URL> -ExternalSPMySiteHostURL <new_OneDrive_URL>

Methode 2: Festlegen von Werten auf Null

Führen Sie das folgende Cmdlet aus, um die internen und externen Host-URLs für meine Website in der OwaMailboxPolicy Einstellung auf Null festzulegen:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL $Null -ExternalSPMySiteHostURL $Null

Nachdem Sie die OwaMailboxPolicy Einstellung mithilfe einer der Methoden aktualisiert haben, erstellen Sie ein neues Outlook-Profil, um die aktualisierten Werte zu verwenden. Dies ist erforderlich, da die vorherigen OwaMailboxPolicy Einstellungen in Ihrem aktuellen Outlook-Profil zwischengespeichert werden und nicht aktualisiert werden können.

Weitere Informationen zu dieser Einstellung finden Sie unter Konfigurieren der Dokumentzusammenarbeit mit OneDrive for Business und Exchange 2016 lokal.OwaMailboxPolicy