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Symptome
Wenn Sie eine Aufgabenanforderungsnachricht in Outlook senden, enthält die Aufgabenanfrage des Empfängers nicht die Schaltflächen "Annehmen " und "Ablehnen " oder "Lesbare Aufgabendetails". Dieses Problem kann für Empfänger auftreten, die intern oder extern in Ihrer Microsoft Exchange-Organisation sind.
Die Aufgabenanforderung des Empfängers könnte z. B. dem folgenden Beispiel ähneln.
Der nächste Screenshot zeigt, wie die Aufgabenanforderung aussehen soll.
Ursache
Outlook hat die Aufgabenanforderung als RTF-Nachricht (Rich Text Format) gesendet, aber eine Transportkomponente hat das Nachrichtenformat in HTML geändert. Die Konvertierung in HTML hat die Schaltflächenelemente entfernt und das Nachrichtenlayout gekrambliert.
Wenn der Empfänger in Ihrer Exchange-Organisation intern ist, hat Ihre Exchange-Konfiguration möglicherweise Folgendes:
- Ein ausgehender Connector , der Nachrichten über einen externen Dienst weiter leitet. Der interne Nachrichtenfluss behält das Format von RTF-Nachrichten bei, externe Dienste konvertieren jedoch häufig RTF-Nachrichten in HTML. Beispielsweise konvertieren Signatur- und Datenschutzhaftungsausschlussdienste RTF-Nachrichten in HTML.
Wenn sich der Empfänger außerhalb Ihrer Exchange-Organisation befindet, hat Ihre Exchange-Konfiguration möglicherweise eine der folgenden Optionen:
Ein ausgehender Connector, der Nachrichten über einen externen Dienst leitet, der das Nachrichtenformat in HTML ändert.
Eine Remotedomäneneinstellung
TNEFEnabled
, die ausgehende RTF-Nachrichten in HTML konvertiert.
Lösung
Um das Problem zu beheben, überprüfen Sie die folgenden Einstellungen, und nehmen Sie dann die entsprechenden Änderungen vor:
Überprüfen Sie bei internen und externen Empfängern, ob ein ausgehender Connector Nachrichten über einen externen Dienst weiter leitet. Wenn dies der Fall ist, sollten Sie der Nachrichtenflussregel eine Ausnahme hinzufügen, die Nachrichten an diesen Connector weiter leitet. Sie können z. B. die Weiterleitung von Aufgabenanforderungsnachrichten durch externe Dienste ausschließen, indem Sie eine Ausnahme für Nachrichten erstellen, die einen Betreff haben, der mit "
Task request:
" beginnt.Überprüfen Sie bei externen Empfängern die
TNEFEnabled
Einstellung für alle Remotedomänen. Führen Sie zu diesem Zweck den folgenden Befehl aus:Get-RemoteDomain | Where {$_.TNEFEnabled -ne $true}
Wenn die TNEFEnabled
Einstellung für eine Remotedomäne lautet $null
oder $false
, konvertiert Exchange RTF-Nachrichten für Empfänger in dieser Domäne in HTML. Wenn beispielsweise die TNEFEnabled
Einstellung für Ihre Standard-Remotedomäne lautet und dies Ihre einzige Remotedomäne ist $null
, konvertiert Exchange alle externen RTF-Nachrichten in HTML. Führen Sie die folgenden Schritte aus, um das Problem für einen betroffenen externen Empfänger zu beheben:
Erstellen Sie eine Remotedomäne für die Domäne des betroffenen externen Empfängers.
Legen Sie
TNEFEnabled
diese Einstellung$true
für diese Domäne fest, indem Sie den folgenden Befehl ausführen:Set-RemoteDomain -Identity <name of the new remote domain> -TNEFEnabled $true
Notiz
Vermeiden Sie die Einstellung TNEFEnabled
für $true
die Standard-Remotedomäne, da sich diese Änderung auf alle externen Empfänger auswirkt, einschließlich derjenigen, deren E-Mail-Client RTF-Nachrichten möglicherweise nicht unterstützt.