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Fehler "Es ist nicht genügend freier Arbeitsspeicher vorhanden, um dieses Programm auszuführen" in Outlook

Symptome

Wenn Sie während der Verwendung von Microsoft Outlook auf einen Ordner klicken, wird eine der folgenden Fehlermeldungen angezeigt:

Fehlermeldung 1

Es ist nicht genügend freier Arbeitsspeicher vorhanden, um dieses Programm auszuführen. Beenden Sie ein oder mehrere Programme, und versuchen Sie es dann erneut.

Fehlermeldung 2

Der Ordner kann nicht angezeigt werden. Es ist nicht genügend freier Arbeitsspeicher vorhanden, um dieses Programm auszuführen. Beenden Sie ein oder mehrere Programme, und versuchen Sie es dann erneut.

Fehlermeldung 3

Der Ordner kann nicht angezeigt werden. Es ist nicht genügend freier Arbeitsspeicher vorhanden, um dieses Programm auszuführen. Beenden Sie ein oder mehrere Programme, und versuchen Sie es dann erneut.

Dieses Problem tritt möglicherweise häufiger auf, wenn Sie Add-Ins in Outlook verwenden.

Ursache

Dieses Problem tritt auf, weil nicht genügend Arbeitsspeicher zum Anzeigen des Ordners vorhanden ist. Dies kann aus verschiedenen Gründen verursacht werden. Einer dieser Gründe ist, dass Anpassungen, z. B. das Festlegen eines Filters, an der Ordneransicht vorgenommen wurden. Einige Add-Ins in Outlook abonnieren viele Ordner in einigen oder allen Speicher im Profil. Jedes MAPI-Abonnement verwendet freigegebenen Arbeitsspeicher. Daher können große Kombinationen von Elementen und Ordnern den verfügbaren Arbeitsspeicher aufgebraucht haben.

Problemumgehung

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung, bevor Sie sie ändern, damit Sie sie bei Bedarf wiederherstellen können.

Um das im Abschnitt "Symptome" beschriebene Problem zu umgehen, erhöhen Sie den verfügbaren Arbeitsspeicher. Führen Sie die folgenden Schritte aus, um die Größe des Speicherheaps zu erhöhen:

  1. Beenden Sie Outlook.

  2. Wählen Sie Start und dann Ausführen aus, geben Sie regedit ein, und wählen Sie anschließend OK aus.

  3. Klicken Sie auf den folgenden Registrierungsunterschlüssel:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und wählen Sie dann DWORD-Wert aus.

  5. Geben Sie SharedMemMaxSize ein, und drücken Sie dann die EINGABETASTE.

  6. Klicken Sie mit der rechten Maustaste auf SharedMemMaxSize, und wählen Sie dann Ändern aus.

  7. Geben Sie im Feld Wert den Wert 300000 ein. Verwenden Sie die Standardbasis von Hexadezimal.

  8. Wählen Sie OK aus.

  9. Klicken Sie auf den folgenden Registrierungsunterschlüssel:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook

    Hinweis

    Möglicherweise müssen Sie die Unterschlüssel Anwendungen und Outlook erstellen, wenn sie nicht vorhanden sind.

  10. Zeigen Sie im Menü Bearbeiten auf Neu, und wählen Sie dann DWORD-Wert aus.

  11. Geben Sie SharedMemMaxSize ein, und drücken Sie dann die EINGABETASTE.

  12. Geben Sie im Feld Wert den Wert 300000 ein. Verwenden Sie die Standardbasis von Hexadezimal.

  13. Wählen Sie OK aus.

  14. Klicken Sie im Menü Datei auf Beenden, um den Registrierungs-Editor zu beenden.

Hinweis

Wenn das Problem durch Festlegen der beiden Registrierungswerte auf 0x300000 nicht behoben wird, können Sie die Größe dieser Werte auf 0x800000 erhöhen.

Weitere Informationen

Wenn Sie eine große Outlook-Datendatei (PST) in Outlook geöffnet haben, können Sie die PST-Datei schließen oder die Anzahl der Ordner in der PST-Datei verringern, um das Problem zu beheben.

Wenn Sie über viele Add-Ins verfügen, die in Outlook aktiviert sind, können Sie diese deaktivieren oder deinstallieren, um festzustellen, ob das Problem dadurch behoben wird.

Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:

269794 MAPI Advise()-Aufruf gibt 0x8007000E (E_OUTOFMEMORY) zurück.