MAPI-Lösungen funktionieren nicht, da Outlook.exe nicht ordnungsgemäß unter dem Schlüssel \App-Pfade in der Registrierung registriert ist.

Ursprüngliche KB-Nummer: 2698523

Problembeschreibung

Wenn Sie eine benutzerdefinierte MAPI-Lösung (z. B. ein Outlook-Add-In) verwenden, funktioniert die Lösung möglicherweise nicht, da Outlook.exe nicht ordnungsgemäß in der Windows-Registrierung registriert ist.

Hinweis

Das tatsächliche Problem mit der benutzerdefinierten Lösung hängt davon ab, wie die Outlook.exe Registrierungsinformationen verwendet werden.

Ursache

Dieses Problem kann auftreten, wenn Outlook.exe unter den folgenden Schlüsseln in der Windows-Registrierung nicht ordnungsgemäß registriert ist:

  • 32-Bit-Versionen von Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

  • 64-Bit-Versionen von Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

Wenn Outlook.exe ordnungsgemäß registriert ist, finden Sie unter dem obigen Schlüssel einen \Outlook.exe Unterschlüssel, und unter dem \Outlook.exe Unterschlüssels finden Sie einen Zeichenfolgenwert namens Path, dessen Daten auf den richtigen Pfad zu Outlook.exe auf Ihrem Computer verweisen. Die folgende Abbildung zeigt die richtige Outlook.exe Registrierung unter einer 32-Bit-Version von Windows.

Screenshot der Outlook.exe Registrierung.

Hinweis

Der Pfad zu Outlook.exe auf Ihrem Computer kann von der obigen Abbildung abweichen, wenn Sie Office an einem nicht standardmäßigen Speicherort installiert haben.

Fehlerbehebung

Um dieses Problem zu beheben, reparieren Sie Die Installation von Office.