Freigeben über


Outlook-Suchordner werden nach der Migration von Exchange 2013 zu Exchange 2010 nicht im Onlinemodus aufgefüllt

Ursprüngliche KB-Nummer: 3056652

Symptome

Angenommen, Ihr Postfach wird von Microsoft Exchange Server 2013 oder Exchange Online zu Exchange 2010 migriert, und Ihr Microsoft Outlook-Profil ist im Onlinemodus konfiguriert. In dieser Situation können die folgenden Symptome auftreten:

  • Erinnerungen werden nicht zugestellt.
  • Gekennzeichnete Elemente werden nicht in der liste To-Do angezeigt.
  • Elemente mit einem MRM-Tag laufen nicht ab oder werden nicht gelöscht, wenn der Assistent für verwaltete Ordner ausgeführt wird.

Ursache

Dieses Problem tritt auf, wenn das ausgeblendete SEARCH_RUNNING-Flag für einige Ordner in Ihrem Postfach nicht festgelegt ist.

Lösung

Verwenden Sie zum Beheben dieses Problems das MFCMapi-Hilfsprogramm, um den Suchdienst für jeden betroffenen Ordner neu zu starten. Um MFCMapi herunterzuladen, wechseln Sie zum April 2017 Release von MFCMAPI und MrMAPI.

Führen Sie die folgenden Schritte aus, um MFCMapi zum Neustarten des Suchdiensts zu konfigurieren und zu verwenden:

  1. Starten Sie mfcmapi.exe.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie, um die Option zu aktivieren: Verwenden Sie beim Aufrufen von OpenMsgStore das flag MDB_ONLINE.

  4. Klicken Sie im Menü Sitzung auf Anmelden.

  5. Wenn Sie zur Eingabe eines Profils aufgefordert werden, wählen Sie Ihren Profilnamen aus, und klicken Sie dann auf OK.

  6. Suchen Sie im oberen Fenster die Zeile, die Ihrem Postfach entspricht, und doppelklicken Sie darauf.

    Ihr Postfach wird in der Regel nach Ihrer E-Mail-Adresse aufgelistet, wie im folgenden Screenshot gezeigt.

    Screenshot mit der Suche nach der E-Mail-Adresse.

  7. Erweitern Sie im Navigationsbereich auf der linken Seite Den Stammcontainer.

    • Klicken Sie für das Problem Erinnerungen mit der rechten Maustaste auf den Ordner Erinnerungen , und wählen Sie dann Suchkriterien bearbeiten aus.

    • Klicken Sie für das To-Do Problem mit der rechten Maustaste auf den Ordner To-Do Suche, und wählen Sie dann Suchkriterien bearbeiten aus.

    • Klicken Sie für das MRM-Problem mit der rechten Maustaste auf den Ordner AllItems , und wählen Sie dann Suchkriterien bearbeiten aus.

      Der folgende Screenshot zeigt z. B. den Ordner AllItems unter Stammcontainer.

      Screenshot des Ordners

  8. Suchen Sie im zweiten Feld Suchstatus nach dem wert SEARCH_RUNNING. Wenn SEARCH_RUNNING nicht angezeigt wird, fahren Sie mit dem nächsten Schritt fort.

    Screenshot des SEARCH_RUNNING Werts im zweiten Suchstatusfeld.

  9. Ersetzen Sie im ersten Feld Suchflags den vorhandenen Text durch den wert 0x2 . Sobald Sie mit der Eingabe von 0x2 fertig sind, wird das zweite Feld "Suchflags " mit "RESTART_SEARCH" aufgefüllt, wie im folgenden Screenshot gezeigt. Klicken Sie unten im Fenster auf OK . Dadurch wird der Suchdienst für diesen Ordner neu gestartet.

    Screenshot des zweiten Felds

Weitere Informationen

Wenn "SEARCH_RUNNING" im zweiten Suchstatusfeld angezeigt wird, wenn Sie Schritt 8 ausführen, tritt das im Abschnitt "Symptome" beschriebene Problem nicht auf.