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Dieser Artikel enthält Lösungen für die Probleme, die auftreten können, wenn Sie den Microsoft Dynamics CRM-Client für Outlook starten.
Gilt für: Microsoft CRM Client für Microsoft Office Outlook®
Ursprüngliche KB-Nummer: 911384
Symptome
Symptome 1
Wenn Sie den Microsoft Dynamics CRM-Client für Microsoft Office Outlook öffnen, wird die folgende Fehlermeldung angezeigt:
Fehler beim Laden der Microsoft CRM-Funktionalität, versuchen Sie, Outlook neu zu starten.
Im Ereignisprotokoll werden Fehlermeldungen protokolliert, die dem folgenden ähneln.
Fehlermeldung 1
Die Beschreibung für die Ereignis-ID ( 2 ) in Source ( Microsoft CRM ) wurde nicht gefunden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Nachrichten-DLL-Dateien, um Nachrichten von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag "/AUXSOURCE=" verwenden, um diese Beschreibung abzurufen; Weitere Informationen finden Sie unter Hilfe und Support.
Die folgenden Informationen sind Teil des Ereignisses. MSCRM-Plattformfehlerbericht:
Fehler: Ausnahme von HRESULT: 0x80040220. Fehlermeldung: Ausnahme von HRESULT: 0x80040220. Fehlerdetails: Details zu diesem Fehler wurden von der Plattform nicht bereitgestellt. Quelldatei: Nicht verfügbare Zeilennummer: Nicht verfügbare Stapelablaufverfolgungsinformationen: at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain() at System.Web.UI.Page.ProcessRequest() at System.Web.Web.UI.Page.ProcessRequest(HttpContext context) at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously).
Fehlermeldung 2
Die Beschreibung für ereignis-ID ( 16930 ) in Source ( MSCRMAddin ) kann nicht gefunden werden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Nachrichten-DLL-Dateien, um Nachrichten von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag "/AUXSOURCE=" verwenden, um diese Beschreibung abzurufen; Weitere Informationen finden Sie unter Hilfe und Support. Die folgenden Informationen sind Teil des Ereignisses: 80004005, , CAddin::HrActivateAddin, 472.
Fehlermeldung 3
Die Beschreibung für die Ereignis-ID ( 5944 ) in Source ( MSCRMAddin ) wurde nicht gefunden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Nachrichten-DLL-Dateien, um Nachrichten von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag "/AUXSOURCE=" verwenden, um diese Beschreibung abzurufen; Weitere Informationen finden Sie unter Hilfe und Support. Die folgenden Informationen sind Teil des Ereignisses: 80004005, , CAddin::HrInitializeUI, 137.
Symptome 2
Wenn Sie Windows Vista mit Microsoft Dynamics CRM für Outlook verwenden und die Plattformablaufverfolgung aktivieren, erhalten Sie eine Fehlermeldung, die etwa wie folgt aussieht:
Clientkonfiguration: [Fehler] COM-Registrierungsschlüssel scheinen beschädigt zu sein. Führen Sie den CRM-Konfigurations-Assistenten erneut aus, oder wenden Sie sich an Ihren Microsoft Dynamics CRM-Administrator. >--- System.TypeLoadException: Fehler beim Abrufen der COM-Klassenfactory für komponenten mit CLSID {<ID>} aufgrund des folgenden Fehlers: 80131522. bei
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) bei
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) at
System.Activator.CreateInstance(Type type, Boolean nonPublic) at
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- Ende der inneren Ausnahmestapelablaufverfolgung --- unter
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) bei Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)
Symptome 3
Wenn Sie versuchen, den Microsoft Dynamics CRM-Client für Outlook auszuführen, können Sie die Microsoft Dynamics CRM-Ordnerstruktur nicht anzeigen. Außerdem wird die folgende Fehlermeldung angezeigt:
Fehler beim Laden der Microsoft CRM-Funktionalität, versuchen Sie, Outlook neu zu starten.
Die folgenden Fehlermeldungen werden im Ereignisprotokoll protokolliert:
Ereignistyp: Fehler Ereignisquelle: MSCRMAddin Ereigniskategorie: Keine Ereignis-ID: 16930 Datum: Uhrzeit: Benutzer: N/A Computer: ComputerName Beschreibung: Initialisierung der Microsoft CRM-Benutzeroberfläche fehlgeschlagen. Versuchen Sie, Microsoft Outlook neu zu starten. HR=0x80004005. Context=. Funktion=CAddin::HrActivateAddin. Line=521. Darüber hinaus erhalten Sie die folgende Fehlermeldung in der OUTLOOK-YYDDMM.log Ablaufverfolgungsprotokolldatei: [Datum und Uhrzeit] Prozess: OUTLOOK |Thread:0832 |Kategorie: Unmanaged.Platform |Benutzer: PlatformUser |Ebene: Fehler | HrGetXmlDOM Datei: c:\bt\643\src\application\outlook\v3caddin\xmlutil.cpp Zeile: 179 >hr = 0x80004005
Notiz
In dieser Fehlermeldung stellt der Platzhalter "Datum" und "Uhrzeit" das tatsächliche Datum und die tatsächliche Uhrzeit dar. Beispielsweise könnte das tatsächliche Datum und die aktuelle Uhrzeit "2007-10-19 17:53:26.138" sein.
Symptome 4
Wenn Sie den Microsoft Dynamics CRM-Client für Outlook starten, erhalten Sie die folgende Fehlermeldung:
Fehler beim Laden der Microsoft CRM-Funktionalität, versuchen Sie, Outlook neu zu starten. Darüber hinaus wird im Anwendungsprotokoll auf das Fehlerereignis 80072f19 verwiesen: Ereignis: 16941 Bei der Initialisierung der Fortschrittsanzeige für die Initialisierung ist ein Problem aufgetreten. Starten Sie Microsoft CRM neu, und versuchen Sie es erneut. HR=0x80072f19. Context=. Funktion=CAddin::HrActivateAddin. Line=322.
Symptome 5
Wenn Sie versuchen, Microsoft Office Outlook auf einem Computer zu starten, auf dem der Microsoft Dynamics CRM-Client für Outlook installiert ist, wird die folgende Fehlermeldung angezeigt:
Fehler beim Laden der Microsoft Dynamics CRM-Funktionalität.
Versuchen Sie, Microsoft Outlook neu zu starten.
Wenden Sie sich an den Systemadministrator, wenn Fehler weiterhin bestehen.
Darüber hinaus wird die folgende Fehlermeldung im Anwendungsereignisprotokoll protokolliert:
Ereignistyp: Fehler
Ereignisquelle: MSCRMAddin
Ereigniskategorie: Keine
Ereignis-ID: 16931
Beschreibung:Beim Initialisieren der Microsoft CRM COM-Interoperabilität ist ein Problem aufgetreten. Starten Sie Microsoft CRM neu, und versuchen Sie es erneut. HR=0x80131700. Context=. Funktion=CAddin::HrActivateAddin. Line=274.
Ereignistyp: Fehler
Ereignisquelle: MSCRMAddin
Ereigniskategorie: Keine
Ereignis-ID: 5903
Beschreibung:Das Microsoft CRM Outlook-Add-In konnte nicht ordnungsgemäß initialisiert werden. Starten Sie Microsoft Outlook neu, und versuchen Sie es erneut. HR=0x80070057. Context=. Function=CAddin::OnConnection. Line=196.
Ursache
Ursache 1
Dieses Problem tritt auf, da die Rolle, die dem Benutzerkonto zugewiesen ist, keinen Lesezugriff auf die Entität "Gespeicherte Ansicht" in Microsoft Dynamics CRM hat. Siehe Entschließung 1.
Ursache 2
Die Konfiguration zur Deaktivierung der Ordnerstartseite wird über Gruppenrichtlinien aktiviert. Die Konfiguration "Ordnerstartseite deaktivieren" ist eine Microsoft Office 2003-Administrativvorlage (OUTLK11.adm)-Konfiguration. Wenn diese Einstellung aktiviert ist, kann Office 2003 die Microsoft Dynamics CRM-Ordnerstruktur nicht laden. Siehe Entschließung 2.
Ursache 3
Dieses Problem tritt auf, wenn IIS die Zuordnungen für die SRF-Erweiterungen fehlen, die auf die CRMisapi.dll-Datei verweisen. Siehe Entschließung 3.
Ursache 4
Dieses Problem tritt auf, da die Überprüfung auf die Serverzertifikatsperrung aktiviert ist. Siehe Entschließung 4.
Ursache 5
Dieses Problem tritt auf, da die Datei Outlook.exe.config im Microsoft Office-Installationsordner vorhanden ist. Diese Datei wird in Problembehandlungsinstanzen für den Microsoft Outlook CRM-Client für Outlook verwendet, sodass Outlook eine bestimmte Version von Microsoft .NET Framework verwenden kann. Siehe Auflösung 5.
Beschluss
Lösung 1
Um den Microsoft Dynamics CRM-Client für Outlook ordnungsgemäß zu starten, muss die Rolle, die dem Benutzerkonto zugewiesen ist, Über Lesezugriff auf die Entität "Gespeicherte Ansicht" verfügen. Führen Sie die folgenden Schritte aus, um den Zugriff des Benutzers zu ändern:
- Öffnen Sie Microsoft Dynamics CRM.
- Wählen Sie "Einstellungen" aus, wählen Sie "Einstellungen" aus, wählen Sie "Geschäftseinheitseinstellungen" aus, wählen Sie "Benutzer" aus, und doppelklicken Sie dann auf den Benutzer, um den Benutzer zu öffnen.
- Wählen Sie Rollen aus, doppelklicken Sie auf die Rolle, um sie zu öffnen, wählen Sie die Registerkarte Kerndatensätze aus und wählen Sie dann Lesezugriff für die EntitätGespeicherte Ansicht aus.
Lösung 2
Um dieses Problem zu beheben, ändern Sie die Einstellung der Konfiguration "Ordnerstartseite deaktivieren" in den Status "Deaktiviert ". Führen Sie dazu die folgenden Schritte für Outlook 2003 aus:
- Um die Gruppenrichtlinie zu bearbeiten, die die administrative Office 2003-Vorlage enthält, öffnen Sie den Gruppenrichtlinienobjekt-Editor.
- Erweitern Sie die Benutzerkonfiguration, erweitern Sie Richtlinien, erweitern Sie administrative Vorlagen, und erweitern Sie dann Microsoft Office Outlook 2003.
- Wählen Sie "Ordnerhomepages" für Outlook-Spezielle Ordner aus, und doppelklicken Sie dann auf "Ordnerhomepages deaktivieren".
- Aktivieren Sie auf der Seite "Ordner-Homepage deaktivieren – Eigenschaften" das Kontrollkästchen "Deaktivieren" und wählen Sie dann "OK" aus.
- Beenden Sie den Gruppenrichtlinienobjekt-Editor.
- Starten Sie den betroffenen Clientcomputer neu.
Führen Sie die folgenden Schritte für Outlook 2007 aus:
- Um die Gruppenrichtlinie zu bearbeiten, die die administrative Office 2007-Vorlage enthält, öffnen Sie den Gruppenrichtlinienobjekt-Editor.
- Erweitern Sie die Benutzerkonfiguration, erweitern Sie Richtlinien, erweitern Sie administrative Vorlagen, und erweitern Sie dann Microsoft Office Outlook 2007.
[HINWEIS] Der Ordner "Microsoft Office Outlook 2007" kann unter klassischen administrativen Vorlagen (ADM) enthalten sein.
- Wählen Sie Startseiten für spezielle Outlook-Ordner aus, und doppelklicken Sie dann auf Festlegen der Homepage-URL in den Ordnereigenschaften nicht zulassen.
- Öffnen Sie auf der Seite "Homepage-URL nicht in den Ordnereigenschaften zulassen" das Kontrollkästchen "Deaktiviert" und wählen Sie dann "OK" aus.
- Beenden Sie den Gruppenrichtlinienobjekt-Editor.
- Starten Sie den betroffenen Clientcomputer neu.
Beschluss 3
Um dieses Problem zu beheben, fügen Sie die .srf-Zuordnung zur Microsoft Dynamics CRM-Website hinzu. Gehen Sie dazu wie folgt vor:
- Erweitern Sie die Microsoft Dynamics CRM-Website in IIS.
- Klicken Sie mit der rechten Maustaste auf das virtuelle Verzeichnis der MSCRMServices-Anwendung, und wählen Sie dann "Eigenschaften" aus.
- Wählen Sie auf der Registerkarte "Virtuelles Verzeichnis" die Option "Konfiguration" aus.
- Wählen Sie im Abschnitt "Anwendungserweiterungen" die Option "Hinzufügen" aus.
- Suchen Sie die CRMIsapi.dll Datei, und fügen Sie dann den Pfad wie folgt in Anführungszeichen ein:
C:\Programme\Microsoft CRM\Server\bin\CrmIsapi.dll - Geben Sie im Erweiterungsfeld die Zeichenfolge .srf ein.
- Geben Sie im Feld "Limit to" GET, POST, HEAD ein.
- Aktivieren Sie das Kontrollkästchen Skriptmodul , und aktivieren Sie das Kontrollkästchen "Überprüfen, ob die Datei vorhanden ist ", und aktivieren Sie dann "OK".
- Setzen Sie IIS zurück. Wählen Sie hierzu "Start" aus, wählen Sie "Ausführen" aus, geben Sie "iisreset" in das Feld "Öffnen" ein, und wählen Sie dann "OK" aus.
Beschluss 4
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
- Wählen Sie in Internet Explorer das Menü "Extras " und dann "Internetoptionen" aus.
- Wählen Sie die Registerkarte "Erweitert" aus, und deaktivieren Sie dann das Kontrollkästchen "Auf Serverzertifikatsperrung überprüfen" (erfordert einen Neustart).
- Starten Sie Outlook neu.
Entschließung 5
Um dieses Problem zu beheben, entfernen oder benennen Sie die Datei Outlook.exe.config um, und starten Sie Outlook dann neu.