Beim Konfigurieren des Microsoft Dynamics CRM-Clients für Outlook tritt ein Problem bei der Kommunikation mit dem Microsoft Dynamics CRM Server auf.
Dieser Artikel bietet eine Lösung für einen Fehler, der beim Konfigurieren des Microsoft Dynamics CRM-Clients für Outlook auftritt.
Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2834554
Problembeschreibung
Wenn Sie versuchen, den Microsoft Dynamics CRM-Client für Microsoft Office Outlook zu konfigurieren, wird die folgende Fehlermeldung angezeigt:
Es liegt ein Problem bei der Kommunikation mit dem Microsoft Dynamics CRM-Server vor. Der Server ist möglicherweise nicht verfügbar. Versuchen Sie es später erneut. Wenn das Problem weiterhin besteht, wenden Sie sich an Ihren Systemadministrator.
Fehler in der Crm50ClientConfig.log-Datei:
Fehler| Ausnahme: Ein Fehler ist aufgetreten. Versuchen Sie diese Aktion erneut. Wenn das Problem weiterhin besteht, überprüfen Sie die Microsoft Dynamics CRM Community auf Lösungen, oder wenden Sie sich an den Microsoft Dynamics CRM Administrator Ihres organization. Schließlich können Sie sich an Microsoft-Support wenden. unter Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.InitializeMapiStoreForFirstTime()
Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(Object stateInfo)
Fehler| Ausnahme: Der Server konnte die Anforderung nicht verarbeiten.
Ursache
Dieser Fehler kann auftreten, wenn Sie versuchen, den Microsoft Dynamics CRM-Client für Outlook für einen Microsoft Dynamics CRM Server zu konfigurieren, der einen falschen Eintrag in der ConfigSettings-Tabelle der MSCRM_Config Datenbank für die HelpServerUrl-Spalte aufweist.
Lösung
Aktualisieren der HelpServerUrl-Einstellung auf eine gültige HTTP-Adresse
Öffnen Sie SQL Server Management Studio, und stellen Sie eine Verbindung mit der instance her, die Microsoft Dynamics CRM 2011 hosten.
Wählen Sie eine neue Abfrage aus, und führen Sie eine select-Anweisung aus, um die Einstellung HelpServerUrl für die MSCRM_Config Datenbank für die Configsettings-Tabelle zu überprüfen:
Use MSCRM_CONFIG go select HelpServerUrl from configsettings
Wenn die Ergebnisse nicht im HTTP-Format vorliegen, erstellen Sie eine Sicherung der MSCRM_config Datenbank, und aktualisieren Sie dann die Einstellung mit einer Abfrage wie der folgenden:
Use MSCRM_Config go update ConfigSettings set HelpServerUrl = 'https://<crmserver>/'