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Der Konfigurations-Manager für E-Mail-Router konnte Benutzer- und Warteschlangeninformationen nicht vom Microsoft Dynamics CRM-Serverfehler abrufen, wenn Sie "Daten laden" in Microsoft Dynamics CRM 2011 auswählen.

Dieser Artikel enthält eine Lösung für einen Fehler, der auftritt, wenn Sie "Daten laden" in Microsoft Dynamics CRM 2011 auswählen.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2531924

Symptome

Nachdem Sie den Microsoft Dynamics CRM 2011-E-Mail-Router konfiguriert haben und Sie "Daten laden" auswählen, um CRM-E-Mail-Router-Benutzer zu testen, erhalten Sie eine Fehlermeldung, die dem folgenden Beispiel ähnelt:

Der Konfigurations-Manager für den E-Mail-Router konnte keine Benutzer- und Warteschlangeninformationen vom Microsoft Dynamics CRM-Server abrufen. Dies kann darauf hindeuten, dass der Microsoft Dynamics CRM-Server ausgelastet ist. Stellen Sie sicher, dass die URL "https://dev.crm.dynamics.com/CrmOrgName" korrekt ist. Darüber hinaus kann dieses Problem auftreten, wenn angegebene Zugriffsanmeldeinformationen nicht ausreichen. Klicken Sie auf 'Daten laden', um es erneut zu versuchen. (Ein unsicherer oder falsch gesicherter Fehlerzustand wurde von der anderen Partei erhalten. Siehe die innere FaultException für den Fehlercode und Details.)

Ursache

Dieses Problem kann aus einem der folgenden Gründe auftreten:

  • Der Computer, auf dem CRM 2011-E-Mail-Router installiert ist, hat ein Problem, das sich auf die Uhrzeit, das Datum oder beides auswirkt. Insbesondere weicht die koordinierte Weltzeit (UTC) auf dem Computer um einige Minuten ab.
  • Das Dienstkonto, das im Bereitstellungsprofil des CRM-Router-Konfigurations-Managers angegeben ist, ist in Active Directory gesperrt.
  • Das Dienstkonto, das im Bereitstellungsprofil des CRM-E-Mail-Router-Konfigurations-Managers angegeben ist, verfügt über restriktive Anmeldeberechtigungen in Active Directory.

Entschließung

  • Lösung 1

    Aktualisieren Sie die Uhrzeit und das Datum auf dem Computer, auf dem CRM 2011-E-Mail-Router installiert ist, auf die richtige lokale Werte und Zeitzone. Gehen Sie dazu wie folgt vor:

    1. Beenden Sie den Konfigurations-Assistenten für CRM-E-Mail-Router.

    2. Ändern Sie das Datum und die Uhrzeit des Betriebssystems, indem Sie eine der folgenden Optionen ausführen:

      Option 1 : Manuelles Ändern der Betriebssystemzeit

      1. Wählen Sie "Start", dann "Systemsteuerung", " Uhr", "Sprache" und "Region" und dann "Datum und Uhrzeit" aus.
      2. Wählen Sie "Datum und Uhrzeit ändern " aus, um die Datums- und Uhrzeiteinstellungen zu ändern. Wählen Sie das Datum (z. B. 1. Februar 2011) aus dem Kalender aus, ändern Sie die Uhrzeit, und wählen Sie dann "OK" aus.
      3. Wählen Sie Zeitzone ändern, wählen Sie Ihre Zeitzone aus, klicken Sie auf Übernehmen und danach auf OK.

      Notiz

      Diese Schritte gelten für Windows 7- oder Windows Server 2008 R2-Betriebssysteme. Informationen zum Ändern von Datum und Uhrzeit in Windows XP finden Sie im Handbuch zur Betriebssystemhilfe.

      Option 2 : Konfigurieren der Betriebssystemzeit für die Synchronisierung mit einem Internetzeitserver

      1. Wählen Sie "Start", dann "Systemsteuerung", " Uhr", "Sprache" und "Region" und dann "Datum und Uhrzeit" aus.
      2. Wählen Sie die Registerkarte "Internetzeit " und dann " Einstellungen ändern" aus.
      3. Aktivieren Sie das Kontrollkästchen neben " Mit einem Internetzeitserver synchronisieren", wählen Sie einen Zeitserver aus, wählen Sie "Jetzt aktualisieren" und dann "OK" aus.

      Option 3 : Synchronisieren der Zeit über die Domäne über eine Eingabeaufforderung

      Wenn der Computer Mitglied einer Domäne ist, verwenden Sie eine Eingabeaufforderung, um die Computerzeit mit der Zeit der Domäne zu synchronisieren. Führen Sie dazu die folgenden Schritte aus.

      Notiz

      Bevor Sie diese Anweisungen ausführen, vergewissern Sie sich, dass die Uhrzeit auf dem Zeitserver korrekt ist. Öffnen Sie dazu eine Eingabeaufforderung, geben Sie die Netzzeit ein, und drücken Sie dann die EINGABETASTE.

      1. Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten, indem Sie "Start" auswählen, " Alle Programme" auswählen, " Zubehör" auswählen, mit der rechten Maustaste auf die Eingabeaufforderung klicken und dann " Als Administrator ausführen" auswählen.

      2. Führen Sie in der Eingabeaufforderung den folgenden Befehl aus:

        net time [{\\ComputerName | /domain[:DomainName] | /rtsdomain[:DomainName]}] [/set]
        

      Notiz

      Weitere Informationen zum Net time-Befehl finden Sie unter Net time

      Option 4 : Wenn der Computer einen NTP-Client zum Synchronisieren mit einem NTP-Server verwendet, erzwingen Sie eine Synchronisierung des NTP-Clients.

    3. Öffnen Sie den Konfigurations-Assistenten für CRM-E-Mail-Router.

    4. Wählen Sie die Registerkarte "Benutzer", "Warteschlangen" und "Postfächer weiterleiten" aus .

    5. Wählen Sie "Daten laden" aus.

    CRM-Benutzerdaten werden jetzt erfolgreich geladen.

  • Lösung 2

    Entsperren Sie das konto, das im Bereitstellungsprofil des CRM-E-Mail-Router-Konfigurations-Managers angegeben ist. Gehen Sie dazu wie folgt vor:

    1. Auf einem Domänencontroller Active Directory-Benutzer und -Computer starten.
    2. Suchen Sie das im Bereitstellungsprofil angegebene Active Directory-Konto, klicken Sie mit der rechten Maustaste darauf, und wählen Sie dann "Eigenschaften" aus.
    3. Klicken Sie mit der rechten Maustaste auf das Benutzerkonto, und wählen Sie dann "Eigenschaften" aus.
    4. Wählen Sie die Registerkarte "Konto " aus.
    5. Deaktivieren Sie das Kontrollkästchen "Konto entsperren" .
    6. Schließen Sie den CRM-E-Mail-Router Configuration Manager, wenn er noch geöffnet ist.
    7. Starten Sie auf dem Server, auf dem DER CRM-E-Mail-Router installiert ist, den Microsoft CRM-E-Mail-Router-Dienst neu. Wählen Sie dazu "Start" aus, wählen Sie "Ausführen", geben Sie "services.msc" ein, und wählen Sie dann "OK" aus. Suchen Sie den Microsoft CRM-E-Mail-Router-Dienst, klicken Sie mit der rechten Maustaste darauf, und wählen Sie dann "Neu starten" aus.
    8. Starten Sie den CRM-E-Mail-Router Configuration Manager erneut.
    9. Wählen Sie die Registerkarte "Benutzer", "Warteschlangen" und "Postfächer weiterleiten" aus .
    10. Wählen Sie "Daten laden" aus.

    Die Benutzerinformationen sollten jetzt erfolgreich geladen werden.

  • Entschließung 3

    Fügen Sie die CRM- und die Server der Active Directory-Verbunddienste (AD FS) zur Liste der Anmeldeserver für das im Bereitstellungsprofil angegebene Dienstkonto hinzu. Gehen Sie dazu wie folgt vor:

    1. Auf einem Domänencontroller Active Directory-Benutzer und -Computer starten.
    2. Suchen Sie das im Bereitstellungsprofil angegebene Active Directory-Konto, klicken Sie mit der rechten Maustaste darauf, und wählen Sie dann "Eigenschaften" aus.
    3. Wählen Sie die Registerkarte "Konto " aus.
    4. Wählen Sie "Anmelden bei" aus.
    5. Wenn die Einstellung Dieser Benutzer kann sich anmelden bei auf Die folgenden Computer festgelegt ist, stellen Sie sicher, dass die AD FS- und CRM-Server in dieser Liste von Computern angegeben sind. Wenn sie nicht angegeben sind, fügen Sie sie der Liste hinzu.
    6. Starten Sie den CRM-E-Mail-Router Configuration Manager erneut.
    7. Wählen Sie die Registerkarte "Benutzer", "Warteschlangen" und "Postfächer weiterleiten" aus .
    8. Wählen Sie "Daten laden" aus.

    Die Benutzerinformationen sollten jetzt erfolgreich geladen werden.