Fehler "Postfach hat keine gültige E-Mail-Adresse", wenn die serverseitige Synchronisierung verwendet wird.
Dieser Artikel hilft Ihnen, ein Problem zu beheben, bei dem beim Verwenden der serverseitigen Synchronisierung in Microsoft Dynamics 365 der Fehler "Postfach hat keine gültige E-Mail-Adresse" angezeigt wird.
Gilt für: Microsoft Dynamics CRM 2016
Ursprüngliche KB-Nummer: 3214684
Symptome
Wenn Sie ein Postfach in Dynamics 365 testen und aktivieren, treten im Bereich "Warnungen" eine der folgenden Fehler auf:
Termine, Kontakte und Aufgaben können nicht synchronisiert werden, da der Postfachname <> nicht über eine gültige E-Mail-Adresse verfügt. Geben Sie eine gültige E-Mail-Adresse im Postfachdatensatz an, und aktivieren Sie dann das Postfach für Termine, Kontakte und Aufgabensynchronisierung.
Fehlercode des E-Mail-Servers: Exchange.server hat ErrorNonExistentMailbox-Fehler zurückgegeben.
Beim Senden der E-Mail-Nachricht "Ihr Postfach ist jetzt mit Dynamics 365 verbunden" ist ein allgemeiner Postfachzugriffsfehler aufgetreten. Postfach [Postfachname] wurde nicht synchronisiert. Der Besitzer des zugehörigen E-Mail-Serverprofils wurde Microsoft Exchange Online benachrichtigt.
Fehlercode des E-Mail-Servers: Exchange-Server hat die ErrorInvalidOperation-Ausnahme zurückgegeben.
E-Mails können für das Postfach [Postfachname] nicht empfangen werden, da der Postfachdatensatz nicht über eine gültige E-Mail-Adresse verfügt. Das Postfach wurde nicht synchronisiert. Eine Benachrichtigung dazu wird auf der Warnungswand für den Besitzer des E-Mail-Serverprofils Microsoft Exchange Online veröffentlicht.
Fehlercode des E-Mail-Servers: Exchange.server hat ErrorNonExistentMailbox-Fehler zurückgegeben.
Ursache
Dieser Fehler kann aus einem der folgenden Gründe auftreten:
- Das Postfach für den Benutzer konnte nicht gefunden werden, da die E-Mail-Adresse nicht korrekt ist.
- Die E-Mail-Adresse ist für eine Verteilergruppe vorgesehen, bei der es sich nicht um ein Postfach handelt.
- Das Postfach ist für die Verwendung eines Exchange Online-Profils konfiguriert, das Postfach des Benutzers befindet sich jedoch lokal in Exchange.
Lösung
Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:
- Überprüfen Sie, ob die E-Mail-Adresse des Postfachdatensatzes in Dynamics 365 der E-Mail-Adresse in Exchange entspricht. Der Fehler enthält einen Link zum Postfachdatensatz in Dynamics 365. Sie können diesen Link verwenden, um das Feld "E-Mail-Adresse" schnell zu überprüfen.
- Überprüfen Sie, ob die E-Mail-Adresse für ein tatsächliches Postfach und nicht für eine Verteilergruppe gilt. Verteilergruppen sind keine Postfächer, die E-Mails speichern. Verteilergruppen werden verwendet, um E-Mails an die Postfächer zu verteilen, die Mitglieder der Gruppe sind.
- Wenn sich das Postfach des Benutzers lokal in Exchange befindet, stellen Sie sicher, dass Sie ein Exchange Server-Profil (Hybrid) in Dynamics 365 anstelle eines Exchange Online-Profils verwenden.
Weitere Informationen
Wenn Sie auf "Details anzeigen" klicken, werden Fehlerdetails wie die folgenden angezeigt:
>Fehler: <ResponseMessageType xmlns:q1="
https://schemas.microsoft.com/exchange/services/2006/messages
" p2:type="q1:FindItemResponseMessageType" ResponseClass="Error" xmlns:p2="https://www.w3.org/2001/XMLSchema-instance
"><q1:MessageText>Mailbox does not exist.</q1:MessageText><q1:ResponseCode>ErrorNonExistentMailbox</q1:ResponseCode><q1:DescriptiveLinkKey>0</q1:DescriptiveLinkKey></ResponseMessageType>
>Fehler: <ResponseMessageType xmlns:q1="
https://schemas.microsoft.com/exchange/services/2006/messages
" p2:type="q1:ItemInfoResponseMessageType" ResponseClass="Error" xmlns:p2="https://www.w3.org/2001/XMLSchema-instance
q1><:MessageText>SendOnly kann nicht von einem Benutzer ohne postfach verwendet werden. Verwenden Sie SendAndSaveCopy, und geben Sie eine Ordner-ID in einem Postfach an, um ein Element aus einem Konto zu senden, das nicht über ein Postfach verfügt.</q1:MessageText><q1:ResponseCode>ErrorInvalidOperation</q1:ResponseCode><q1:DescriptiveLinkKey>0</q1:DescriptiveLinkKey><q1:Items /></ResponseMessageType>