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Microsoft Dynamics CRM Outlook-Client reagiert möglicherweise nicht mehr im Nicht-Administratormodus

Dieser Artikel hilft Ihnen, das Problem zu umgehen, das auftritt, wenn Sie versuchen, Microsoft Dynamics CRM Client für Outlook zu öffnen, oder wenn Sie den Offlinesynchronisierungsprozess im Microsoft Dynamics CRM-Client für Outlook mit Offlinezugriff testen.

Gilt für: Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft Dynamics CRM 2015, Microsoft CRM Client für Microsoft Office Outlook®
Ursprüngliche KB-Nummer: 3106337

Symptome

Wenn Sie versuchen, Microsoft Dynamics CRM Client für Outlook zu öffnen oder den Offlinesynchronisierungsprozess im Microsoft Dynamics CRM-Client für Outlook mit Offlinezugriff zu testen, treten möglicherweise Fehler wie die folgenden auf:

Outlook reagiert nicht mehr (blinkend), und Sie müssen den Prozess beenden.

Outlook zeigt einen Fehler an: Es war kein Endpunkt vorhanden, der die Nachricht an net.pipe://localhost/WebFormService/{random-guid-number} akzeptieren konnte. Ursache dieses Fehlers ist häufig eine falsche Adresse oder SOAP-Aktion. Weitere Informationen finden Sie unter InnerException ( falls vorhanden).

Ursache

Der CRM-Client für Outlook nutzt Windows Communication Foundation (WCF), um mit einem Dienst außerhalb des Prozesses zu kommunizieren und mit einem CRM-Server zu interagieren. Die verwendete WCF-Bindung ist net.pipe, die eine bestimmte Methode zum Benennen der zugrunde liegenden benannten Pipe hat. Ab WCF 4.0 ist der Prozess der Benennung und Registrierung des URI des Net.pipe-Endpunkts hierarchisch und in zwei Ebenen: nicht administrativer Modus und Administrativer Modus. Wenn ein Prozess den URI net.pipe://localhostregistriert, können alle nicht administrativen Prozesse nicht auf einen anderen Dienst mit net.pipe-Bindung zugreifen, einschließlich der lokalen CRM-Webformulardienstsignatur.

Lösung

Es gibt keine Lösung, da dies beabsichtigt ist. WCF-Dienste sollten nicht über einen Listener-URI verfügen unter net.pipe://localhost/. Es gibt zwei mögliche Problemumgehungen, falls die Situation zutrifft.

Führen Sie die folgenden Schritte aus, um herauszufinden, welcher Prozess den Listener net.pipe://localhost/ blockiert:

  • Sysinternals-Toolhandle laden (Handle v4.22)

  • Entpacken sie Handle.zip in einen Ordner (z. B.: c:\sysinternals)

  • Öffnen von cmd.exe als Administrator

  • Wechseln zum Ordner, in dem Sie Handle.exe entzippt haben (z. B. CD c:\sysinternals)

  • Führen Sie den folgenden Befehl aus:

    handle "net.pipe:EbmV0LnBpcGU6Ly8rLw=="
    
  • Wenn eine Übereinstimmung vorliegt, wird der ausführbare Name und die PID als Beispielausgabe unten angegeben:

    StandAloneService.exe pid: 10724 type: Section 318: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
    

Problemumgehung

  • Problemumgehung 1

    Suchen Sie die Datei (oder den Dienst), die wie vorher festgelegt auf net.pipe://localhost lauscht, und beenden Sie sie, während Sie Outlook ausführen.

  • Problemumgehung 2 (weniger empfohlen)

    Wenn Sie Microsoft Dynamics CRM-Clients für Outlook mit lokalen Administratorrechten starten (klicken Sie mit der rechten Maustaste auf Outlook , und wählen Sie "Als Administrator ausführen" aus), funktioniert der Microsoft Dynamics CRM-Client für Outlook als Entwurf, und Sie können den Offlinesynchronisierungsprozess ohne Fehler verwenden.