Freigeben über


Langsame Leistung bei Verwendung des Microsoft Dynamics CRM 2011-Clients für Outlook

Dieser Artikel enthält eine Lösung für ein Problem, bei dem die Leistung für den Microsoft Dynamics CRM 2011-Client für Outlook langsam ist.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2585157

Symptome

Die Leistung des Microsoft Dynamics CRM 2011-Clients ist für Sie langsam. Wenn Sie Microsoft Dynamics CRM-Client- und Servernetzwerkdatenverkehr untersuchen, stellen Sie fest, dass datenverkehr vorhanden ist, auch wenn keine Microsoft Dynamics CRM-Benutzeraktivität auftritt.

Ursache

Der Microsoft Dynamics CRM-Client für Microsoft Outlook führt Hintergrundabfragungsaktivitäten aus, die mit dem Server kommunizieren und auf serverseitige Änderungen reagieren, auch wenn keine clientseitige Aktivität vorhanden ist.

Es gibt Caches für verschiedene Microsoft Dynamics CRM-Features wie Adressbuch, Erinnerungen und Ansichten. Das Standardabfragungsintervall für MAPI-Caches beträgt alle 15 Minuten.

Die regelmäßige Abfrage generiert Hintergrundaktivitäten in Microsoft Dynamics CRM, und diese Aktivitäten können die Leistung beeinflussen.

Lösung

Es gibt eine Reihe von Registrierungswerten und Unterschlüsseln, die geändert werden können, um die Abrufintervalle zu optimieren.

Die folgende Tabelle enthält die Liste des Microsoft Dynamics CRM-Clients für Outlook-Registrierungseinträge und Unterschlüssel, die die CRM-Hintergrundaktivität beeinflussen. Testen und finden Sie die optimalen Werte für Ihre Umgebung. Als Ausgangspunkt gibt es eine Spalte "Vorgeschlagene Tests ", in der die Standardwerte verdoppelt werden.

Registrierungseintrag Server/Client Typ Einheit Standarddauer/Wert Registrierungsunterschlüssel Vorgeschlagene Tests
Benachrichtigungsabfrageintervall Kunde (DWORD-Registrierungsschlüssel) ms 180000 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Erhöhung auf den Wert 3600000 (Dezimal)
Intervall für die Abfrage des Zustandsmanagers Kunde (DWORD-Registrierungsschlüssel) Min 5 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Inkrementierung auf 10 (Dezimalzahl)
TagDisabled (dieser Schlüssel deaktiviert das automatische E-Mail-Tagging) Kunde (DWORD-Registrierungsschlüssel) Nicht zutreffend 0 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Auf 1 festlegen
Abfragezeitraum Kunde (DWORD-Registrierungsschlüssel) ms 300000 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Inkrementierung auf 600000 (Dezimalzahl)
TagMaxAggressiveCycles Kunde (DWORD-Registrierungsschlüssel) Nicht zutreffend 2 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Setzen Sie auf 0.
AktiveCacheAktualisierungsperiode in Millisekunden Kunde (DWORD-Registrierungsschlüssel) ms 15000000 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Erhöhung auf 3000000 (Dezimal)
Aktualisierungszeitraum in Millisekunden für die inkrementelle Datencache-Einbeziehung Kunde (DWORD-Registrierungsschlüssel) ms 300000 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Inkrementierung auf 60000000 (Dezimalzahl)
IncrementalDataCachesExclusionUpdatingPeriodMilliseconds Kunde (DWORD-Registrierungsschlüssel) ms 300000 (Dezimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Inkrementierung auf 60000000 (Dezimalzahl)

Darüber hinaus können Sie auch versuchen, das Outlook-Synchronisierungsintervall zu erhöhen. Dieses Intervall ist standardmäßig auf 15 Minuten festgelegt. Führen Sie die folgenden Schritte aus, um das Interne zu erhöhen:

  1. Öffnen Sie den CRM-Webclient.
  2. Wählen Sie "Einstellungen", dann "Verwaltung" und dann "Systemeinstellungen" aus.
  3. Wählen Sie die Registerkarte "Outlook " aus, und überprüfen Sie dann die Option "Mindestzeit zwischen Synchronisierungen ".

Ein Microsoft Dynamics CRM-Benutzer kann den Synchronisierungswert für diesen Server auf den Minimalwert anpassen, der in den persönlichen Microsoft Dynamics CRM-Optionen des Benutzers in Outlook definiert ist. Führen Sie die folgenden Schritte aus, um den Outlook-Mindestwert zu aktualisieren:

  1. Öffnen Sie Microsoft Outlook 2010.
  2. Wählen Sie "Datei", dann "CRM" und dann "Optionen" aus.
  3. Aktualisieren Sie auf der Registerkarte "Synchronisierung " den Wert für die CRM-Elemente in meinem Outlook-Ordner alle "x"-Minuten-Option .