Fehler "Crystal Print Engine Error 723" beim Drucken oder Anzeigen einer Vorschau eines benutzerdefinierten Berichts in Microsoft Dynamics SL
Dieser Artikel enthält eine Problemumgehung für ein Problem, bei dem Sie die Fehlermeldung "Crystal Print Engine Error 723 " erhalten, wenn Sie versuchen, einen benutzerdefinierten Bericht in Microsoft Dynamics SL zu drucken oder in einer Vorschau zu drucken.
Gilt für: Microsoft Dynamics SL 2011
Ursprüngliche KB-Nummer: 930445
Symptome
Wenn Sie versuchen, einen benutzerdefinierten Bericht in Microsoft Dynamics SL zu drucken oder in der Vorschau anzuzeigen, wird eine Fehlermeldung angezeigt, die der folgenden Meldung ähnelt:
Der Druckauftrag kann nicht gestartet werden.
Bericht: C:\Programme\Salomon\Usr_Rpts\CUSTOM. RPT
Crystal Print Engine Fehler: 723 - Fehler in Datei
C:\Programme\Salomon\Usr_Rpts\CUSTOM. RPT: Fehler beim Öffnen eines Rowsets.
Dieses Problem tritt auf, wenn die folgenden Bedingungen erfüllt sind:
- Der benutzerdefinierte Bericht enthält ein Parameterfeld.
- Sie geben den entsprechenden Wert ein, wenn der Bericht Sie zur Eingabe eines Parameters auffordert.
- Sie geben zusätzliche Auswahlkriterien auf der Registerkarte "Auswählen " auf dem Bildschirm "Berichtsoptionen-Interpreter (ROI)" an.
Ursache
Dieses Problem tritt auf, da der Bildschirm "Report Options Interpreter" (ROI) die WHERE-Klauseln, die sich in den Auswahlkriterien und im Parameterfeld befinden, falsch verkettet.
Problemumgehung
Um dieses Problem zu umgehen, schließen Sie das Parameterfeld nicht in den benutzerdefinierten Bericht ein. Erstellen Sie stattdessen die Parameterauswahlkriterien auf der Registerkarte "Auswählen " des Bildschirms "Berichtsoptionen-Interpreter (ROI) ".