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Fehler 0x8000FFFF, wenn Sie den Befehl "vssadmin list writer" auf einem Windows Server 2003-basierten Computer ausführen

In diesem Artikel wird ein Problem behoben, das auftritt, wenn Sie den vssadmin list writers Befehl auf einem Windows Server 2003-basierten Computer verwenden. Wenn das Problem auftritt, erhalten Sie möglicherweise eine Fehlermeldung, ein Ereignis oder die Liste ist leer.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 940184

Symptome

Wenn Sie den vssadmin list writers Befehl auf einem Windows Server 2003-basierten Computer ausführen, treten möglicherweise die folgenden Symptome auf.

Notiz

Der vssadmin list writers Befehl listet die registrierten Schattenkopie-Dienste des Volumens auf.

  • Sie erhalten die folgende Fehlermeldung:

    Fehler: 0x8000FFFF

  • Das folgende Ereignis kann im Anwendungsprotokoll protokolliert werden:

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 12302
    Beschreibung: Fehler des Schattenkopie-Dienstes: Eine interne Inkonsistenz wurde erkannt, als versucht wurde, die Schattenkopie-Dienstautoren zu kontaktieren. Überprüfen Sie, ob der Ereignisdienst und der Volumeschattenkopie-Dienst einwandfrei arbeiten.

  • Die Liste ist leer.

Ursache

Dieses Problem kann auftreten, wenn der folgende Registrierungsschlüssel beschädigt ist:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

Lösung

Wichtig

Dieser Artikel dient nicht zur Verwendung mit Windows Vista, mit Windows Server 2008 oder mit höheren Windows-Betriebssystemen. Ab Windows Vista und windows Server 2008 ist die Installation von Windows-Komponenten manifestbasiert. Wenn Sie versuchen, bestimmte Komponenten manuell zu registrieren, wie in den folgenden Schritten beschrieben, können unerwartete Ergebnisse auftreten, die möglicherweise erfordern, dass Sie Windows erneut installieren müssen, um die Lösung zu beheben.

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Klicken Sie auf "Start">"Ausführen", geben Sie "Regedit" ein, und klicken Sie dann auf "OK".

  2. Lokalisieren Sie zuerst den folgenden Registrierungsunterschlüssel und klicken Sie dann darauf.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

  3. Klicken Sie im Menü "Bearbeiten " auf "Löschen", und klicken Sie dann auf "Ja ", um zu bestätigen, dass Sie den Unterschlüssel löschen möchten.

  4. Beenden Sie den Registrierungs-Editor.

  5. Klicken Sie auf Start>Ausführen, geben Sie services.msc ein, und klicken Sie dann auf OK.

  6. Klicken Sie mit der rechten Maustaste auf die folgenden Dienste einzeln. Klicken Sie für jeden Dienst auf "Neu starten":

    • COM+-Ereignissystem
    • COM+-Systemanwendung
    • Microsoft-Softwareschattenkopie-Anbieter
    • Volumeschattenkopie
  7. Klicken Sie auf Start>, Ausführen, geben Sie cmd ein, und klicken Sie dann auf OK.

  8. Geben Sie vssadmin list writers an der Eingabeaufforderung ein, und drücken Sie dann die EINGABETASTE.

  9. Wenn die VSS-Autoren jetzt aufgelistet sind, schließen Sie das Eingabeaufforderungsfenster. Sie müssen die verbleibenden Schritte nicht ausführen.

    Wenn die VSS-Autoren nicht aufgeführt sind, geben Sie an der Eingabeaufforderung die folgenden Befehle ein. Drücken Sie nach jedem Befehl die EINGABETASTE.

    • cd /d %windir%\system32
    • net stop vss
    • net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll

    Notiz

    Der letzte Befehl kann nicht erfolgreich ausgeführt werden.

  10. Geben Sie vssadmin list writers an der Eingabeaufforderung ein, und drücken Sie dann die EINGABETASTE.

  11. Vergewissern Sie sich, dass die VSS-Autoren jetzt aufgelistet sind.

Wurde das Problem dadurch behoben?

Testen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie sich an den Support wenden.