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Verschiedene Probleme können auf einem Windows Server 2003-basierten Computer auftreten, auf dem der Volumeschattenkopiedienst ausgeführt wird.

In diesem Artikel werden Probleme beschrieben, bei denen die Ereignis-ID 8019, 20, 8193 oder 12302 im Anwendungsprotokoll protokolliert wird. Sie erhalten eine Fehlermeldung 0x8004230F oder 0x80004002.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 940032

Symptome

Auf einem Computer mit Microsoft Windows Server 2003, bei dem der Volumeschattenkopiedienst (Volume Shadow Copy Service, VSS) ausgeführt wird, treten eines der folgenden Symptome auf:

  • Wenn Sie einen Sicherungsvorgang mithilfe des NTBackup-Tools ausführen, wird das folgende Ereignis im Anwendungsprotokoll protokolliert:

    Ereignistyp: Fehler
    Ereignisquelle: NTBackup
    Ereignis-ID: 8019
    Beschreibung: Endvorgang: Warnungen oder Fehler wurden gefunden. Weitere Informationen finden Sie im Sicherungsbericht.

    Notiz

    Wenn Sie die Sicherungsprotokolldatei anzeigen, werden die folgenden Informationen angezeigt:

    Fehler beim Erstellen der Volumeschattenkopie: 0xffffffff

  • Wenn Sie auf die Eigenschaften eines Volumes zugreifen und dann auf Schattenkopien klicken, erhalten Sie eine der folgenden Fehlermeldungen:

    Fehler 0x8004230F: Der Schattenkopie-Anbieter hatte einen unerwarteten Fehler beim Versuch, den angegebenen Vorgang zu verarbeiten.

    Fehler 0x80004002: Keine solche Schnittstelle unterstützt

  • Eines der folgenden Ereignisse wird im Anwendungsprotokoll protokolliert:

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 20
    Beschreibung: Fehler des Volumeschattenkopie-Diensts: Eine kritische Komponente, die vom Volumeschattenkopie-Dienst benötigt wird, ist nicht registriert. Dies kann passieren, wenn während des Windows-Setups oder während der Installation eines Schattenkopie-Anbieters ein Fehler aufgetreten ist. Der von CoCreateInstance zurückgegebene Fehler für die Klasse mit CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} und name VSSEvent lautet [0x80040154].

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 20
    Beschreibung: Fehler des Volumeschattenkopie-Diensts: Eine kritische Komponente, die vom Volumeschattenkopie-Dienst benötigt wird, ist nicht registriert. Dies kann passieren, wenn während des Windows-Setups oder während der Installation eines Schattenkopie-Anbieters ein Fehler aufgetreten ist. Der von CoCreateInstance zurückgegebene Fehler für die Klasse mit CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} und dem Namen VSSEvent lautet [0x80004002].

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 8193
    Beschreibung: Volume Shadow Copy Service-Fehler: Unerwarteter Fehler beim Aufrufen der CoCreateInstance-Routine. hr = 0x80040154.

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereigniskategorie: Keine
    Ereignis-ID: 8193
    Beschreibung: Volume Shadow Copy Service-Fehler: Unerwarteter Fehler beim Aufrufen der CoCreateInstance-Routine. hr = 0x80004002.

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 12302
    Beschreibung: Fehler des Volumeschattenkopiediensts: Es wurde eine interne Inkonsistenz beim Versuch erkannt, Schattenkopierer zu kontaktieren. Überprüfen Sie, ob der Ereignisdienst und der Volumeschattenkopie-Dienst ordnungsgemäß funktionieren.

Ursache

Dieses Problem tritt auf, da die VSS-Systemdateien nicht registriert sind.

Lösung

Notiz

Dieser Artikel ist nicht für die Verwendung mit Windows Vista, mit Windows Server 2008 oder mit höheren Betriebssystemen vorgesehen. Ab Windows Vista und windows Server 2008 ist die Installation von Windows-Komponenten manifestbasiert. Wenn Sie versuchen, bestimmte Komponenten, z. B. die in diesem Abschnitt "Lösung" beschriebenen Komponenten, manuell zu registrieren, können in den in diesem Hinweis erwähnten Betriebssystemen unerwartete Ergebnisse auftreten, die möglicherweise eine erneute Installation von Windows erfordern.

Gehen Sie folgendermaßen vor, um das Problem zu beheben:

  1. Klicken Sie auf Start und auf Ausführen, geben Sie „cmd“ ein, und klicken Sie dann auf OK.

  2. Geben Sie an einer Eingabeaufforderung die folgenden Befehle ein. Drücken Sie die EINGABETASTE, nachdem Sie jeden Befehl eingegeben haben.

    • cd /d %windir%\system32
    • Net stop vss
    • Net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll

    Notiz

    Der letzte Befehl kann nicht erfolgreich ausgeführt werden.

  3. Führen Sie einen Sicherungsvorgang aus, um zu überprüfen, ob das Problem behoben ist.

Weitere Informationen

Schritte zum Reproduzieren dieses Problems

  1. Geben Sie an einer Eingabeaufforderung den folgenden Befehl ein. Drücken Sie die EINGABETASTE, nachdem Sie den Befehl eingegeben haben.

    regsvr32 /u swprv.dll
    
  2. Versuchen Sie, einen Sicherungsvorgang auszuführen.