Microsoft Security Bulletin MS16-091 – Wichtig

Sicherheitsupdate für .NET Framework (3170048)

Veröffentlicht: 12. Juli 2016 | Aktualisiert: 8. November 2016

Version: 1.1

Kurzfassung

Dieses Sicherheitsupdate behebt ein Sicherheitsrisiko in Microsoft .NET Framework. Die Sicherheitsanfälligkeit kann zur Offenlegung von Informationen führen, wenn ein Angreifer eine speziell gestaltete XML-Datei in eine webbasierte Anwendung hochlädt.

Dieses Sicherheitsupdate wird für Microsoft .NET Framework 2.0 Service Pack 2, Microsoft .NET Framework 3.5, Microsoft .NET Framework 3.5.1, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.6 und Microsoft als Wichtig eingestuft. .NET Framework 4.6.1 für betroffene Versionen von Microsoft Windows. Weitere Informationen finden Sie im Abschnitt Bewertungen für betroffene Software und Schweregrad der Sicherheitsrisiken .

Das Update behebt die Sicherheitsanfälligkeit, indem geändert wird, wie der XML External Entity (XXE)-Parser XML-Eingabe analysiert. Weitere Informationen zu der Sicherheitsanfälligkeit finden Sie im Abschnitt Informationen zu Sicherheitsrisiken .

Weitere Informationen zu diesem Update finden Sie im Microsoft Knowledge Base-Artikel 3170048.

Bewertungen des Schweregrads der betroffenen Software und der Sicherheitsrisiken

Die folgenden Softwareversionen oder Editionen sind betroffen. Versionen oder Editionen, die nicht aufgeführt sind, haben entweder ihren Supportlebenszyklus hinter sich oder sind nicht betroffen. Informationen zum Ermitteln des Supportlebenszyklus für Ihre Softwareversion oder Edition finden Sie unter Microsoft-Support Lifecycle.

Die für jede betroffene Software angegebenen Schweregradbewertungen gehen von der potenziellen maximalen Auswirkung der Sicherheitsanfälligkeit aus. Informationen zur Wahrscheinlichkeit der Ausnutzung des Sicherheitsrisikos in Bezug auf den Schweregrad und die Sicherheitsauswirkungen innerhalb von 30 Tagen nach Veröffentlichung dieses Sicherheitsbulletins finden Sie im Ausnutzbarkeitsindex in der Zusammenfassung des Bulletins vom Juli.

Betriebssystem **Komponente** Sicherheitsanfälligkeit in .NET bezüglich Offenlegung von Informationen – CVE-2016-3255 **Updates ersetzt **
Windows Vista
Windows Vista Service Pack 2 Microsoft .NET Framework 2.0 Service Pack 2 (3163244) Wichtig Offenlegung von Informationen Keine
Windows Vista Service Pack 2 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Vista Service Pack 2 Microsoft .NET Framework 4.6[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Vista x64 Edition Service Pack 2 Microsoft .NET Framework 2.0 Service Pack 2 (3163244) Wichtig Offenlegung von Informationen Keine
Windows Vista x64 Edition Service Pack 2 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Vista x64 Edition Service Pack 2 Microsoft .NET Framework 4.6[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2008
Windows Server 2008 für 32-Bit-Systeme Service Pack 2 Microsoft .NET Framework 2.0 Service Pack 2 (3163244) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für 32-Bit-Systeme Service Pack 2 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für 32-Bit-Systeme Service Pack 2 Microsoft .NET Framework 4.6[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für x64-basierte Systeme Service Pack 2 Microsoft .NET Framework 2.0 Service Pack 2 (3163244) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für x64-basierte Systeme Service Pack 2 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für x64-basierte Systeme Service Pack 2 Microsoft .NET Framework 4.6[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 für Itanium-basierte Systeme Service Pack 2 Microsoft .NET Framework 2.0 Service Pack 2 (3163244) Wichtig Offenlegung von Informationen Keine
Windows 7
Windows 7 für 32-Bit-Systeme Service Pack 1 Microsoft .NET Framework 3.5.1 (3163245) Wichtig Offenlegung von Informationen Keine
Windows 7 für 32-Bit-Systeme Service Pack 1 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows 7 für 32-Bit-Systeme Service Pack 1 Microsoft .NET Framework 4.6/4.6.1[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows 7 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 3.5.1 (3163245) Wichtig Offenlegung von Informationen Keine
Windows 7 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows 7 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 4.6/4.6.1[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 3.5.1 (3163245) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 Microsoft .NET Framework 4.6/4.6.1[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2 für Itanium-basierte Systeme Service Pack 1 Microsoft .NET Framework 3.5.1 (3163245) Wichtig Offenlegung von Informationen Keine
Windows 8.1
Windows 8.1 für 32-Bit-Systeme Microsoft .NET Framework 3.5 (3163247) Wichtig Offenlegung von Informationen Keine
Windows 8.1 für 32-Bit-Systeme Microsoft .NET Framework 4.5.2[1](3163291) Wichtig Offenlegung von Informationen Keine
Windows 8.1 für 32-Bit-Systeme Microsoft .NET Framework 4.6/4.6.1[1](3164024) Wichtig Offenlegung von Informationen Keine
Windows 8.1 für x64-basierte Systeme Microsoft .NET Framework 3.5 (3163247) Wichtig Offenlegung von Informationen Keine
Windows 8.1 für x64-basierte Systeme Microsoft .NET Framework 4.5.2[1](3163291) Wichtig Offenlegung von Informationen Keine
Windows 8.1 für x64-basierte Systeme Microsoft .NET Framework 4.6/4.6.1[1](3164024) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 und Windows Server 2012 R2
Windows Server 2012 Microsoft .NET Framework 3.5 (3163246) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 Microsoft .NET Framework 4.5.2[1](3163250) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 Microsoft .NET Framework 4.6/4.6.1[1](3164023) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 Microsoft .NET Framework 3.5 (3163247) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 Microsoft .NET Framework 4.5.2[1](3163291) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 Microsoft .NET Framework 4.6/4.6.1[1](3164024) Wichtig Offenlegung von Informationen Keine
Windows RT 8.1
Windows RT 8.1 Microsoft .NET Framework 4.5.2[1][2](3163291) Wichtig Offenlegung von Informationen Keine
Windows RT 8.1 Microsoft .NET Framework 4.6/4.6.1[1][2](3164024) Wichtig Offenlegung von Informationen Keine
Windows 10
Windows 10 für 32-Bit-Systeme[3](3163912) Microsoft .NET Framework 3.5 Wichtig Offenlegung von Informationen 3163017
Windows 10 für 32-Bit-Systeme[3](3163912) Microsoft .NET Framework 4.6 Wichtig Offenlegung von Informationen 3163017
Windows 10 für x64-basierte Systeme[3](3163912) Microsoft .NET Framework 3.5 Wichtig Offenlegung von Informationen 3163017
Windows 10 für x64-basierte Systeme[3](3163912) Microsoft .NET Framework 4.6 Wichtig Offenlegung von Informationen 3163017
Windows 10 Version 1511 für 32-Bit-Systeme[3](3172985) Microsoft .NET Framework 3.5 Wichtig Offenlegung von Informationen 3163018
Windows 10 Version 1511 für 32-Bit-Systeme[3](3172985) Microsoft .NET Framework 4.6.1 Wichtig Offenlegung von Informationen 3163018
Windows 10 Version 1511 für x64-basierte Systeme[3](3172985) Microsoft .NET Framework 3.5 Wichtig Offenlegung von Informationen 3163018
Windows 10 Version 1511 für x64-basierte Systeme[3](3172985) Microsoft .NET Framework 4.6.1 Wichtig Offenlegung von Informationen 3163018
Server Core-Installationsoption
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 (Server Core-Installation) Microsoft .NET Framework 3.5.1 (3163245) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 (Server Core-Installation) Microsoft .NET Framework 4.5.2[1](3163251) Wichtig Offenlegung von Informationen Keine
Windows Server 2008 R2 für x64-basierte Systeme Service Pack 1 (Server Core-Installation) Microsoft .NET Framework 4.6/4.6.1[1](3164025) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 (Server Core-Installation) Microsoft .NET Framework 3.5 (3163246) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 (Server Core-Installation) Microsoft .NET Framework 4.5.2[1](3163250) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 (Server Core-Installation) Microsoft .NET Framework 4.6/4.6.1[1](3164023) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 (Server Core-Installation) Microsoft .NET Framework 3.5 (3163247) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 (Server Core-Installation) Microsoft .NET Framework 4.5.2[1](3163291) Wichtig Offenlegung von Informationen Keine
Windows Server 2012 R2 (Server Core-Installation) Microsoft .NET Framework 4.6/4.6.1[1](3164024) Wichtig Offenlegung von Informationen Keine

[1]Informationen zu Änderungen an der Unterstützung für .NET Framework 4.x finden Sie unter Internet Explorer und .NET Framework 4.x-Supportankündigungen.

[2]Windows RT 8.1-Updates sind nur über Windows Update verfügbar.

[3]Windows 10 Updates sind kumulativ. Das monatliche Sicherheitsrelease enthält alle Sicherheitskorrekturen für Sicherheitsrisiken, die sich auf Windows 10 auswirken, zusätzlich zu nicht sicherheitsrelevanten Updates. Die Updates sind über den Microsoft Update-Katalog verfügbar.

Hinweis Die in diesem Bulletin beschriebene Sicherheitsanfälligkeit betrifft Windows Server 2016 Technical Preview 4 und Windows Server 2016 Technical Preview 5. Ein Update ist für Windows Server 2016 Technical Preview 5 über Windows Update verfügbar. Für Windows Server 2016 Technical Preview 4 ist jedoch kein Update verfügbar. Um vor dem Sicherheitsrisiko geschützt zu sein, empfiehlt Microsoft Kunden, die Windows Server 2016 Technical Preview 4 ausführen, ein Upgrade auf Windows Server 2016 Technical Preview 5 durchzuführen.

Informationen zu Sicherheitsrisiken

Sicherheitsanfälligkeit in .NET bezüglich Offenlegung von Informationen – CVE-2016-3255

Ein Sicherheitsrisiko bei der Offenlegung von Informationen liegt vor, wenn .NET Framework XML-Eingaben, die einen Verweis auf eine externe Entität enthalten, falsch analysiert. Ein Angreifer, der diese Sicherheitsanfälligkeit erfolgreich ausnutzt, kann beliebige Dateien über eine EXTERNE XML-Entitätsdeklaration lesen.

Um die Sicherheitsanfälligkeit auszunutzen, könnte ein Angreifer speziell gestaltete XML-Daten erstellen und eine Anwendung dazu veranlassen, die XML-Daten zu analysieren und zu überprüfen. Beispielsweise könnte ein Angreifer eine XML-Datei erstellen und in eine webbasierte Anwendung hochladen. Das Update behebt die Sicherheitsanfälligkeit, indem geändert wird, wie der XML External Entity (XXE)-Parser XML-Eingaben analysiert.

Die folgende Tabelle enthält Links zum Standardeintrag für die einzelnen Sicherheitsrisiken in der Liste Allgemeiner Sicherheitsrisiken und Risiken:

Titel der Sicherheitslücke CVE-Nummer Öffentlich zugänglich gemacht Genutzt
Sicherheitsrisiko bei der Offenlegung von .NET-Informationen CVE-2016-3255 Nein Nein

Schadensbegrenzende Faktoren

Microsoft hat keine mildernden Faktoren für dieses Sicherheitsrisiko identifiziert.

Problemumgehungen

Microsoft hat keine Problemumgehungen für dieses Sicherheitsrisiko identifiziert.

Bereitstellung von Sicherheitsupdates

Informationen zur Bereitstellung von Sicherheitsupdates finden Sie im Microsoft Knowledge Base-Artikel, auf den in der Zusammenfassung verwiesen wird.

Danksagungen

Microsoft erkennt die Bemühungen von Personen in der Sicherheitscommunity an, die uns helfen, Kunden durch koordinierte Offenlegung von Sicherheitsrisiken zu schützen. Weitere Informationen finden Sie unter Bestätigungen .

Haftungsausschluss

Die in der Microsoft Knowledge Base bereitgestellten Informationen werden ohne Jegliche Gewährleistung "wie ben" bereitgestellt. Microsoft lehnt jegliche Gewährleistungen ab, sei es ausdrücklich oder stillschweigend, einschließlich der Gewährleistungen der Marktgängigkeit und Eignung für einen bestimmten Zweck. In keinem Fall haften Die Microsoft Corporation oder ihre Lieferanten für Schäden jeglicher Art, einschließlich direkter, indirekter, zufälliger, Folgeschäden, Verlust von Geschäftsgewinnen oder besonderen Schäden, auch wenn Microsoft Corporation oder ihre Lieferanten auf die Möglichkeit solcher Schäden hingewiesen wurden. Einige Staaten lassen den Ausschluss oder die Beschränkung der Haftung für Folge- oder Nebenschäden nicht zu, sodass die vorstehende Einschränkung möglicherweise nicht gilt.

Revisionen

  • V1.0 (12. Juli 2016): Bulletin veröffentlicht.
  • V1.1 (8. November 2016): Das Bulletin wurde überarbeitet, um bekannt zu geben, dass eine Erkennungsänderung vorgenommen wurde, um .NET Framework 4.6.1-Hotfixrollup-Kunden zu berücksichtigen, denen nicht ordnungsgemäß Sicherheitsupdates für die .NET Framework 4.6.1 angeboten wurden.

Seite generiert am 03.11.2016 um 15:41-07:00 Uhr.