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Fehler AADSTS50020 beim Anmelden bei der OneDrive-Synchronisation-App

Symptome

Sie können sich nicht bei der Microsoft OneDrive-Synchronisation-App anmelden, und Sie erhalten die folgende Fehlermeldung:

AADSTS50020 Benutzerkonto des Identitätsanbieters ist im Mandanten nicht vorhanden und kann nicht auf die Anwendung (OneDrive SyncEngine) zugreifen.

Ursache

Dieses Problem kann durch zwischengespeicherte Identitäten aus dem vorherigen Mandanten verursacht werden. Dies tritt am häufigsten während einer Mandanten-zu-Mandant-Migration auf.

Weitere Informationen zu anderen möglichen Ursachen finden Sie unter Fehler AADSTS50020 : Benutzerkonto vom Identitätsanbieter ist im Mandanten nicht vorhanden.

Lösung

Um dieses Problem zu beheben, entfernen Sie die zwischengespeicherten Microsoft Office-Kontoidentitäten aus der Registrierung.

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung, bevor Sie sie ändern, damit Sie sie bei Bedarf wiederherstellen können.

  1. Starten Sie den Registrierungs-Editor.

  2. Suchen Sie den folgenden Registrierungseintrag:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

  3. Klicken Sie mit der rechten Maustaste auf Identität, und wählen Sie dann Löschen aus.

Hinweis: Wenn Sie die Aktivierung gemeinsam genutzter Computer aktiviert haben, entfernen Sie auch den Registrierungseintrag Identität aus HKEY_USERS\<The user SID>\SOFTWARE\Microsoft\Office\16.0\Common. Um die SID des aktuell angemeldeten Benutzers abzurufen, führen Sie den whoami /user Befehl in einem Eingabeaufforderungsfenster aus. Wenn das Problem weiterhin besteht, erweitern Sie "Abschnitt A: Entfernen von Office-Lizenzen & zwischengespeicherten Konten" in Löschen der vorherigen Aktivierungsinformationen manuell, und führen Sie dann die Schritte in Teil 1: Entfernen vorheriger Office-Aktivierungen und Teil 3: Entfernen von office-Anmeldeinformationen aus, die in Windows Credential Manager gespeichert sind.

Wenn das Problem weiterhin besteht, führen Sie die folgenden Schritte aus:

  1. Melden Sie sich von OneDrive for Business ab. 

  2. Entfernen Sie alle Ordner an den folgenden Speicherorten:

    • %localappdata%/Microsoft/OneAuth
    • %localappdata%/Microsoft/IdentityCache