Anmeldung mit SSO nicht möglich, wenn ADAL und AD FS in Skype for Business

Ursprüngliche KB-Nummer: 4508931

Symptome

Neue Benutzer können sich nicht bei Microsoft Skype for Business 2016 lokal mit der SSO-Methode (Single Sign-On, einmaliges Anmelden) anmelden, wenn die Azure Active Directory-Authentifizierungsbibliothek (ADAL) und Active Directory-Verbunddienste (AD FS) (AD FS) verwendet werden.

Vorhandene Profile sind von diesem Problem nicht betroffen. Neue Benutzer oder Benutzer, die beim Versuch, sich anzumelden, ihr Profil gelöscht haben, erhalten diese Fehlermeldung:

Ein Fehler aufgetreten.

Dieses Problem tritt auch auf neu imageierten Computern auf, wenn kein Benutzerprofil erstellt wurde.

Ursache

Dieses Problem tritt auf, weil die Standardauthentifizierungsmethode nach dem Upgrade auf Microsoft Office 2016 Version 16.0.7967.0000 oder höher in Web Account Manager (WAM) geändert wird.

Problemumgehung

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung für die Wiederherstellung , falls Probleme auftreten.

Fügen Sie einen der folgenden Registrierungsschlüssel hinzu:

  • Fügen Sie den EnableWAM Schlüssel zu diesem Unterschlüssel hinzu:

    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Lync

    Name: EnableWAM
    Typ: DWORD (32 Bit)
    Wert: 0x00000000

  • Fügen Sie den EnableWAM Schlüssel zu diesem Unterschlüssel hinzu:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync

    Name: EnableWAM
    Typ: DWORD (32 Bit)
    Wert: 0x00000000

  • Fügen Sie den DisableADALatopWAM Schlüssel zu diesem Unterschlüssel hinzu:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

    Name: DisableADALatopWAM
    Typ: DWORD (32 Bit)
    Wert: 1

    Hinweis

    Es gibt einen ähnlichen Schlüssel mit dem Namen DisableADALatopWAMOverride am gleichen Speicherort. Dieser Schlüssel wird von Skype for Business nicht verwendet. Verwenden Sie DisableADALatopWAM , wenn Sie diese Option auswählen.

Weitere Informationen

Verwenden Sie die moderne Hybridauthentifizierung, um dieses Problem zu vermeiden. Weitere Informationen finden Sie unter Übersicht über moderne Hybridauthentifizierung und Voraussetzungen für die Verwendung mit lokalen Skype for Business- und Exchange-Servern.