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MSSQLSERVER_3201

Gilt für: SQL Server

Details

attribute Wert
Produktname SQL Server
Ereignis-ID 3201
Ereignisquelle MSSQLSERVER
Komponente SQLEngine
Symbolischer Name BADOPEN
Meldungstext Das Sicherungsmedium '%ls' kann nicht geöffnet werden. Betriebssystemfehler "%ls".

Erklärung

Der Fehler tritt auf, wenn SQL Server kein neues oder vorhandenes Sicherungsgerät zum Ausführen eines Sicherungsvorgangs erstellen kann. Sicherungsgeräte umfassen Dateien, Bänder, virtuelle Geräte für VDI. Die Meldung enthält den ausgelösten Betriebssystemfehler und wird zurückgegeben, wenn der Gerätezugriff ausgeführt wird. Dieser Betriebssystemfehler enthält wichtige Informationen, die Ihnen helfen, die Ursache des Fehlers zu verstehen.

Der Status des Fehlers kann auch einige nützliche Informationen bereitstellen. Hier sind einige nützliche Zustände:

  • Status 1 und 3 – Sicherungsdatei erstellen
  • Status 2 : Sicherungsdatei öffnen
  • Zustand 5 - offenes Band
  • Status 7 – Initialisieren des virtuellen Geräts
  • Status 6 – virtuelles Gerät öffnen
  • Zustand 8 – Öffnen und Erwerben des Besitzes eines Bandgeräts

Mögliche Ursachen

Es kann mehrere Gründe geben, warum sie nicht auf ein Sicherungsgerät zugreifen können. Häufige Beispiele sind:

  • Das Sicherungsgerät ist nicht verfügbar oder ungültig. Typische Beispiele für Betriebssystemfehler, die diesem Szenario zugeordnet sind: Fehler 2 (Das System kann die angegebene Datei nicht finden.), Fehler 6 (Das Handle ist ungültig.), Fehler 3 (Das System kann den angegebenen Pfad nicht finden.)
  • Unzureichende Berechtigungen verhindern, dass SQL Server auf das Gerät zugreift– Betriebssystemfehler 5 (Zugriff verweigert.), Betriebssystemfehler 1117 (Die Anforderung konnte aufgrund eines E/A-Gerätefehlers nicht ausgeführt werden.)
  • Das Gerät ist beschädigt oder enthält beschädigte oder beschädigte Daten - Betriebssystemfehler 1117 (Die Anforderung konnte aufgrund eines E/A-Gerätefehlers nicht ausgeführt werden.), Betriebssystemfehler 21 (Das Gerät ist nicht bereit.), Betriebssystemfehler 23 (Datenfehler (zyklische Redundanzüberprüfung).), Betriebssystemfehler 27 (Das Laufwerk kann den angeforderten Sektor nicht finden.)

Benutzeraktion

Um Fehler zu beheben, bei denen das Gerät nicht verfügbar oder ungültig ist, stellen Sie sicher, dass Sie den richtigen Gerätespeicherort (Pfad, Name) angeben und sicherstellen, dass das Gerät vorhanden ist und online ist. Verwenden Sie beispielsweise Windows Explorer, um zu einer Sicherungsdatei zu navigieren und sicherzustellen, dass sie vorhanden ist. Für die Sicherung zur URL in einem Azure-Speicherkonto können Sie Ping oder PsPing am Port 443 durchführen, um die Konnektivität zu überprüfen.

Um Fehler mit unzureichenden Berechtigungen zu beheben, stellen Sie sicher, dass dem SQL Server-Startkonto Lese- und Schreibzugriff auf das Sicherungsgerät gewährt wurde. Stellen Sie sicher, dass für die Sicherung zu URL zu Cloud wie Azure ein gültiges SAS-Token (Shared Access Signature) oder verwaltete Identitäten vorhanden sind, um auf eine Azure-Ressource zuzugreifen.For backup to URL to cloud like Azure, ensure a valid shared access signature (SAS) token or Managed identities exist to access an Azure resource.

Beschädigte oder beschädigte Daten auf Geräten sind häufig Probleme mit der Hardware oder weniger häufig mit dem Betriebssystem. Untersuchen Sie mit Ihrem Systemadministrator, ob das Gerät intakt ist und ob Sie Testdaten lesen oder schreiben können, und reparieren oder ersetzen Sie beschädigtes Gerät.