Authentifizierungsprobleme beim Herstellen einer Verbindung mit Salesforce CRM
Dieser Artikel hilft Ihnen bei der Behandlung und Behebung von Authentifizierungsproblemen beim Herstellen einer Verbindung mit Salesforce CRM über das Microsoft Copilot for Sales-Add-In für Outlook.
Hinweis
Microsoft Sales Copilot wird im Januar 2024 in Microsoft Copilot for Sales umbenannt. Die Screenshots in diesem Artikel werden in Kürze mit dem neuen Namen aktualisiert.
Wer ist betroffen?
Anforderungstyp | Beschreibung |
---|---|
Client-App | Copilot for Sales Outlook-Add-In und Teams-App |
Plattform | Web- und Desktopclients |
Betriebssystem | Windows und Mac |
Bereitstellung | Vom Benutzer verwaltet und vom Administrator verwaltet |
CRM | Salesforce |
Benutzer | Benutzer, die versuchen, sich bei Salesforce CRM anzumelden |
Symptome
Wenn Sie versuchen, sich über das Copilot for Sales-Add-In für Outlook bei Salesforce CRM anzumelden, wird die folgende Fehlermeldung angezeigt:
Fehler, der an die Umleitungs-URL übergeben wurde. error=OAUTH_APP_ACCESS_DENIED error_description=user is not vom Administrator genehmigt für den Zugriff auf diese App
Ursache
Richtlinien der verbundenen Microsoft Power Platform-App verhindern, dass Benutzer eine Verbindung mit Salesforce CRM herstellen.
Copilot for Sales stellt über die verbundene Microsoft Power Platform-App eine Verbindung mit Salesforce CRM her. Um sich von Copilot for Sales bei Salesforce CRM anzumelden, müssen Benutzer der Microsoft Power Platform-App ihre Zustimmung erteilen, um Salesforce CRM in ihrem Namen zu kontaktieren. Wenn keine Zustimmung erteilt werden kann, schlägt der Anmeldevorgang fehl.
Lösung
Copilot for Sales verwendet die verbundene Microsoft Power Platform-App, um eine Verbindung mit Salesforce CRM herzustellen. Stellen Sie sicher, dass die Richtlinien der Microsoft Power Platform-App so konfiguriert sind, dass Benutzer eine Verbindung mit Salesforce CRM herstellen können.
Melden Sie sich bei Salesforce CRM als Administrator an.
Wechseln Sie zu Plattformtools>>Einrichten Von Apps>Verbundene Apps>Verwaltete verbundene Apps.
Wählen Sie auf der Seite Verbundene Appsdie Option Microsoft Power Platform aus.
Wählen Sie Richtlinien bearbeiten aus.
Wählen Sie unter OAuth-Richtlinien einen der folgenden Werte für Zulässige Benutzer aus:
Alle Benutzer können sich selbst autorisieren: Mit dieser Option kann jeder authentifizierte Salesforce-Benutzer über den Microsoft Power Platform-Connector, der von Microsoft Copilot for Sales, Microsoft Power Automate und potenziell anderen Apps verwendet wird, eine Verbindung mit salesforce instance herstellen und so das Problem beheben.
Admin genehmigten Benutzer vorautorisiert sind: Mit dieser Option können Administratoren einzelnen Benutzern explizit Berechtigungen über Profile und Berechtigungssätze erteilen. Weitere Informationen finden Sie unter Verbundene Apps und Verwalten des Zugriffs auf eine verbundene App.
Klicken Sie auf Speichern.
Weitere Informationen
Wenn Ihr Problem immer noch nicht gelöst ist, wechseln Sie zum Copilot for Sales - Microsoft Community Hub , um mit unseren Experten zu interagieren.
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