Fehler "Anfordern von CRM-Administratorberechtigungen für den Zugriff auf Salesforce mithilfe von APIs"
Dieser Artikel hilft Ihnen bei der Behandlung und Behebung von Problemen, wenn eine Fehlermeldung angezeigt wird, nachdem sie eine Verbindung hergestellt und sich bei Salesforce CRM in Microsoft Copilot for Sales angemeldet haben.
Hinweis
Microsoft Sales Copilot wird im Januar 2024 in Microsoft Copilot for Sales umbenannt. Die Screenshots in diesem Artikel werden in Kürze mit dem neuen Namen aktualisiert.
Wer ist betroffen?
Anforderungstyp | Beschreibung |
---|---|
Client-App | Copilot for Sales Outlook-Add-In |
Plattform | Web- und Desktopclients |
Betriebssystem | Windows und Mac |
Bereitstellung | Vom Benutzer verwaltet und vom Administrator verwaltet |
CRM | Salesforce |
Benutzer | Benutzer, die versuchen, Copilot for Sales mit Salesforce CRM zu verwenden |
Symptome
Nachdem Sie sich über das Copilot for Sales-Add-In für Outlook bei Salesforce CRM angemeldet haben, wird die folgende Fehlermeldung angezeigt:
Anfordern von CRM-Administratorberechtigungen für den Zugriff auf Salesforce mithilfe von APIs
Ursache
Das Problem tritt auf, wenn Sie nicht über API-Berechtigungen in Salesforce verfügen. Sie können überprüfen, ob dies die Grundursache des Problems ist, wenn der folgende Fehler in den Protokollen angezeigt wird:
Exception thrown in VivaSalesContacts/GetContactsByEmailAddress -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self --->
System.Exception: {
"error": {
"code": 502,
"source": "{APIM SOURCE}",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
}
}
Lösung
Ein Administrator kann dem Benutzer oder dem Profil des betroffenen Benutzers die API-fähige Berechtigung erteilen, indem er die folgenden Schritte ausführt:
Melden Sie sich bei Salesforce als Administrator an.
Geben Sie im Suchfeld Benutzer ein.
Wählen Sie im linken Navigationsbereich Profile und dann das Profil des betroffenen Benutzers aus.
Wählen Sie im Abschnitt Administrative Berechtigungen die Option API aktiviert aus.
Klicken Sie auf Speichern.
Weitere Informationen
Wenn Ihr Problem immer noch nicht gelöst ist, wechseln Sie zum Copilot for Sales - Microsoft Community Hub , um mit unseren Experten zu interagieren.
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