Fehler AADSTS750054: SAMLRequest oder SAMLResponse muss als Abfragezeichenfolgenparameter in der HTTP-Anforderung für die SAML-Umleitungsbindung vorhanden sein.

In diesem Artikel wird ein Problem beschrieben, bei dem Sie die Fehlermeldung "Error AADSTS750054 - SAMLRequest or SAMLResponse must be present as query string parameters in HTTP request for SAML Redirect binding." (Fehler AADSTS750054 – SAMLRequest oder SAMLResponse muss als Abfragezeichenfolgenparameter in der HTTP-Anforderung für Microsoft Entra ID die SAML-Umleitungsbindung vorhanden sein.

Problembeschreibung

Beim Versuch, sich bei einer Anwendung anzumelden, die für die Verwendung von Microsoft Entra ID für die Identitätsverwaltung mit SAML-basiertem einmaligem Anmelden eingerichtet wurde, wird eine Fehlermeldung AADSTS750054 angezeigt.

Ursache

Microsoft Entra ID konnte die SAML-Anforderung in den URL-Parametern in der HTTP-Anforderung nicht identifizieren. Dies kann passieren, wenn die Anwendung beim Senden der SAML-Anforderung an Microsoft Entra ID keine HTTP-Umleitungsbindung verwendet.

Fehlerbehebung

Die Anwendung muss die SAML-Anforderung mithilfe der HTTP-Umleitungsbindung in den Location-Header codiert senden. Weitere Informationen zur Implementierung finden Sie im Abschnitt HTTP-Umleitungsbindung im Dokument zur SAML-Protokollspezifikation.

In den meisten Fällen ist der Fehler auf eines der folgenden Probleme zurückzuführen:

  1. Stellen Sie sicher, dass einmaliges Anmelden auf der Anwendungsseite aktiviert ist.
  2. Die Anwendung muss das vom Dienstanbieter initiierte einmalige Anmelden (manchmal als SP-initiiertes einmaliges Anmelden bezeichnet) unterstützen. Wenn Sie eine Anmelde-URL für eine Anwendung eingeben, die nur das vom Identitätsanbieter initiierte einmalige Anmelden unterstützt, kann dies zu einem Rücksprung von der Anwendung ohne SAML-Antwort führen.
  3. Vergewissern Sie sich, dass die Anmelde-URL ordnungsgemäß konfiguriert ist.

Verwenden der Test-SSO-Funktion im Microsoft Entra Admin Center

Die Microsoft Entra Admin Center kann Ihnen bei der Behandlung von SAML-Konfigurationsfehlern helfen.

Screenshot: Testen des SSO-Features in Microsoft Entra Admin Center.

  1. Wechseln Sie im Microsoft Entra Admin Center zu Unternehmensanwendungen, und klicken Sie auf die Anwendung, für die eine Problembehandlung erforderlich ist.
  2. Navigieren Sie über das linke Navigationsmenü zur Seite einmaliges Anmelden .
  3. Klicken Sie auf Diese Anwendung testen , um die Funktion Test SSO zu verwenden.
  4. Kopieren Sie den empfangenen Fehler, fügen Sie ihn in den Abschnitt Beheben von Fehlern ein, und klicken Sie auf Leitfaden zur Auflösung abrufen.
  5. Führen Sie die Schritte zum Beheben von Fehlern aus. AADSTS750054

Weitere Informationen

Eine vollständige Liste der Fehlercodes für die Active Directory-Authentifizierung und -Autorisierung finden Sie unter Microsoft Entra Authentifizierungs- und Autorisierungsfehlercodes.

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