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Problembehandlung für den Fehlercode K8SAPIServerConnFailVMExtensionError (51)

In diesem Artikel wird erläutert, wie Sie den K8SAPIServerConnFailVMExtensionError Fehler (auch als Fehlercode ERR_K8S_API_SERVER_CONN_FAIL, Fehlernummer 51 bezeichnet) identifizieren und beheben, der auftritt, wenn Sie versuchen, einen AKS-Cluster (Microsoft Azure Kubernetes Service) zu starten oder zu erstellen und bereitzustellen.

Voraussetzungen

Problembeschreibung

Wenn Sie versuchen, einen AKS-Cluster zu starten oder zu erstellen, wird die folgende Fehlermeldung angezeigt:

Es kann keine Verbindung von Agents mit dem Kubernetes-API-Server hergestellt werden. Weitere Informationen finden Sie unter https://aka.ms/aks-required-ports-and-addresses .

Details: Code="VMExtensionProvisioningError"

Message="VM hat einen Fehler bei der Verarbeitung der Erweiterung 'vmssCSE' gemeldet.

Fehlermeldung: "Fehler beim Aktivieren: Befehl konnte nicht ausgeführt werden: Befehl beendet mit exit status=51\n[stdout]\n{

"ExitCode": "51",

"Output": "Do Okt 14 18:07:37 UTC 2021,aks-nodepool1-18315663-vmss000000\nConnection to

Ursache

Ihre Clusterknoten können keine Verbindung mit Ihrem Cluster-API-Serverpod herstellen.

Lösung

Führen Sie einen Netcat-Befehl aus, um zu überprüfen, ob Ihre Knoten den vollqualifizierten Domänennamen (FQDN) des Clusters auflösen können:

nc -vz <cluster-fqdn> 443

Wenn Sie die Filterung für ausgehenden Datenverkehr durch eine Firewall verwenden, stellen Sie sicher, dass Datenverkehr für Ihren Cluster-FQDN zulässig ist.

In seltenen Fällen kann die ausgehende IP-Adresse der Firewall blockiert werden, wenn Sie IP-Adressen autorisiert haben, die für Ihren Cluster aktiviert sind. In diesem Szenario müssen Sie die ausgehende IP-Adresse Ihrer Firewall der Liste der autorisierten IP-Adressbereiche für den Cluster hinzufügen. Weitere Informationen finden Sie unter Sicherer Zugriff auf den API-Server mithilfe autorisierter IP-Adressbereiche in AKS.

Weitere Informationen

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.