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Problembehandlung für den Fehlercode TooManyRequestsReceived oder SubscriptionRequestsThrottled

In diesem Artikel wird erläutert, wie Sie den Fehler oder den Fehler identifizieren und SubscriptionRequestsThrottled beheben, der TooManyRequestsReceived beim Löschen eines AKS-Clusters (Microsoft Azure Kubernetes Service) auftritt.

Problembeschreibung

Wenn Sie versuchen, einen AKS-Cluster zu löschen, wird die folgende Fehlermeldung angezeigt:

internalErrorCode: TooManyRequestsReceived

StatusCode: 429

{

message: "Anzahl der Leseanforderungen für das Abonnement '.....'' hat den Grenzwert von "...." überschritten. für das Zeitintervall "XX:XX:XX". Versuchen Sie es nach "....." erneut. sekunden."

}

Ursache

Jeder Vorgang auf Abonnement- und Mandantenebene unterliegt Drosselungsgrenzwerten. Diese Grenzwerte gelten für jeden instance von Azure Resource Manager. Wenn Sie den Grenzwert erreichen, erhalten Sie eine HTTP-Antwort, die status Code 429 angibt: "Zu viele Anforderungen".

Lösung

Die HTTP-Antwort enthält einen Retry-After Wert. Dies gibt die Anzahl von Sekunden an, die Ihre Anwendung warten (oder in den Ruhezustand versetzen) soll, bevor sie die nächste Anforderung sendet. Wenn Sie eine Anforderung senden, bevor der Wiederholungswert abgelaufen ist, wird Ihre Anforderung nicht verarbeitet, und ein neuer Wiederholungswert wird zurückgegeben. Weitere Informationen zu Drosselungsgrenzwerten finden Sie unter Drosselung Resource Manager Anforderungen.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.