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Die Liste der Benutzer oder Gruppen kann beim Hinzufügen von Berechtigungen in der Zugriffssteuerung im Azure-Portal nicht angezeigt werden.

Dieser Artikel enthält Informationen zu einem Problem, bei dem sie beim Hinzufügen von Berechtigungen in Access Control (IAM) im Azure-Portal keine Liste von Benutzern oder Gruppen sehen können.

Originalversion des Produkts: Azure
Ursprüngliche KB-Nummer: 4229970

Symptome

Wenn Sie versuchen, Berechtigungen in IAM im Azure-Portal hinzuzufügen, wird die Liste der Benutzer oder Gruppen nicht angezeigt.

Ursache

Dieses Problem tritt auf, da das Konto, mit dem Sie sich bei Azure-Portal angemeldet haben, keine Enumerationsberechtigung besitzt. Dieses Konto kann ein Gastbenutzer sein, der zum Verzeichnis eingeladen wurde, dem Sie Zugriff auf andere Azure-Ressourcen gewähren möchten. Selbst wenn dieser Gastbenutzer ein globaler Administrator ist, verfügt er immer noch nicht über enumerationsberechtigungen.

Lösung

Sie können dieses Problem mit einer der folgenden Methoden beheben:

Methode 1: So erlauben Sie allen Gastbenutzern Enumerationsberechtigungen

  1. Melden Sie sich mit dem globalen Administrator beim Azure-Portal an.
  2. Wechseln Sie ggf. zu dem Verzeichnis, in dem der Gastbenutzer hinzugefügt wurde.
  3. Navigieren Sie zu Microsoft Entra ID.
  4. Wechseln Sie zu "Benutzereinstellungen".
  5. Ändern Sie die Berechtigungen für Gastbenutzer, sind die Einstellung auf "Nein" beschränkt, und wählen Sie dann "Speichern" aus.

Methode 2: So lassen Sie nur den einen Gastbenutzer zu oder konfigurieren sie pro Benutzer

  1. Stellen Sie sicher, dass die Microsoft Graph PowerShell installiert ist.

  2. Verwenden Sie den Connect-MgGraph Befehl, um sich mit den erforderlichen Bereichen anzumelden. Weitere Informationen finden Sie unter Erste Schritte mit dem Microsoft Graph PowerShell-SDK.

  3. Führen Sie das Cmdlet Update-MgUser aus:

    Update-MgUser -UserId '0ba17ca9-0000-0000-0000-a5e34bc4803b' -UserType Member
    

    Sie können die Benutzerobjekt-ID abrufen, indem Sie sich die Seite "Benutzerprofil" im Azure-Portal ansehen.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.