Beheben eines AllocationFailed- oder ZonalAllocationFailed-Fehlers beim Erstellen, Neustarten oder Ändern der Größe Virtual Machine Scale Sets in Azure

Warnung

Wenn Ihre Microsoft Azure-VM-Skalierungsgruppe Teil eines Azure Service Fabric-Clusters ist, befolgen Sie diesen Leitfaden zur Problembehandlung nicht. Diese Anleitung kann in diesem Szenario zu Datenverlusten und irreversiblen Clusterschäden führen. Weitere Informationen finden Sie unter Kann ich große VM-Skalierungsgruppen in meinem Service Fabric-Cluster verwenden?

In diesem Artikel erhalten Sie Informationen zu:

  • AllocationFailed- oder ZonalAllocationFailed-Fehler in Microsoft Azure Virtual Machine Scale Sets.
  • So vermeiden Sie Zuordnungsfehler.
  • Die Ursachen der Zuordnungsfehler.
  • Behandeln von Zuordnungsfehlern, wenn sie auftreten.

Informationen zur Problembehandlung von Zuordnungsfehlern für virtuelle Standardcomputer (VMs) finden Sie unter Behandeln von Zuordnungsfehlern beim Erstellen, Neustarten oder Ändern der Größe von VMs in Azure.

Problembeschreibung

Aufgrund der hohen Nachfrage nach Azure-Diensten kann ein Zuordnungsfehler auftreten, wenn Sie versuchen, VM-Instanzen in bestimmten Regionen zu erstellen oder zu starten. Azure versucht, Ihrem Abonnement Computeressourcen zuzuordnen, wenn Sie:

  • Erstellen Sie eine VM-Skalierungsgruppe.
  • Starten Sie eine beendete (nicht zugeordnete) Skalierungsgruppe-VM instance neu.
  • Ändern der Größe einer Skalierungsgruppe

Die folgenden Fehlerdetails sind ein Beispiel für die Zuordnungsfehlermeldung.

Fehlercode: AllocationFailed oder ZonalAllocationFailed

Fehlermeldung 1: Fehler bei der Zuordnung. Wir verfügen in dieser Region nicht über genügend Kapazität für die angeforderte VM-Größe. Weitere Informationen zur Verbesserung der Wahrscheinlichkeit einer erfolgreichen Zuordnung finden Sie unter https://aka.ms/allocation-guidance.

Fehlermeldung 2: Fehler bei der Zuordnung. Virtuelle Computer mit den folgenden Einschränkungen können nicht zugewiesen werden, da die Bedingung zu restriktiv ist. Entfernen Sie einige Einschränkungen, und versuchen Sie es erneut. Angewendete Einschränkungen sind:

  • Verfügbarkeitszone
  • VM-Größe

Fehlermeldung 3: Fehler bei der Zuordnung. Wenn Sie versuchen, einer VM-Skalierungsgruppe mit einer einzelnen Platzierungsgruppe eine neue VM hinzuzufügen oder eine vorhandene VM zu aktualisieren bzw. ihre Größe zu ändern, sollten Sie beachten, dass diese Zuordnung nur auf einen einzelnen Cluster beschränkt ist und es möglich ist, dass der Cluster nicht über genügend Kapazität verfügt. Weitere Informationen zur Verbesserung der Wahrscheinlichkeit einer erfolgreichen Zuordnung finden Sie unter https://aka.ms/allocation-guidance.

Vermeiden von Zuordnungsfehlern

Um Zuordnungsfehler zu vermeiden, können Sie einige Konfigurationseinstellungen auf die Skalierungsgruppe anwenden, um Zuordnungsanforderungen zu optimieren.

  • Überbereitstellung. Wenn die Überbereitstellung aktiviert ist, führt die Skalierungsgruppe tatsächlich mehr VM-Instanzen aus, als Sie angefordert haben. Anschließend werden die zusätzlichen VM-Instanzen gelöscht, sobald die angeforderte Anzahl von VM-Instanzen erfolgreich bereitgestellt wurde. Diese Vorgehensweise verbessert die Erfolgsraten bei der Bereitstellung und verkürzt die Bereitstellungszeit. Die zusätzlichen VM-Instanzen werden Ihnen nicht in Rechnung gestellt, und sie werden nicht auf Ihre Kontingentgrenzen angerechnet. So aktivieren Sie die Überbereitstellung:

    1. Suchen Sie im Azure-Portal nach VM-Skalierungsgruppen, und wählen Sie diese Option aus.

    2. Wählen Sie den Namen Ihrer Skalierungsgruppe aus.

    3. Wählen Sie im Menübereich Konfiguration aus.

    4. Legen Sie in der Überschrift Überbereitstellung aktivieren die Option Überbereitstellung aktivieren auf Ein fest.

    5. Klicken Sie auf Speichern.

    Erfahren Sie mehr über die Überbereitstellung.

  • Aktivieren sie große Skalierungsgruppen. Große Virtual Machine Scale Sets werden als Skalierungsgruppen definiert, die auf mehr als 100 VM-Instanzen skaliert werden können. Diese Funktion wird durch eine Skalierungsgruppeneigenschaft (singlePlacementGroup=false) festgelegt. Das Besondere an einer großen Skalierungsgruppe ist nicht die Anzahl der VM-Instanzen, sondern die Anzahl der darin enthaltenen Platzierungsgruppen. Eine Platzierungsgruppe ähnelt einer Azure-Verfügbarkeitsgruppe mit eigenen Fehlerdomänen und Upgradedomänen. Wenn singlePlacementGroup auf falsefestgelegt ist, haben Sie eine höhere Wahrscheinlichkeit, dass die Zuordnung erfolgreich ist, da die Bereitstellungen auf mehrere Cluster verteilt werden können, wenn sie als Multiplacementgruppe bereitgestellt werden. Erfahren Sie mehr über das Arbeiten mit großen VM-Skalierungsgruppen, insbesondere zum Konvertieren einer vorhandenen Skalierungsgruppe, um mehrere Platzierungsgruppen zu umfassen.

    Hinweis

    Sie können eine Skalierungsgruppe von der Unterstützung einer einzelnen Platzierungsgruppe in die Unterstützung mehrerer Platzierungsgruppen ändern, aber Sie können keine Konvertierung in die andere Richtung durchführen. Sobald singlePlacementGroup auf falsefestgelegt ist, können Sie es nicht mehr zurück ändern.

Verringern Sie die Anzahl der Instanzen der angeforderten VM-Größe, und wiederholen Sie dann den Bereitstellungsvorgang. Bei größeren Bereitstellungen können Sie Azure Virtual Machine Scale Sets mit mehreren Platzierungsgruppen auswerten. Die Anzahl der VM-Instanzen kann als Reaktion auf die Nachfrage oder einen definierten Zeitplan automatisch erhöht oder verringert werden.

Weitere Tipps

Bis Ihr bevorzugter VM-Typ in Ihrer bevorzugten Region verfügbar ist, sollten Kunden, bei denen Bereitstellungsprobleme auftreten, die Anleitung in den folgenden Abschnitten als temporäre Lösung betrachten.

Identifizieren Sie das Szenario, das am besten zu Ihrem Fall passt. Um die Wahrscheinlichkeit eines erfolgreichen Zuordnungsvorgangs zu erhöhen, wiederholen Sie die Zuordnungsanforderung mithilfe der entsprechenden vorgeschlagenen Lösung. Sie können es auch später immer wiederholen. Möglicherweise wurden genügend Ressourcen im Cluster, in der Region oder in der Zone freigegeben, um Ihre Anforderung zu einem anderen Zeitpunkt zu berücksichtigen.

Ursache

Die Region oder Zone verfügt nicht über genügend Kernkapazität für die angeforderte SKU.

Ursache 1: Ändern der Größe einer Skalierungsgruppe oder Hinzufügen von VM-Instanzen zu einer vorhandenen Skalierungsgruppe

Wenn eine Anforderung zum Ändern der Größe einer Skalierungsgruppe oder zum Hinzufügen eines virtuellen Computers instance zu einer vorhandenen Skalierungsgruppe vorhanden ist, muss dies im ursprünglichen Cluster versucht werden, der die vorhandene Skalierungsgruppe hostet. Oder der Cluster unterstützt die angeforderte VM-Größe, verfügt aber möglicherweise derzeit nicht über genügend Kapazität.

Lösung für Ursache 1

Probieren Sie eine der folgenden Aktionen aus:

  • Versuchen Sie, die Skalierungsgruppe in einen anderen Cluster in derselben Region mit ausreichender Kapazität zu verschieben.

    Beenden (Aufheben der Zuordnung) aller VM-Instanzen in der Skalierungsgruppe, und ändern Sie dann die Größe der Skalierungsgruppe nach Bedarf. Nachdem die Größenänderung abgeschlossen ist, starten Sie die VM-Instanzen neu. So beenden Sie die VM-Instanzen:

    1. Suchen Sie im Azure-Portal nach VM-Skalierungsgruppen, und wählen Sie diese Option aus.

    2. Wählen Sie den Namen Ihrer Skalierungsgruppe aus.

    3. Wählen Sie Beenden aus.

    Nachdem Sie alle VM-Instanzen beendet haben, um die Größenänderung auszuführen, und dann die Skalierungsgruppe starten, kann der neue Zuordnungsversuch einen Cluster identifizieren, der über genügend Kapazität verfügt, um die gesamte Skalierungsgruppe zu hosten.

  • Konfigurieren Sie Ihre Skalierungsgruppe so, dass sie über mehrere Platzierungsgruppen hinweg skaliert wird.

    Weitere Informationen finden Sie unter Erstellen einer großen Skalierungsgruppe.

Ursache 2: Neustart einer teilweise beendeten (freigegebenen) VM

Partielle Aufhebung der Zuordnung bedeutet, dass Sie eine oder mehrere VM-Instanzen in einer Skalierungsgruppe beendet (die Zuordnung aufgehoben), aber nicht alle. Wenn Sie die Zuordnung eines virtuellen Computers instance aufheben, werden die zugeordneten Ressourcen freigegeben. Das Neustarten von VM-Instanzen in einer teilweise freigegebenen Verfügbarkeitsgruppe entspricht dem Hinzufügen von VM-Instanzen zu einer vorhandenen Verfügbarkeitsgruppe. Daher müssen Sie die Zuordnungsanforderung im ursprünglichen Cluster ausprobieren, der die vorhandene Verfügbarkeitsgruppe hostet, die möglicherweise nicht genügend Kapazität aufweist.

Lösung für Ursache 2

Beenden (Aufheben der Zuordnung) aller VM-Instanzen in der Skalierungsgruppe, und starten Sie dann jede VM instance neu. So beenden Sie die VM-Instanzen:

  1. Suchen Sie im Azure-Portal nach VM-Skalierungsgruppen, und wählen Sie diese Option aus.

  2. Wählen Sie den Namen Ihrer Skalierungsgruppe aus.

  3. Wählen Sie im Menübereich Instanzen aus.

  4. Wählen Sie alle aufgeführten VM-Instanzen aus.

  5. Wählen Sie Beenden aus.

Nachdem alle VMs beendet wurden, wählen Sie die erste VM instance und dann Start aus. Azure unternimmt einen neuen Zuordnungsversuch und wählt einen neuen Cluster aus, der über ausreichende Kapazität verfügt.

Ursache 3: Neu gestartete VM-Instanzen, die vollständig beendet wurden

Vollständige Aufhebung der Zuordnung bedeutet, dass Sie alle VM-Instanzen in einer Verfügbarkeitsgruppe beendet (die Zuordnung aufgehoben) haben. Die Zuordnungsanforderung zum Neustart dieser VM-Instanzen zielt auf alle Cluster ab, die die erforderliche Größe innerhalb der Region oder Zone unterstützen.

Lösung für Ursache 3

Ändern Sie Ihre Zuordnungsanforderung mithilfe der Vorschläge in diesem Artikel. Wiederholen Sie dann die Anforderung, um die Wahrscheinlichkeit einer erfolgreichen Zuordnung zu verbessern.

Wenn Sie ältere VM-Serien oder -Größen (z. B. Dv1, DSv1, Av1, D15v2 oder DS15v2) verwenden, sollten Sie zu neueren Versionen wechseln. Beachten Sie diese Empfehlungen für bestimmte VM-Größen. Ist es Ihnen nicht erlaubt, eine andere VM-Größe zu verwenden? Versuchen Sie dann, die Bereitstellung in einer anderen Region innerhalb derselben Geografie auszuführen. Weitere Informationen zu den verfügbaren VM-Größen in jeder Region finden Sie unter https://aka.ms/azureregions.

Wenn Sie Verfügbarkeitszonen verwenden, versuchen Sie es mit einer anderen Zone innerhalb der Region, die möglicherweise über verfügbare Kapazität für die angeforderte VM-Größe verfügt.

Wenn Ihre Zuordnungsanforderung groß ist (mehr als 500 Kerne), lesen Sie die folgenden Abschnitte, um die Anforderung in kleinere Bereitstellungen aufzuteilen.

Versuchen Sie, die VM-instance erneut bereitzustellen, wodurch die VM-instance einem neuen Cluster innerhalb der Region zugewiesen wird.

Zuordnungsfehler für ältere VM-Größen

Einige vm-Größen älterer Serien werden nicht in unserer Infrastruktur der neuesten Generation ausgeführt. Bei Kunden können gelegentlich Zuordnungsfehler für diese Legacy-SKUs auftreten. Wir empfehlen Kunden, die virtuelle Computer der Legacyserie verwenden, eine Migration zu den entsprechenden neueren VMs in Betracht zu ziehen. Die neueren VMs sind für die neueste Hardware optimiert und ermöglichen es Ihnen, bessere Preise und Leistung zu nutzen.

Sehen Sie sich die folgenden Empfehlungen an:

Legacy-VM-Serie oder -Größe Empfohlene neuere VM-Serie oder -Größe Bloglink
Av1-Serie Av2-Serie Neue A_v2-Series VM-Größen
Dv1- oder DSv1-Serie (D1 bis D5) Dv3- oder DSv3-Serie Einführung in die neuen VM-Größen Dv3 und Ev3
Dv1- oder DSv1-Serie (D11 bis D14) Ev3- oder ESv3-Serie
D15v2 oder DS15v2

Wenn Sie das Resource Manager-Bereitstellungsmodell verwenden, um die größeren VM-Größen zu nutzen, sollten Sie den Wechsel zu D16v3/DS16v3 oder D32v3/DS32v3 in Betracht ziehen. Diese Größen sind für die Ausführung auf Hardware der neuesten Generation konzipiert.

Verwenden Sie das Resource Manager-Bereitstellungsmodell, um sicherzustellen, dass Ihre VM instance auf Hardware isoliert ist, die für einen einzelnen Kunden bestimmt ist? Ziehen Sie dann den Wechsel zu den neuen isolierten VM-Größen in Betracht, E64i_v3 oder E64is_v3, die für die Ausführung auf Hardware der neuesten Generation konzipiert sind.

Neue isolierte VM-Größen jetzt verfügbar

Hintergrundinformationen

Funktionsweise der Zuordnung

Die Azure-Plattform versucht, Rechenzentrumsserver in Cluster zu partitionieren. Normalerweise wird eine Zuordnungsanforderung in mehreren Clustern versucht. Bestimmte Einschränkungen der Zuordnungsanforderung können jedoch dazu führen, dass die Azure-Plattform die Anforderung nur in einem Cluster versucht ("an einen Cluster angeheftet"). Abbildung 1 unten zeigt eine normale Zuordnung, die in mehreren Clustern versucht wird (Cluster 1 bis Cluster n). In Diagramm 2 ist eine Zuordnung an Cluster 2 angeheftet, da dieser Cluster den vorhandenen Clouddienst (CS_1) oder die Vorhandene Verfügbarkeitsgruppe hostet.

Diagramm 1: Versuchter Versuch der Azure-Plattformzuweisung in mehreren Clustern Diagramm 2: Eine Azure-Plattformzuordnung, die an einen Cluster angeheftet ist.

Gründe für Zuordnungsfehler

Wenn eine Zuordnungsanforderung an einen Cluster angeheftet wird, ist die Wahrscheinlichkeit höher, dass keine freien Ressourcen gefunden werden, da der verfügbare Ressourcenpool kleiner ist. Was geschieht, wenn Ihre Zuordnungsanforderung an einen Cluster angeheftet ist, der den angeforderten Ressourcentyp nicht unterstützt? Dann schlägt Ihre Anforderung auch dann fehl, wenn der Cluster über freie Ressourcen verfügt. Abbildung 3 unten zeigt, wo eine angeheftete Zuordnung fehlschlägt, da der einzige Kandidatencluster keine freien Ressourcen hat. Abbildung 4 zeigt, wo eine angeheftete Zuordnung fehlschlägt, da der einzige Kandidatencluster die angeforderte VM-Größe nicht unterstützt, obwohl der Cluster über freie Ressourcen verfügt.

Diagramme von Zuordnungsfehlern sind angeheftete Cluster. Abbildung 3 zeigt, dass keine freien Ressourcen verfügbar sind. Diagramm 4 zeigt, dass die Größe nicht unterstützt wird.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.