Windows-Aktivierung– doppelte Clientcomputer-ID

Wir empfehlen im Allgemeinen die Verwendung von KMS-Servern (Azure Key Management Services), um virtuelle Azure Windows-Computer (VMs) zu aktivieren, auch wenn Azure-Hybridvorteil aktiviert ist. In bestimmten Fällen können Sie jedoch einen selbstgehosteten KMS-Server für die Aktivierung verwenden, da Netzwerkeinschränkungen VMs an der Kommunikation mit Azure KMS-Servern hindern können. In diesem Artikel wird ein Problem mit einer doppelten Clientcomputer-ID behandelt, das auftritt, wenn Sie einen selbstgehosteten KMS-Server für die Windows-Aktivierung verwenden, und bietet eine Lösung.

Hinweis

Dieser Artikel gilt nur, wenn Sie einen selbstgehosteten KMS-Server für die Aktivierung verwenden. Sie gilt nicht, wenn Sie Azure KMS für die Aktivierung verwenden.

Symptome

Wenn Sie einen selbstgehosteten KMS-Server für die Aktivierung verwenden und versuchen, mehrere Windows Server-VMs zu aktivieren, schlägt die Aktivierung nach dem Auswertungszeitraum fehl, und Ihr selbstgehostetem KMS-Server meldet den folgenden Fehler im Bericht über doppelte Clientcomputer-ID:

Der Bericht über doppelte Clientcomputer-ID hilft bei der Identifizierung von Computern in der Umgebung, auf denen Images ausgeführt werden, die vor der Bereitstellung mithilfe des Sysprep-Tools nicht ordnungsgemäß generalisiert wurden.
Hinweis:
- Mehrere Volumenaktivierungsclients mit derselben CMID werden von KMS als einzelner Client gezählt. Wenn dies dazu führt, dass die KMS-Clientanzahl unter den Mindestschwellenwert fällt, schlägt die KMS-Aktivierung in Ihrer Umgebung fehl.

Ursache

  • Die Client Machine ID (CMID) wird während des Sysprep-Prozesses des ursprünglichen Quellimages gelöscht. Wenn der Sysprep-Prozess jedoch mit dem Parameter SkipRearm ausgelöst wird, der auf 1 anstelle des Standardwerts von 0festgelegt ist, wird die CMID nicht gelöscht. In diesem Fall verfügen alle VMs, die aus diesem Image erstellt wurden, über die gleiche CMID.

  • Wenn Sie VMs aus Azure Marketplace erstellen, wurden Azure Marketplace Images für Windows Server generalisiert, wobei der Parameter SkipRearm auf 1festgelegt ist. Daher weisen die VMs, die aus demselben Windows Server-Image erstellt wurden, dieselbe CMID auf.

Doppelte CMID bestätigen

Überprüfen Sie, ob die virtuellen Computer basierend auf dem Quellimage und der Quellversion die gleiche CMID aufweisen:

  1. Führen Sie den folgenden Befehl auf den problematischen virtuellen Computern aus:

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    Hier sehen Sie ein Beispiel für die Befehlsausgabe:

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. Vergleichen Sie die Befehlsausgaben auf den problematischen VMs, und vergewissern Sie sich, ob die VMs über die gleiche CMID verfügen.

Lösung

  • Für die problematischen VMs, die aus einem benutzerdefinierten Image erstellt wurden, generalisieren/sysprep die ursprüngliche VM, wobei der Parameter SkipRearm auf 0 festgelegt ist, um sicherzustellen, dass die CMID aus dem Image gelöscht wird.

  • Führen Sie für die problematischen VMs, die bereits bereitgestellt wurden, die folgenden Schritte aus:

    1. Führen Sie den slmgr /rearm Befehl an einer Eingabeaufforderung mit erhöhten Rechten aus.

    2. Starten Sie den virtuellen Computer neu.

    3. Sobald die VM nach dem Neustart online ist, führen Sie den folgenden Befehl aus, um zu bestätigen, dass die CMID geändert wurde:

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. Lösen Sie die Aktivierung erneut aus.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.