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Gilt für: ✔️ Windows-VMs
Symptome
Der Screenshot des virtuellen Computers (VM) zeigt das Betriebssystem (Betriebssystem) vollständig geladen und wartet auf Anmeldeinformationen.
Wenn Sie die Gastbetriebssystemprotokolle anzeigen, sehen Sie, dass der Kernnetzwerkdienst Network Store Interface (NSI) nicht gestartet wird oder nicht gestartet wird. Dieses Problem kann aufgrund eines Absturzes, eines Absturzes dieses Diensts oder eines erforderlichen Diensts auftreten, bevor er ausgeführt werden kann.
Log Name: System Source: Service Control Manager Date: 12/16/2015 11:19:36 AM Event ID: 7022 Task Category: None Level: Error Keywords: Classic User: N/A Computer: myvm.contoso.net Description: The Network Store Interface service hung on starting.
Log Name: System Source: Service Control Manager Date: 2/25/2016 11:59:08 AM Event ID: 7001 Task Category: None Level: Error Keywords: Classic User: N/A Computer: myvm.contoso.net Description: The DHCP Client service depends on the Network Store Interface service which failed to start because of the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
Log Name: System Source: Service Control Manager Date: 12.08.2016 15:35:22 Event ID: 7000 Task Category: None Level: Error Keywords: Classic User: N/A Computer: myvm.contoso.net Description: The Network Store Interface Service service failed to start due to the following error: The account specified for this service is different from the account specified for other services running in the same process.
Herstellen einer Verbindung mit dem virtuellen Computer mithilfe der seriellen Konsole (Problembehandlung)
Wenn Sie RDP nicht erfolgreich auf den virtuellen Computer (VM) zugreifen können, verwenden Sie PowerShell und serielle Konsole , um nach den Protokolleinträgen zu suchen.
- Starten Sie in der Befehlszeile PowerShell, indem Sie folgendes ausführen
powershell.exe
. - Führen Sie in PowerShell die folgenden Befehle aus:
psCopy
remove-module psreadline
Get-WinEvent -FilterHashtable @{LogName='System'; StartTime=(Get-Date).AddDays(-1); ProviderName='Service Control Manager'}
Ursache
Der NSI-Dienst wird auf dem virtuellen Computer nicht ausgeführt. Dieses Problem tritt in den folgenden Szenarien auf:
- Der NSI-Dienst wurde auf deaktiviert festgelegt.
- Der NSI reagiert nicht oder stürzt ab.
- Ein anderer erforderlicher Dienst wird nicht ausgeführt.
Lösung
Sichern Sie den VM-Betriebssystemdatenträger mithilfe Ihrer bevorzugten Methode.
Eine Methode, die Sie verwenden können, besteht darin, eine Momentaufnahme des Datenträgers zu erstellen.
Herstellen einer Verbindung mit dem virtuellen Computer mithilfe der seriellen Konsole (Lösung)
Stellen Sie mithilfe der seriellen Konsole eine Verbindung mit dem virtuellen Computer her, um zu versuchen, den NSI-Dienst zu starten.
Führen Sie in der seriellen Konsole den folgenden Befehl aus:
sc query NSI
Wenn der Dienst wie folgt angezeigt wird:
Beendet – Versuchen Sie, den Dienst zu starten:
sc start NSI
- Wenn der Dienst ohne Fehler gestartet wird und Sie eine Verbindung mit dem virtuellen Computer herstellen können, beenden Sie hier.
Starten/Beenden – Versuchen Sie, den Dienst erneut mit den folgenden Befehlen zu beenden und zu starten:
sc stop NSI
sc start NSI
Wenn der NSI-Dienst deaktiviert ist:
Legen Sie zuerst den Dienst auf "Automatisch" fest:
sc config NSI start=auto
Starten Sie den NSI-Dienst:
sc start NSI
Überprüfen Sie, ob der NSI-Dienst ausgeführt wird:
sc query NSI
Wenn der NSI-Dienst aufgrund einer Abhängigkeit fehlschlägt, können Sie den obigen Prozess für die aufgeführte Abhängigkeit ausprobieren. Sobald der NSI-Dienst ausgeführt wird, können Sie versuchen, über RDP auf die VM zuzugreifen.
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