Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Gilt für: ✔️ Windows-VMs
Ursprüngliche KB-Nummer: 4010129
Dieser Artikel enthält eine Lösung für ein Problem, bei dem azure VM nicht mit Fehlercode 0xc000000e beginnt.
Symptome
Windows wird nicht gestartet. Stattdessen generiert das System den folgenden Fehler:
Datei: \Windows\system32\winload.exe
Status: 0xC000000E
Informationen: Die Anwendung oder das Betriebssystem konnte nicht geladen werden, da eine erforderliche Datei fehlt oder Fehler enthält.
Ursache
Das Problem tritt auf, wenn in den Startkonfigurationsdaten ein nicht vorhandenes Gerät angegeben ist.
Lösung
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
Führen Sie diese Schritte aus, um das Problem zu beheben:
Schritt 1: Anfügen des Betriebssystemdatenträgers des virtuellen Computers als Datenträger an einen anderen virtuellen Computer
- Löschen Sie den virtuellen Computer (VM). Stellen Sie sicher, dass Sie die Option "Datenträger beibehalten" auswählen, wenn Sie dies tun.
- Fügen Sie den Betriebssystemdatenträger einer anderen VM (VM, auf der Sie die Problembehandlung ausführen) als Datenträger an. Weitere Informationen finden Sie unter Anfügen eines Datenträgers an eine Windows VM im Azure-Portal.
- Stellen Sie eine Verbindung mit der Problembehebungs-VM her. Öffnen Sie Computerverwaltung>Datenträgerverwaltung. Stellen Sie sicher, dass der Betriebssystemdatenträger online ist und dass den Partitionen Laufwerksbuchstaben zugewiesen sind.
- Ermitteln Sie die Startpartition und die Windows-Partition. Falls sich auf dem Betriebssystemdatenträger nur eine einzelne Partition befindet, handelt es sich dabei um die Start- und Windows-Partition.
Wenn der Betriebssystemdatenträger mehr als eine Partition enthält, können Sie diese ermitteln, indem Sie sich die Ordner in den Partitionen ansehen:
Die Windows-Partition enthält einen Ordner namens „Windows“ und ist größer als die anderen.
Die Startpartition enthält einen Ordner namens "Boot". Dieser Ordner ist standardmäßig ausgeblendet. Um den Ordner sichtbar zu machen, müssen Sie die ausgeblendeten Dateien und Ordner einblenden und die Option Geschützte Systemdateien ausblenden (empfohlen) deaktivieren. Die Startpartition hat in der Regel eine Größe von etwa 300 MB bis 500 MB.
Schritt 2: Reparieren der Startkonfigurationsdaten
Führen Sie die folgende Befehlszeile als Administrator aus, und notieren Sie sich den Bezeichner des Windows-Startladeprogramms (nicht zu verwechseln mit dem Windows-Start-Manager). Der Bezeichner ist ein 32-stelliger Code und sieht wie folgt aus: xxxxxxxx-xxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. Sie benötigen diesen Bezeichner im nächsten Schritt.
bcdedit /store <Boot partition>:\boot\bcd /enum /v
Führen Sie die folgenden Befehlszeilen aus, um die Startkonfigurationsdaten zu korrigieren. Ersetzen Sie dabei die Platzhalter durch die tatsächlichen Werte:
Notiz
Dieser Schritt wird auf die meisten Probleme bei der Beschädigung von Startkonfigurationsdaten angewendet. Sie müssen diesen Schritt auch dann ausführen, wenn das Gerät und osDevice auf die richtige Partition zeigen.
<Die Windows-Partition> ist die Partition, die einen Ordner mit dem Namen "Windows" enthält.
<Die Startpartition> ist die Partition, die einen ausgeblendeten Systemordner namens "Boot" enthält.
<Der Bezeichner ist der Bezeichner> des Windows-Startladeprogramms, den Sie im vorherigen Schritt gefunden haben.
bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} device partition=<boot partition>: bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} integrityservices enable bcdedit /store <Boot partition>:\boot\bcd /set {<Identifier>} device partition=<Windows partition>: bcdedit /store <Boot partition>:\boot\bcd /set {<Identifier>} integrityservices enable bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} recoveryenabled Off bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} osdevice partition=<Windows partition>: bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} bootstatuspolicy IgnoreAllFailures
Trennen Sie den Betriebssystemdatenträger von der VM, auf der Sie die Problembehandlung ausführen. Erstellen Sie eine neue VM auf Grundlage des Betriebssystemdatenträgers.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.