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Gilt für: Windows ✔️ VMs
Ursprüngliche KB-Nummer: 4010129
Zusammenfassung
Dieser Artikel bietet eine Lösung für ein Problem, bei dem Azure VM nicht mit Fehlercode 0xc000000e beginnt.
Symptome
Windows wird nicht gestartet. Stattdessen generiert das System den folgenden Fehler:
Datei: \Windows\system32\winload.exe
Status: 0xC000000E
Informationen: Die Anwendung oder das Betriebssystem konnte nicht geladen werden, da eine erforderliche Datei fehlt oder Fehler enthält.
Ursache
Das Problem tritt auf, wenn in den Startkonfigurationsdaten ein nicht vorhandenes Gerät angegeben ist.
Lösung
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
Führen Sie diese Schritte aus, um das Problem zu beheben:
Schritt 1: Anfügen des Betriebssystemdatenträgers des virtuellen Computers als Datenträger an einen anderen virtuellen Computer
- Löschen Sie den virtuellen Computer (VM). Stellen Sie sicher, dass Sie die Option "Datenträger beibehalten" auswählen, wenn Sie dies tun.
- Befestigen Sie den Betriebssystemdatenträger als Datenträger an einer anderen VM, auf der Sie die Fehlerbehebung ausführen. Weitere Informationen finden Sie unter Wie sie einen Datenträger an eine Windows VM im Azure-Portal anfügen.
- Stellen Sie eine Verbindung mit der Problembehebungs-VM her. Öffnen Sie Computerverwaltung>Datenträgerverwaltung. Stellen Sie sicher, dass der Betriebssystemdatenträger online ist und dass den Partitionen Laufwerksbuchstaben zugewiesen sind.
- Identifizieren Sie die Startpartition und die Windows Partition. Wenn nur eine Partition auf dem Betriebssystemdatenträger vorhanden ist, ist diese Partition die Startpartition und die Windows Partition.
Wenn der Betriebssystemdatenträger mehr als eine Partition enthält, können Sie diese ermitteln, indem Sie sich die Ordner in den Partitionen ansehen:
Die Windows Partition enthält einen Ordner mit dem Namen "Windows", und diese Partition ist größer als die anderen.
Die Startpartition enthält einen Ordner namens "Boot". Dieser Ordner ist standardmäßig ausgeblendet. Um den Ordner sichtbar zu machen, müssen Sie die ausgeblendeten Dateien und Ordner einblenden und die Option Geschützte Systemdateien ausblenden (empfohlen) deaktivieren. Die Startpartition hat in der Regel eine Größe von etwa 300 MB bis 500 MB.
Schritt 2: Reparieren der Startkonfigurationsdaten
Führen Sie die folgende Befehlszeile als Administrator aus, und notieren Sie dann den Bezeichner des Windows Startladeprogramms (nicht Windows Start-Manager). Der Bezeichner ist ein 32-stelliger Code und sieht wie folgt aus: xxxxxxxx-xxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. Sie benötigen diesen Bezeichner im nächsten Schritt.
bcdedit /store <Boot partition>:\boot\bcd /enum /vFühren Sie die folgenden Befehlszeilen aus, um die Startkonfigurationsdaten zu korrigieren. Ersetzen Sie dabei die Platzhalter durch die tatsächlichen Werte:
Notiz
Dieser Schritt wird auf die meisten Probleme bei der Beschädigung von Startkonfigurationsdaten angewendet. Sie müssen diesen Schritt auch dann ausführen, wenn das Gerät und osDeviceauf die richtige Partition zeigen.
<Windows partition> ist die Partition, die einen Ordner mit dem Namen "Windows" enthält.
<Die Startpartition> ist die Partition, die einen ausgeblendeten Systemordner namens "Boot" enthält.
<Identifier> ist der Bezeichner des Windows Startladeprogramms, das Sie im vorherigen Schritt gefunden haben.
bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} device partition=<boot partition>: bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} integrityservices enable bcdedit /store <Boot partition>:\boot\bcd /set {<Identifier>} device partition=<Windows partition>: bcdedit /store <Boot partition>:\boot\bcd /set {<Identifier>} integrityservices enable bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} recoveryenabled Off bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} osdevice partition=<Windows partition>: bcdedit /store <Boot partition>:\boot\bcd /set {<identifier>} bootstatuspolicy IgnoreAllFailuresTrennen Sie den Betriebssystemdatenträger von der VM, auf der Sie die Problembehandlung ausführen. Erstellen Sie eine neue VM auf Grundlage des Betriebssystemdatenträgers.