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Gilt für: ✔️ Windows-VMs
In diesem Artikel wird beschrieben, wie eine falsch konfigurierte Gastbetriebssystem-Firewall der Azure-VM repariert wird.
Symptome
Die Willkommensseite des virtuellen Computers (VM) zeigt, dass der virtuelle Computer vollständig geladen wurde.
Je nachdem, wie das Gastbetriebssystem konfiguriert ist, könnte der Netzwerkdatenverkehr teilweise oder gar nicht den virtuellen Computer erreichen.
Ursache
Eine fehlerhafte Konfiguration der Gastbetriebssystem-Firewall kann den Netzwerkdatenverkehr mit dem virtuellen Computer teilweise oder völlig blockieren.
Lösung
Erstellen Sie eine Momentaufnahme des Systemdatenträgers des betroffenen virtuellen Computers als Sicherung, bevor Sie die unten angegebenen Schritte ausführen. Weitere Informationen finden Sie unter Erstellen einer Momentaufnahme eines Datenträgers.
Verwenden Sie zum Beheben dieses Problems die serielle Konsole, oder reparieren Sie den virtuellen Computer offline, indem Sie den Systemdatenträger des virtuellen Computers an einen virtuellen Wiederherstellungscomputer anfügen.
Vorbeugende Maßnahmen online
Stellen Sie eine Verbindung mit der seriellen Konsole her, und öffnen Sie eine PowerShell-Instanz. Ist die serielle Konsole auf Ihrem virtuellen Computer nicht aktiviert, gehen Sie zum Abschnitt „Reparieren des virtuellen Computers im Offlinestatus“ des folgenden Azure-Artikels:
Die folgenden Regeln können bearbeitet werden, um entweder den Zugriff auf den virtuellen Computer (über RDP) zu aktivieren oder eine einfachere Problembehandlung zu ermöglichen:
Remotedesktop (TCP-In): Dies ist die Standardregel, die primären Zugriff auf den virtuellen Computer bietet, indem RDP in Azure zugelassen wird.
Windows-Remoteverwaltung (HTTP-In): Mit dieser Regel können Sie die Verbindung mit dem virtuellen Computer mithilfe von PowerShell herstellen. In Azure können Sie mit dieser Art von Zugriff den Skripterstellungsaspekt von Remoteskripterstellung und Problembehandlung verwenden.
Datei- und Druckerfreigabe (SMB-In): Diese Regel aktiviert den Zugriff auf die Netzwerkfreigabe als Option zur Fehlerbehandlung.
Datei- und Druckerfreigabe (Echoanforderung - ICMPv4-In): Mit dieser Regel können Sie die VM anpingen.
In der Instanz „Zugriff auf die serielle Konsole“ können Sie den aktuellen Status der Firewallregel abfragen.
Verwenden Sie bei der Abfrage den Anzeigenamen als Parameter:
netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(DisplayName.*<FIREWALL RULE NAME>)" -context 9,4 | more
Verwenden Sie bei der Abfrage den von der Anwendung genutzten lokalen Port:
netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(LocalPort.*<APPLICATION PORT>)" -context 9,4 | more
Verwenden Sie bei der Abfrage die von der Anwendung genutzte lokale IP-Adresse:
netsh advfirewall firewall show rule dir=in name=all | select-string -pattern "(LocalIP.*<CUSTOM IP>)" -context 9,4 | more
Wenn Sie sehen, dass die Regel deaktiviert ist, können Sie sie aktivieren, indem Sie den folgenden Befehl ausführen:
netsh advfirewall firewall set rule name="<RULE NAME>" new enable=yes
Zur Problembehandlung können Sie die Firewallprofile auf OFF setzen:
netsh advfirewall set allprofiles state off
Aktivieren Sie in diesem Fall die Firewall nach Abschluss der Problembehandlung erneut, um sie ordnungsgemäß einzurichten.
Notiz
Sie müssen den virtuellen Computer nicht neu starten, um diese Änderungen zu übernehmen.
Versuchen Sie erneut, eine Verbindung mit dem virtuellen Computer über RDP herzustellen.
Vorbeugende Maßnahmen offline
Informationen zum Aktivieren und Deaktivieren der Firewallregeln finden Sie unter Aktivieren oder Deaktivieren einer Firewallregel unter einem Gastbetriebssystem in Azure VM.
Überprüfen Sie, ob folgendes Szenario vorliegt: Gastbetriebssystem-Firewall blockiert eingehenden Datenverkehr.
Wenn Sie sich noch nicht sicher sind, ob die Firewall den Zugriff blockiert, handeln Sie gemäß Deaktivieren der Gastbetriebssystem-Firewall auf der Azure-VM, und aktivieren Sie dann die Gastbetriebssystem-Firewall erneut mithilfe der richtigen Regeln.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.