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Melden Sie sich nicht bei Ihrem Konto an, wenn Sie versuchen, eine Verbindung mit einer Azure Windows-VM herzustellen.

Gilt für: ✔️ Windows-VMs

In diesem Artikel wird erläutert, wie Sie den Fehler "Wir können uns nicht bei Ihrem Konto anmelden" beheben, wenn Sie versuchen, eine Verbindung mit einer Azure Windows-VM mithilfe des Remotedesktopprotokolls (RDP) herzustellen.

Symptome

Wenn Sie versuchen, die Windows-VM mit RDP zu verbinden, wird die folgende Fehlermeldung angezeigt:

Wir können uns nicht bei Ihrem Konto anmelden.
Dieses Problem kann häufig behoben werden, indem Sie sich von Ihrem Konto abmelden und sich dann wieder anmelden. Wenn Sie sich jetzt nicht abmelden, gehen alle Von Ihnen erstellten Dateien oder Änderungen verloren.

Im Anwendungsereignisprotokoll wird die Ereignis-ID 1511 für jeden RDP-Verbindungsversuch protokolliert.

ID: 1511
Ebene: Fehler
Quelle: Microsoft-Windows-User Profiles Service
Computer: RDPDemo.contoso.net
Meldung: Windows kann das lokale Profil nicht finden und protokolliert Sie mit einem temporären Profil. Änderungen, die Sie an diesem Profil vornehmen, gehen verloren, wenn Sie sich abmelden.

Ursache

Das Problem kann auftreten, wenn das lokale Profil des Benutzers beschädigt ist und Windows kein neues lokales Profil für die RDP-Sitzung erstellen kann.

Lösung

Bevor Sie mit einem der Lösungsvorgänge in diesem Dokument beginnen, sollten Sie den Betriebssystemdatenträger Ihrer VM sichern, indem Sie eine Momentaufnahme erstellen. Falls Sie während der Problembehandlung vorgenommene Änderungen rückgängig machen müssen, können Sie die Momentaufnahme nutzen, um den Datenträger neu zu erstellen.

Onlinereparatur über die serielle Azure-Konsole

  1. Stellen Sie über die serielle Azure-Konsole eine Verbindung mit der VM her, und starten Sie dann eine PowerShell-Sitzung. Stellen Sie per Remote-PowerShell eine Verbindung mit der VM her, falls die serielle Azure-Konsole nicht funktioniert. Weitere Informationen finden Sie unter Verwenden von Remotetools zur Behandlung von Azure-VM-Problemen.

  2. Führen Sie nach der Verbindungsherstellung mit der VM den folgenden Befehl aus, um die Benutzerprofileinträge aufzulisten. Suchen Sie nach allen Profilen mit der Erweiterung „.bak“ am Ende des Namens.

    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList" /s | more
    
  3. Identifizieren Sie den Profileintrag für den betroffenen Benutzer, indem Sie den Wert für den Schlüssel "ProfileImagePath" betrachten.

  4. Entfernen Sie den Sicherungseintrag für das Benutzerprofil für den betroffenen Benutzer (endet mit ".bak"), entfernen Sie keine Einträge für die integrierten Systemkonten S-1-5-18, S-1-5-19 und S-1-5-20:

    reg delete "HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList\<GUID>.bak"
    
  5. Versuchen Sie, eine Verbindung mit der VM herzustellen, und prüfen Sie, ob das Problem behoben wurde.

  6. Wenn das Problem weiterhin auftritt, können Sie versuchen, den Benutzerprofileintrag für den betroffenen Benutzer zu entfernen.

Offlinereparatur

Wenn Sie über die serielle Azure-Konsole oder andere Remotetools nicht auf die VM zugreifen können, muss die Reparatur im Offlinemodus durchgeführt werden.

  1. Führen Sie unter Reparieren virtueller Azure-Computer die Schritte 1 bis 3 aus, um eine Reparatur-VM zu erstellen. Auf der Reparatur-VM wird automatisch ein kopierter Betriebssystemdatenträger der fehlerhaften VM bereitgestellt. Normalerweise wird der Datenträger als Laufwerk F angefügt.
  2. Stellen Sie eine Verbindung mit der Reparatur-VM her.
  3. Starten Sie auf der Reparatur-VM den Registrierungs-Editor (regedit.exe). Wählen Sie den Schlüssel HKEY_LOCAL_MACHINE und dann im Menü die Optionen Datei>Struktur laden aus. Suchen und laden Sie die SOFTWAREstrukturdatei im Ordner "F:\Windows\System32\config", und geben Sie "RepairSOFTWARE" als Namen für die Struktur ein.
  4. Navigieren Sie zu RepairSOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.
  5. Identifizieren Sie den Profileintrag für den betroffenen Benutzer, indem Sie den Wert für den Schlüssel "ProfileImagePath" betrachten.
  6. Entfernen Sie den Sicherungseintrag für das Benutzerprofil für den betroffenen Benutzer (endet mit ".bak"), entfernen Sie keine Einträge für die integrierten Systemkonten S-1-5-18, S-1-5-19 und S-1-5-20.
  7. Führen Sie Schritt 5 des VM-Reparaturprozesses aus, um den reparierten Betriebssystemdatenträger auf der fehlerhaften VM bereitzustellen.
  8. Starten Sie die fehlerhafte VM, und versuchen Sie, per RDP eine Verbindung mit der VM herzustellen. Wenn das Problem weiterhin auftritt, können Sie versuchen, den Benutzerprofileintrag für den betroffenen Benutzer zu entfernen.

Nächste Schritte

Suchen Sie in den Azure-Foren bei MSDN und Stack Overflow, falls Sie Ihr Azure-Problem mit diesem Artikel nicht beheben konnten. Sie können Ihr Problem in diesen Foren oder an @AzureSupport auf Twitter posten. Sie können auch eine Azure-Supportanfrage senden.

Um eine Supportanfrage zu senden, wechseln Sie zur Azure-Support Seite, und wählen Sie "Support anfordern" aus.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.