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Gilt für: ✔️ Windows-VMs
Dieser Artikel bietet Unterstützung bei der Problemlösung, wenn Sie keine Verbindung mit einem virtuellen Azure-Computer (Azure-VM) herstellen können, weil kein Remotedesktop-Lizenzserver zum Bereitstellen einer Lizenz verfügbar ist.
Symptome
Wenn Sie versuchen, eine Verbindung mit einem virtuellen Computer herzustellen, beobachten Sie dieses Verhalten:
Der VM-Screenshot zeigt, dass das Betriebssystem vollständig geladen ist und auf Anmeldeinformationen wartet.
Sie erhalten die folgenden Fehlermeldungen, wenn Sie versuchen, eine Microsoft RDP-Verbindung (Remotedesktopprotokoll) herzustellen:
Die Remotesitzung wurde getrennt, weil kein Remotedesktop-Lizenzserver zum Bereitstellen einer Lizenz verfügbar ist.
Es ist kein Remotedesktop-Lizenzserver verfügbar. Die Remotedesktopdienste werden beendet, weil die Karenzzeit für diesen Computer abgelaufen ist und der Computer nicht mindestens einen gültigen Windows Server 2008-Lizenzserver kontaktiert hat. Wählen Sie diese Meldung aus, um die RD-Sitzungshost-Serverkonfiguration für eine Lizenzierungsdiagnose zu öffnen.
Beim Verbindungsversuch des Clients ist ein Lizenzierungsfehler aufgetreten (Zeitüberschreitung bei der Lizenzierung). Bitte versuchen Sie erneut, eine Verbindung zum Remote-Computer herzustellen.
Die RDP-Verbindung scheint im Status „Remotesitzung wird konfiguriert“ festzuhängen.
Ursache
Dieses Problem tritt auf, wenn kein Remotedesktop-Lizenzserver verfügbar ist, um eine Lizenz zum Starten einer Remotesitzung bereitzustellen. Es gibt verschiedene Ursachen, selbst wenn eine Remotedesktop-Sitzungshostrolle auf der VM eingerichtet wurde:
- Es war nie eine Remotedesktop-Lizenzierungsrolle in der Umgebung vorhanden, und die Karenzzeit (180 Tage) ist abgelaufen.
- In der Umgebung wurde eine Remotedesktoplizenz installiert, aber nie aktiviert.
- Es ist eine Remotedesktoplizenz mit CALs (Client Access Licenses) vorhanden, und diese wurde aktiviert. Es gibt jedoch mehr aktive Benutzer als verfügbare CALs.
- Eine in der Umgebung vorhandene Remotedesktoplizenz umfasst keine CALs zum Einrichten der Verbindung.
- In der Umgebung wurde eine Remotedesktoplizenz installiert. Es sind CALs verfügbar, aber sie wurden nicht ordnungsgemäß konfiguriert.
- Es ist eine Remotedesktoplizenz mit CALs vorhanden, und diese wurde aktiviert. Probleme auf dem Remotedesktop-Lizenzserver verhindern jedoch, dass Lizenzen in der Umgebung bereitgestellt werden.
Lösung
Um dieses Problem zu lösen erstellen Sie eine Sicherung des Betriebssystemdatenträgers und führen die folgenden Schritte aus:
Stellen Sie über eine administrative Sitzung eine Verbindung mit der VM her. Wenden Sie hierzu eine der folgenden Methoden an:
Führen Sie den folgenden Befehl aus:
mstsc /v:<Server>[:<Port>] /admin
Wechseln Sie im Azure-Portal zum virtuellen Computer, und wählen Sie unter "Einstellungen" die Option "Verbinden" aus. Wählen Sie im rechten Fensterbereich RDP-Datei herunterladen, um eine Verbindungsdatei herunterzuladen.
Wenn es nicht möglich ist, über eine Verwaltungssitzung eine Verbindung mit der VM herzustellen, können Sie die serielle Konsole für VMs in Azure für den Zugriff auf die VM verwenden:
Greifen Sie auf die serielle Konsole zu, indem Sie Support und Problembehandlung>Serielle Konsole auswählen. Wenn dieses Feature auf der VM aktiviert ist, können Sie erfolgreich eine Verbindung mit der VM herstellen.
Erstellen Sie einen neuen Kanal für eine CMD-Instanz. Geben Sie CMD ein, um den Kanal zu starten und den Kanalnamen abzurufen.
Wechseln Sie zu dem Kanal, in dem die CMD-Instanz ausgeführt wird. In diesem Fall ist das Kanal 1:
ch -si 1
Drücken Sie erneut die EINGABETASTE, und geben Sie einen gültigen Benutzernamen, ein Kennwort sowie eine lokale oder Domänen-ID für die VM ein.
Überprüfen Sie, ob für die VM eine Remotedesktop-Sitzungshostrolle aktiviert ist. Wenn die Rolle aktiviert ist, überprüfen Sie, ob sie ordnungsgemäß funktioniert. Öffnen Sie eine CMD-Instanz mit erhöhten Rechten, und führen Sie diese Schritte aus:
Verwenden Sie den folgenden Befehl, um den Status der Remotedesktop-Sitzungshostrolle zu überprüfen:
reg query "HKLM\SOFTWARE\Microsoft\ServerManager\ServicingStorage\ServerComponentCache\RDS-RD-Server" /v InstallState
Wenn dieser Befehl den Wert 0 zurückgibt, ist die Rolle deaktiviert, und Sie können mit Schritt 3 fortfahren.
Verwenden Sie den folgenden Befehl, um die Richtlinien zu überprüfen und ggf. neu zu konfigurieren:
reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode reg query "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers
Wenn der LicensingMode-Wert auf einen anderen Wert als 4 pro Benutzer festgelegt ist, legen Sie den Wert auf 4 fest:
reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core" /v LicensingMode /t REG_DWORD /d 4
Wenn der SpecifiedLicenseServers-Wert nicht vorhanden ist oder über falsche Lizenzserverinformationen verfügt, nehmen Sie die folgenden Änderungen vor:
reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "<FQDN / IP License server>"
Starten Sie die VM neu, nachdem Sie Änderungen an der Registrierung vorgenommen haben.
Wenn Sie keine CALs haben oder nicht mehr als zwei gleichzeitige Benutzer benötigen, entfernen Sie die Rolle Remotedesktop-Sitzungshost. Daraufhin wird RDP wieder so eingestellt, dass nur zwei gleichzeitige RDP-Verbindungen zur VM möglich sind:
dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services
Wenn die VM über die Lizenzierungsrolle Remotedesktop verfügt und diese nicht verwendet wird, können Sie die Rolle auch entfernen:
dism /ONLINE /Disable-feature /FeatureName:Licensing
Stellen Sie sicher, dass die VM eine Verbindung mit dem Remotedesktop-Lizenzserver herstellen kann. Sie können die Konnektivität mit Port 135 zwischen der VM und dem Lizenzserver testen:
telnet <FQDN / IP License Server> 135
Wenn kein Remotedesktop-Lizenzserver in der Umgebung vorhanden ist und Sie einen solchen Lizenzserver verwenden möchten, können Sie einen Remotedesktop-Lizenzierungsrollendienst installieren. Konfigurieren Sie die RDS-Lizenzierung im Anschluss.
Wenn ein Remotedesktop-Lizenzserver konfiguriert ist und fehlerfrei arbeitet, stellen Sie sicher, dass der Remotedesktop-Lizenzserver mit Clientzugriffslizenzen (CALs) aktiviert ist.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.