Freigeben über


Fehler beim Importieren einer SSL-PFX-Datei in den persönlichen Zertifikatspeicher des lokalen Computers mithilfe des IIS-Managers

Dieser Artikel hilft Ihnen, einen Fehler zu beheben, der auftritt, wenn Sie versuchen, eine SSL-Datei (Secure Sockets Layer) mit privatem Schlüsselzertifikat (.pfx) in den persönlichen Zertifikatspeicher des lokalen Computers zu importieren, indem Sie Microsoft-Internetinformationsdienste (IIS)-Manager verwenden.

Ursprüngliche Produktversion: Internetinformationsdienste
Ursprüngliche KB-Nummer: 919074

Wichtig

Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie unter Windows-Registrierungsinformationen für erweiterte Benutzer.

Problembeschreibung

Sie versuchen, eine SSL-PFX-Datei in den persönlichen Zertifikatspeicher des lokalen Computers zu importieren. In dieser Situation können Sie eines der folgenden Symptome feststellen, je nachdem, wie Sie versuchen, die PFX-Datei zu importieren:

  • Wenn Sie versuchen, die PFX-Datei mithilfe des IIS-Managers zu importieren, wird die folgende Fehlermeldung angezeigt:

    Pfx-Datei kann nicht importiert werden. Sie haben entweder ein falsches Kennwort für diese Datei eingegeben, oder das Zertifikat ist abgelaufen.

  • Wenn Sie versuchen, die PFX-Datei mithilfe des MMC-Snap-Ins (Certificates Microsoft Management Console) zu importieren, wird die folgende Fehlermeldung angezeigt:

    Interner Fehler. Dies kann entweder der Zugriff auf das Benutzerprofil sein, oder der private Schlüssel, den Sie importieren, erfordert möglicherweise einen kryptografischen Dienstanbieter, der nicht auf Ihrem System installiert ist.

Ursache

Dieses Verhalten tritt auf, wenn mindestens eine der folgenden Bedingungen zutrifft:

  • Sie verfügen über unzureichende Berechtigungen für den Zugriff auf den DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys Ordner auf dem Computer.
  • Ein Registrierungsunterschlüssel eines Drittanbieters ist vorhanden, der verhindert, dass IIS auf den Kryptografiedienstanbieter zugreift.
  • Sie sind remote über eine Terminaldienstesitzung am Computer angemeldet. Und das Benutzerprofil wird nicht lokal auf dem Server gespeichert, auf dem Terminaldienste aktiviert sind.

Um dieses Verhalten zu beheben, verwenden Sie eine der folgenden Auflösungen, wie sie für Ihre Situation geeignet sind.

Lösung 1: Festlegen der richtigen Berechtigungen für den Ordner "MachineKeys"

Wenn Sie über unzureichende Berechtigungen für den Zugriff auf den DriveLetter:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys Ordner auf dem Computer verfügen, legen Sie die richtigen Berechtigungen für den Ordner fest.

Weitere Informationen zum Festlegen der Berechtigungen für den Ordner "MachineKeys" finden Sie unter "Standardberechtigungen" für die Ordner "MachineKeys".

Lösung 2: Löschen des Registrierungsunterschlüssels eines Drittanbieters

Warnung

Schwerwiegende Probleme können auftreten, wenn die Registrierung mit dem Registrierungs-Editor oder einer anderen Methode unsachgemäß bearbeitet wird. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko.

Wenn der folgende Registrierungsunterschlüssel vorhanden ist, löschen Sie ihn:
HKEY_USERS\Default\Software\Microsoft\Cryptography\Providers\Type 001

Nachdem Sie diesen Registrierungsunterschlüssel gelöscht haben, kann IIS auf den Kryptografiedienstanbieter zugreifen.

Lösung 3: Lokales Speichern des Benutzerprofils für Terminaldienste-Sitzung

Wenn das Benutzerprofil für die Terminaldienste-Sitzung nicht lokal auf dem Server gespeichert ist, auf dem Terminaldienste aktiviert sind, verschieben Sie das Benutzerprofil auf den Server, auf dem Terminaldienste aktiviert sind. Alternativ können Sie Roamingprofile verwenden.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.