Die Fehlermeldung "Die [Lösungsname] verfügt nicht über ein Upgrade, das angewendet werden kann" wird in Microsoft Dynamics 365
Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie eine Lösung in Dynamics 365 und dann die Schaltfläche Lösungsupgrade anwenden auswählen.
Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 4457858
Symptome
Wenn Sie in Dynamics 365 eine Lösung auswählen und dann die Schaltfläche Lösungsupgrade anwenden auswählen, wird die folgende Fehlermeldung angezeigt:
"Aktion nicht verfügbar.
Die Lösung [Lösungsname] verfügt nicht über ein Upgrade, das angewendet werden kann."
Wenn Sie Protokolldatei herunterladen auswählen, enthält die Protokolldatei einen Verweis auf den Fehlercode -2147187397.
Ursache
Diese Meldung wird angezeigt, wenn für die ausgewählte Lösung kein Lösungsupgrade angewendet werden muss.
Die Schaltfläche Lösungsupgrade anwenden soll verwendet werden, wenn Sie ein Update für eine andere Lösung importiert haben, die bereits installiert ist. Beim Importieren der aktualisierten Projektmappe wird die Option Phase für Upgrades angezeigt. Wenn dieses Kontrollkästchen aktiviert ist, wird die Upgradeaktion während des Projektmappenimports nicht ausgeführt. Am Ende des Importvorgangs wird die Schaltfläche Lösungsupgrade anwenden angezeigt. Wenn Sie diese Schaltfläche nicht ausgewählt haben, finden Sie die übergeordnete Lösung in der Lösungsliste und wählen dann Lösungsupgrade anwenden aus.
Lösung
Verwenden Sie die Schaltfläche Projektmappenupgrade anwenden nur, wenn Sie ein Update für eine bereits installierte Lösung importiert und die Option Phase für Upgrade ausgewählt haben.